Session restore profile takes time/memory to be saved to disk.

RESOLVED WORKSFORME

Status

()

Firefox
Session Restore
RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: Clément Lefèvre, Unassigned)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8598262 [details]
memory-report.tgz

MacOS freeze from time to time.  This might be related to the fact that the session restore tab takes ~100MB on its own.

A thing which does not appear in the anonymized profile is that the session restore string appears multiple times.

The reason of the freeze is caused by the fact that Firefox suddenly jump from 2GB to 10GB (until reboot / killing firefox), which cause the system to compress the RAM. Knowing that the biggest source of memory consumption is caused by the session restore tab, I presume that this might be related to the fact that the tabs are saved to the disk.

Is there a way to investigate this issue, knowing that I cannot spawn a new program to investigate this issue when the system is highly loaded, and that I have to kill firefox to keep a running system?

I noticed this issue since Firefox 36.  Is there, by chance, any modification which might be related?
Nicholas, how do you suggest investigating this?
Flags: needinfo?(n.nethercote)
Memory reports from about:memory is the obvious place to start.
Flags: needinfo?(n.nethercote)
So, I see 245Mb of strings in SessionWorker.js, but nothing about the session restore tab. Clément, am I missing something?
Flags: needinfo?(clement.lefevre)
As a side-note, we apparently experience complete system freezes on MacOS X for graphics-related reasons. I just experienced one without any memory pressure involved.
(Reporter)

Comment 5

2 years ago
So, closing as WFM for now: having lost my "recursive" session restore some times ago, I couldn't reproduce the problem anymore excepted maybe by recreating tons of tabs and crashed sessions.

Let's see if the situation comes again in the future.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(clement.lefevre)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.