WebIDE fails to launch simulator on OpenSUSE

RESOLVED FIXED in Firefox 38.0.5

Status

--
major
RESOLVED FIXED
4 years ago
6 months ago

People

(Reporter: andre, Assigned: jryans)

Tracking

37 Branch
Firefox 40
x86_64
Linux

Firefox Tracking Flags

(firefox37 wontfix, firefox38 wontfix, firefox38.0.5 fixed, firefox39 fixed, firefox40 fixed, firefox-esr38 fixed)

Details

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8598362 [details]
Log from the Browser Console

Both Firefox 37 and Nightly can't start any simulator using WebIDE on OpenSUSE Tumbleed (rolling release version). All simulators and both the ADB and the DevTools add-ons are installed.

I've added the ADB logging settings to about:config and attached what happened in the browser console to this bug.

I don't have SELinux, AppArmor or a Firewall configured on this machine. I originally thought that something was killing the B2G process but apparently it is something else.

While I was trying to debug this I saw the same thing happening to a friend who was using arch linux x86_64 as well.
(Assignee)

Updated

4 years ago
Attachment #8598362 - Attachment mime type: text/x-log → text/plain
(Assignee)

Comment 1

4 years ago
I attempted to use the OpenSUSE Tumbleweed live CD[1] to reproduce this.

However, it seems to not support the mouse of my VM (VMware Fusion), so I was not able to proceed.

Is there a different live CD I should try?

[1]: http://download.opensuse.org/tumbleweed/iso/openSUSE-Tumbleweed-GNOME-Live-x86_64-Current.iso
Flags: needinfo?(andre)
(Reporter)

Comment 2

4 years ago
The rolling release might not have support for your VM. I've only tried it with Virtualbox and it worked for me. I think that the non-rolling release might help:

http://mirror.rackcentral.com.au/opensuse/distribution/13.2/iso/openSUSE-13.2-GNOME-Live-x86_64.iso
Flags: needinfo?(andre)
(Assignee)

Comment 3

4 years ago
(In reply to andre from comment #2)
> The rolling release might not have support for your VM. I've only tried it
> with Virtualbox and it worked for me. I think that the non-rolling release
> might help:
> 
> http://mirror.rackcentral.com.au/opensuse/distribution/13.2/iso/openSUSE-13.
> 2-GNOME-Live-x86_64.iso

Okay, great!  I was able to reproduce the issue with this live CD and updating to Firefox 37.0.2.
Assignee: nobody → jryans
Status: NEW → ASSIGNED
(Assignee)

Updated

4 years ago
See Also: → bug 1159006
(Assignee)

Comment 4

4 years ago
Can you test the following Firefox build?  For me, it resolves the issue.

http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/jryans@gmail.com-2cfcfa1d5b57/try-linux64/firefox-40.0a1.en-US.linux-x86_64.tar.bz2
Flags: needinfo?(andre)
(Reporter)

Comment 5

4 years ago
I can confirm it working in here. Thanks a lot for the fix.
Flags: needinfo?(andre)
(Assignee)

Updated

4 years ago
See Also: bug 1159006
(Assignee)

Updated

4 years ago
Duplicate of this bug: 1159006
(Assignee)

Updated

4 years ago
status-firefox37: --- → wontfix
status-firefox38: --- → affected
status-firefox39: --- → affected
status-firefox40: --- → affected
status-firefox-esr38: --- → affected
(Assignee)

Comment 7

4 years ago
Created attachment 8599015 [details] [diff] [review]
0001-Bug-1159083-Pass-XAUTHORITY-to-Linux-simulators.-r-j.patch

Jan, it seems it became necessary to pass along XAUTHORITY for simulators to launch on Linux.  I really don't follow what caused this to suddenly matter when it did not before... but in any case, it seems to resolve the issue.

I'll attempt to land in 38 - 40.  Luckily we don't have to update the simulator add-ons to fix it, thanks to your work! :D

Try: https://treeherder.mozilla.org/#/jobs?repo=try&revision=2cfcfa1d5b57
Attachment #8599015 - Flags: review?(janx)
(Reporter)

Comment 8

4 years ago
Since this bug was happening on OpenSUSE and Arch Linux but not on Ubuntu I am guessing that there is a chance that the new behavior is due to those distros migration to systemd & friends. At least this is the only thing I can see that is really different from the two sets of distros. I have no idea why systemd stuff would prevent some userland app from launching though...

Comment 9

4 years ago
@andre ubuntu 15.04 (from last week) is the first version also using systemd. and yes, this bug is repro there.
Comment on attachment 8599015 [details] [diff] [review]
0001-Bug-1159083-Pass-XAUTHORITY-to-Linux-simulators.-r-j.patch

Wow, I'm glad we were able to fix it this quickly. Thanks!
Attachment #8599015 - Flags: review?(janx) → review+
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/81455ec95c0a
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
status-firefox40: affected → fixed
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 40
(Assignee)

Comment 14

4 years ago
Comment on attachment 8599015 [details] [diff] [review]
0001-Bug-1159083-Pass-XAUTHORITY-to-Linux-simulators.-r-j.patch

Approval Request Comment
[Feature/regressing bug #]: It appears changes to new Linux OSes require a change to Firefox and the way Simulators are launched.
[User impact if declined]: Simulators won't start on newer Linux OSes
[Describe test coverage new/current, TreeHerder]: On m-c
[Risks and why]: Low, only affects WebIDE and simulators
[String/UUID change made/needed]: None
Attachment #8599015 - Flags: approval-mozilla-beta?
Attachment #8599015 - Flags: approval-mozilla-aurora?
Comment on attachment 8599015 [details] [diff] [review]
0001-Bug-1159083-Pass-XAUTHORITY-to-Linux-simulators.-r-j.patch

Too late for 38.0 but taking it for 38.0.5.
If you think it matters, we could take it for the first esr (38.1.0).
Attachment #8599015 - Flags: approval-mozilla-beta?
Attachment #8599015 - Flags: approval-mozilla-beta+
Attachment #8599015 - Flags: approval-mozilla-aurora?
Attachment #8599015 - Flags: approval-mozilla-aurora+
status-firefox38: affected → wontfix
status-firefox38.0.5: --- → affected
(Assignee)

Comment 18

4 years ago
Comment on attachment 8599015 [details] [diff] [review]
0001-Bug-1159083-Pass-XAUTHORITY-to-Linux-simulators.-r-j.patch

[Approval Request Comment]
If this is not a sec:{high,crit} bug, please state case for ESR consideration:
User impact if declined: It appears changes to new Linux OSes require a change to Firefox and the way Simulators are launched.  Simulators won't start on newer Linux OSes.
Fix Landed on Version: 40, in m-c
Risk to taking this patch (and alternatives if risky): Low, only affects WebIDE and simulators
String or UUID changes made by this patch: None

See https://wiki.mozilla.org/Release_Management/ESR_Landing_Process for more info.
Attachment #8599015 - Flags: approval-mozilla-esr38?

Comment 19

4 years ago
This bug did occur for me in 14.10, most likely with 36 or 37. It was also a nearly fresh install of Ubuntu when the bug occurred for me, so was likely not caused by other programs. I can't go back and test now, as I have upgraded to 15.04.
Attachment #8599015 - Flags: approval-mozilla-esr38? → approval-mozilla-esr38+
(Assignee)

Updated

4 years ago
Duplicate of this bug: 1031100

Updated

6 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.