[FFOS7715 v2.1][Message] There is no draft record in sms app saved from setting app.

RESOLVED DUPLICATE of bug 1058459

Status

Firefox OS
Gaia::SMS
--
major
RESOLVED DUPLICATE of bug 1058459
3 years ago
3 years ago

People

(Reporter: Wei Gao (Spreadtrum), Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [sprd 430709])

(Reporter)

Description

3 years ago
OS version
---------------------------------------------
FireFoxOS v2.1

Reproduce steps:
---------------------------------------------
1. open sms app from homescreen, and then click home button, put sms app to background.
2. Settings > Sound > Manage Tones, share any ringtone to sms
3. click "X" and chose save as draft
4. click home button to show homescreen.
5. open sms app background from homescreen.
6. there is no draft record we saved yet.


Expected result:
---------------------------------------------
There is draft we saved yet.

Actual result:
---------------------------------------------
there is no draft record we saved yet.

Probability:
---------------------------------------------
Always Recurrence
(Reporter)

Comment 1

3 years ago
If we kill sms app and launch it again, we can see the saved drafts.
I think the sms app from settings through activity and normal sms app are independent of each other.
How could we monitor the draft changing in the normal sms from sms launched by setting app?

Dear Julien

Could you help to take a look and give some suggestion?
I'm confused with it.
Flags: needinfo?(felash)
(Reporter)

Updated

3 years ago
Whiteboard: [sprd 430709]
(Reporter)

Comment 2

3 years ago
Thanks very much.
(Reporter)

Comment 3

3 years ago
If we share pictures from gallery app to message, we can also encounter this issue.
Hey Wei,

You can look at the patches in bug 1058459 (it even has v2.0m patch that hasn't been landed).

Patch in bug 1080480 is more modern version, but it can work only in master.

Thanks
(Reporter)

Comment 5

3 years ago
(In reply to Oleg Zasypkin [:azasypkin] from comment #4)
> Hey Wei,
> 
> You can look at the patches in bug 1058459 (it even has v2.0m patch that
> hasn't been landed).
> 
> Patch in bug 1080480 is more modern version, but it can work only in master.
> 
> Thanks

Oh, yes, that's right, I will try it.
Thanks so much.
(Reporter)

Comment 6

3 years ago
(In reply to Oleg Zasypkin [:azasypkin] from comment #4)
> Hey Wei,
> 
> You can look at the patches in bug 1058459 (it even has v2.0m patch that
> hasn't been landed).

Hi Oleg
I found the patch for 2.0m was so big. I am not sure does it suit for v2.1?
Do you know about it?
Thanks.

https://github.com/mozilla-b2g/gaia/commit/fd0029522b8804319ab1174ebcf4b73c147bef8b
Patch for master in bug 1058459 should work on v2.1.

It's also a big patch but there is no other solution to solve this issue. So it's up to you to do the trade-of between this (IMO) small issue and adding a big patch to v2.1.

Note that even if it's a big patch it's not that risky: no regression since it landed, and the code is quite well contained.
Flags: needinfo?(felash)
(Reporter)

Comment 8

3 years ago
(In reply to Julien Wajsberg [:julienw] (PTO -> Apr 27) from comment #7)
> Patch for master in bug 1058459 should work on v2.1.
> 
> It's also a big patch but there is no other solution to solve this issue. So
> it's up to you to do the trade-of between this (IMO) small issue and adding
> a big patch to v2.1.
> 
> Note that even if it's a big patch it's not that risky: no regression since
> it landed, and the code is quite well contained.

Ok, thank Julien very much.
Let me dupe to bug 1058459 then :)
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1058459
You need to log in before you can comment on or make changes to this bug.