Closed Bug 1159170 Opened 6 years ago Closed 6 years ago

[Contacts]"cannot use memory card because USB storage is enabled" is too close to the right edge of screen.

Categories

(Firefox OS Graveyard :: Gaia::Contacts, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:2.5+, b2g-v2.2 affected, b2g-master verified)

RESOLVED FIXED
2.2 S14 (12june)
blocking-b2g 2.5+
Tracking Status
b2g-v2.2 --- affected
b2g-master --- verified

People

(Reporter: huayu.li, Assigned: sousmangoosta, Mentored)

References

Details

(Whiteboard: LocRun2.2)

Attachments

(12 files)

[1.Description]:
[Flame2.2][Contacts]"cannot use memory card because USB storage is enabled" is too close to the right edge of screen on the export contacts page.

See attachment:Portuguese Portugal_mememory.png

[2.Testing Steps]: 
Prerequisites:Set device language to  Portuguese Portugal , Have at least 1 contact in the contacts app. Have USB storage Enabled in Settings
1. Open the Contacts app 
2. Tap on the gear icon to open settings 
3.Tap on 'Export Contacts' 
4. Plug the device into the computer 
 
[3.Expected Result]: 
4."cannot use memory card because USB storage is enabled"  should fit the screen width.

[4.Actual Result]: 
4."cannot use memory card because USB storage is enabled" is too close to the right edge of screen.

[5.Reproduction build]: 
Device: Flame 2.2 user [Affected]
Build ID               20150427002504
Gaia Revision          265ca0bc9408c21fc4b25a259fcee7fb642cd06b
Gaia Date              2015-04-24 19:13:28
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/1908685d798d
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150427.040119
Firmware Date          Mon Apr 27 04:01:31 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 2.1 user[This text content on flame 2.1 is different from flame 2.2]
Build ID               20150427001201
Gaia Revision          bbe983b4e8bebfec26b3726b79568a22d667223c
Gaia Date              2015-04-09 13:52:48
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/82a14be0462c
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150427.034910
Firmware Date          Mon Apr 27 03:49:21 EDT 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
12807

[8.Note]:
Text content on flame 2.1 is : "cannot use SD card because USB storage is enabled".
Localizer used 2 different strings, which is why this seems too close to the edge of the string in 2.2.
ASking pt-PT localizer if he can shorten the string back. Thanks!
Assignee: nobody → joao.neves
Component: Gaia::Contacts → pt-PT / Portuguese
Flags: needinfo?(cesperanc)
Product: Firefox OS → Mozilla Localizations
QA Contact: joao.neves
The translations are different because the original strings are also different: 

"Cannot use SD Card because USB storage is enabled", key sdUMSEnabled, v2.1
"Cannot use memory card because USB storage is enabled", key  memoryCardUMSEnabled, v2.2

However, to fix the issue, I've shortened the translation in 2.2 about six chars on the first line, so the problem should now be fixed on locamotion.

Thank you
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: needinfo?(cesperanc)
Resolution: --- → FIXED
Whiteboard: LocRun2.2, MGSEI-l10n-1F-Portuguese Portugal → LocRun2.2, MGSEI-l10n-1F-Portuguese Portugal,MGSEI-l10n-1F-Portuguese Brazil
Whiteboard: LocRun2.2, MGSEI-l10n-1F-Portuguese Portugal,MGSEI-l10n-1F-Portuguese Brazil → LocRun2.2, MGSEI-l10n-1F-Portuguese Portugal,MGSEI-l10n-1F-Serbian Latin
Set System language to Serbian Latin ,this issue exists on flame2.2
Refer to picture:IMAG0811.jpg

Flame 2.2 user:
Build ID               20150429002501
Gaia Revision          1b7aa7e60788668ed09abf76022dfa231dbe88d4
Gaia Date              2015-04-28 19:36:06
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/d38ff4717f39
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150429.040640
Firmware Date          Wed Apr 29 04:06:52 EDT 2015
Bootloader             L1TC000118D0
This issue has been verified on flame 2.2.
Reproduce rate: 0/5

Device: Flame 2.2 user[Verified]
Build ID               20150429002501
Gaia Revision          1b7aa7e60788668ed09abf76022dfa231dbe88d4
Gaia Date              2015-04-28 19:36:06
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/d38ff4717f39
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150429.040640
Firmware Date          Wed Apr 29 04:06:52 EDT 2015
Bootloader             L1TC000118D0
Hi Cláudio, Could you help to check this issue on Serbian Latin as comment 4 descriped
Flags: needinfo?(cesperanc)
The problem with the Serbian Latin is very similar to the one reported for the pt-PT locale, so the issue can be a layout issue (probably the right padding of the graphic element which contains the localized text doesn't exist or it's not being properly applied, which affects the way how the text wrapping should function; or the inner element which contains the text has a size which overlaps the size of the parent).

In the pt-PT locale the issue was fixed by removing some chars which shortened the size of the first line which allowed a localized fix. However, if this is a layout issue, there is a chance the problem will appears in other languages and/or in other screens.

Maybe we need a needinfo from a developer.
Operational notes for QA:
* Please take screenshots of the phone: you can do that either on the device or via Firefox and WebIDE. Opening 7 MB of a photo (PNG is for images with few details, use JPG for photos) is painful, and I assume is painful for you to attach them to Bugzilla.
* Cross-referencing locales in localization bugs is confusing, don't do that unless they're bugs filed in the products (this bug is for pt-PT, you're asking about Serbian Latin and the localizer is not here).

Bug note: this is clearly a layout bug, the message doesn't have any margin/padding on the right, and it should be filed and fixed in Firefox OS::Contacts
Flags: needinfo?(cesperanc)
Thanks Flod for your help on this, I've already raised all this before... Moving components for this bug. Thanks
Assignee: joao.neves → nobody
Component: pt-PT / Portuguese → Gaia::Contacts
Product: Mozilla Localizations → Firefox OS
QA Contact: joao.neves
Attached image 2.2user_Greek.png
Attachment #8601349 - Attachment description: Portuguese from Portugal.png → 2.2user_Portuguese from Portugal.png
I have verified this issue on latest user build.

It is failed verified on follow language, 2.2User[Affected], 2.1user[Unaffected]
Greek
Portuguese from Portugal
Serbian Cyrillic
Serbian Latin

It is succesfully verified on follow language:
Spanish
Russian
Bengali from India
Polish
Basque
Portuguese from Brazil
Arabic

Device: Flame 2.1 user
Build ID               20150504001200
Gaia Revision          b4a03b7ee61de5a479b3cf0916f47e91a43b0f50
Gaia Date              2015-04-30 21:31:55
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/03bfe12e50d0
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150504.040736
Firmware Date          Mon May  4 04:07:47 EDT 2015
Bootloader             L1TC000118D0

Device: Flame2.2 user
Build ID               20150504002502
Gaia Revision          8d14361337e608c8cdf165ea5034db5eda23b618
Gaia Date              2015-05-01 18:23:46
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/cb7cb6597c91
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150504.041541
Firmware Date          Mon May  4 04:15:53 EDT 2015
Bootloader             L1TC000118D0
Hi Delphine, I noticed that you've checked this issue, but have not updated it for a long time. Could you please continue following this issue?
Nominating 2.2 for triage decision: poor UI, strings are different between both versions but they shouldn't be shifting off the screen.
blocking-b2g: --- → 2.2?
Flags: needinfo?(lebedel.delphine)
Reopening the bug as this concerns multiple languages.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Comms triage: This is a regression which affect many non-english speakers. However, the issue is minor, and we think it's too late to block 2.2 for a misalignment, at the current stage of the release. Let's fix it in 3.0.
blocking-b2g: 2.2? → 3.0+
Whiteboard: LocRun2.2, MGSEI-l10n-1F-Portuguese Portugal,MGSEI-l10n-1F-Serbian Latin → LocRun2.2, MGSEI-l10n-1F-Portuguese Portugal,MGSEI-l10n-1F-Serbian Latin [good-first-bug]
Mentor: francisco
Hey Alissa,

Is this what you want ?

Thanks,
Flags: needinfo?(huayu.li)
Attachment #8613290 - Flags: feedback?(huayu.li)
Here Serbian Latin example without margin right.
Here Serbian Latin with margin right, is it ok ?
Attachment #8613304 - Flags: feedback?(huayu.li)
(In reply to Ronald Claveau [:sousmangoosta] from comment #20)
> Created attachment 8613290 [details]
> Screenshot of B2G v2.2 desktop build with margin-right added
> Hey Alissa,
> Is this what you want ?
> Thanks,

Hi Ronald,
Attachment 8613290 [details] looks good to me.


(In reply to Ronald Claveau [:sousmangoosta] from comment #21)
> Created attachment 8613303 [details]
> Serbian Latin without margin right
> Here Serbian Latin example without margin right.
(In reply to Ronald Claveau [:sousmangoosta] from comment #22)
> Created attachment 8613304 [details]
> Serbian Latin with margin right
> Here Serbian Latin with margin right, is it ok ?

For the two designs, attachment 8613304 [details] which with mergin right is good to me. thanks.
Flags: needinfo?(huayu.li)
Attachment #8613290 - Flags: feedback?(huayu.li) → feedback+
Attachment #8613304 - Flags: feedback?(huayu.li) → feedback+
Hey Francisco,

Could you please assign to me this bug ?

Thx you !!
Flags: needinfo?(francisco)
A pleasure!
Assignee: nobody → sousmangoosta
Flags: needinfo?(francisco)
Attachment #8613408 - Flags: review?(francisco)
Comment on attachment 8613408 [details] [review]
[gaia] sousmangoosta:Bug-1159170 > mozilla-b2g:master

tested on the phone, looking good for me.

Thanks for the contribution!
Attachment #8613408 - Flags: review?(francisco) → review+
Oh,

forgot that autolander is off!

Will land manually.
Keywords: checkin-needed
Landed in master:

https://github.com/mozilla-b2g/gaia/commit/45dc6306cf502a4f00ae9f8bd8293a8a3a37c07b
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
QA Whiteboard: [MGSEI-l10n-1F]
Whiteboard: LocRun2.2, MGSEI-l10n-1F-Portuguese Portugal,MGSEI-l10n-1F-Serbian Latin [good-first-bug] → LocRun2.2
We will verify this issue on master once Bug 1169815 or Bug 1171768 is fixed.
This issue has been verified as pass on flame 3.0 user build.
Rate:0/5
Device: Flame 3.0 user[pass]
Build ID               20150614010203
Gaia Revision          1bf2da102560481748ff3f6202fbed5c4daa5832
Gaia Date              2015-06-13 00:22:05
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/c223b8844264
Gecko Version          41.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150614.043102
Firmware Date          Sun Jun 14 04:31:14 EDT 2015
Bootloader             L1TC000118D0
Attached image Verify1_pass_v3.0.png
Target Milestone: --- → 2.2 S14 (12june)
You need to log in before you can comment on or make changes to this bug.