[Contacts]There is no prompt of "App permission" while we launch camera from contact.

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
3 years ago
7 months ago

People

(Reporter: yi.zou, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.2 affected, b2g-master affected)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8598557 [details]
logcat001.txt

[1.Description]:
[Flame v2.2 & v3.0][Nexus5 v2.2 &v3.0][Contacts]There is no prompt  of "App permission" when you first open the camera app from contacts.
Time:5:14
See attachment:logcat001.txt,VIDEO0366.mp4

[2.Testing Steps]: 
1.Open the contacts app.
2.Click the '+' button.
3.Click the '+' button to add a picture.
4.Choose the camera button.

[3.Expected Result]: 
4.Device should enquire user whether to share location with a notification.

[4.Actual Result]: 
4.Device fails to enquire user whether to share location with a notification. 

[5.Reproduction build]: 
N5 v2.2 (Affected):
Build ID               20150427002504
Gaia Revision          265ca0bc9408c21fc4b25a259fcee7fb642cd06b
Gaia Date              2015-04-24 19:13:28
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/1908685d798d
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150427.035747
Firmware Date          Mon Apr 27 03:58:04 EDT 2015
Bootloader             HHZ12f

N5 v3.0 (Affected):
Build ID               20150427160201
Gaia Revision          0636405f0844bf32451a375b2d61a2b16fe33348
Gaia Date              2015-04-27 16:42:28
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/caf25344f73e
Gecko Version          40.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150427.192534
Firmware Date          Mon Apr 27 19:25:51 EDT 2015
Bootloader             HHZ12f

Flame v2.2 (Affected):
Build ID               20150427162501
Gaia Revision          9f6b1b9082662ba2c14168fc66bb02b4df3141e5
Gaia Date              2015-04-27 20:41:33
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/e79c19bf19bf
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150427.195038
Firmware Date          Mon Apr 27 19:50:51 EDT 2015
Bootloader             L1TC000118D0

Flame v3.0 (Affected):
Build ID               20150427160201
Gaia Revision          0636405f0844bf32451a375b2d61a2b16fe33348
Gaia Date              2015-04-27 16:42:28
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/caf25344f73e
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150427.192938
Firmware Date          Mon Apr 27 19:29:49 EDT 2015
Bootloader             L1TC000118D0


[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
(Reporter)

Comment 1

3 years ago
Created attachment 8598559 [details]
VIDEO0366.mp4
(Reporter)

Updated

3 years ago
status-b2g-v2.2: --- → affected
status-b2g-master: --- → affected
Hi zouyi,

We are using a web activity here, so we are launching a new process, if you already granted the permissions to camera in other session, the system won't ask again.

If it's the first time that you launch camara, not just for contacts, but the first time ever that camera app is launched, then this is a bug, that we should move to system.
Flags: needinfo?(yi.zou)
(In reply to Francisco Jordano [:arcturus] [:francisco] from comment #2)
> Hi zouyi, 
> If it's the first time that you launch camara, not just for contacts, but
> the first time ever that camera app is launched, then this is a bug, that we
> should move to system.

Add prerequisite:Haven't launch camera after we flash device.
If we launch camera from homescreen or lockscreen for the first time, the "app permission" page will be displayed, so this issue just exist when first time launch camera from contact.
Component: Gaia::Contacts → Gaia::System
Flags: needinfo?(yi.zou)

Comment 4

7 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.