Status

()

Core
RDF
P3
normal
VERIFIED DUPLICATE of bug 8929
19 years ago
15 years ago

People

(Reporter: Warren Harris, Assigned: dougt)

Tracking

({helpwanted})

Trunk
Future
All
Other
helpwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
We should eliminate the NS_COMFALSE madness once and for all. Here's a list of
offending uses in your module -- please pass the bug along if there's someone
else who should deal with it.


      rdf/content/src/nsXULAttributes.cpp:
            View change log or Blame annotations
            line 558

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M10

Updated

19 years ago
Blocks: 8929

Comment 1

18 years ago
Moving out non-critical tasks.

Updated

18 years ago
Summary: eliminate NS_COMFALSE → [HELP WANTED] eliminate NS_COMFALSE

Updated

18 years ago
QA Contact: phillip

Updated

18 years ago
Keywords: helpwanted

Updated

18 years ago
Summary: [HELP WANTED] eliminate NS_COMFALSE → eliminate NS_COMFALSE

Comment 2

18 years ago
maybe scc'll do it.
Target Milestone: M15 → M20

Comment 3

18 years ago
Not many of these left, now, as most cases were replaced with |
NS_ENUMERATOR_FALSE|, which at least makes the behavior in those situations 
somewhat understandable.
Assignee: waterson → scc
Status: ASSIGNED → NEW

Updated

18 years ago
Status: NEW → ASSIGNED

Updated

18 years ago
Assignee: scc → scc
Status: ASSIGNED → NEW

Comment 4

18 years ago
mass re-assigning to my new bugzilla account

Updated

18 years ago
Status: NEW → ASSIGNED

Comment 5

18 years ago
Up todate list

/rdf/content/src/nsXULElement.cpp
       line 3971 -- rv = nsClassList::HasClass(mPrototype->mClassList, aClass) ? 
NS_OK : NS_COMFALSE;
/rdf/content/src/nsXULAttributes.cpp
       line 855 -- return nsClassList::HasClass(mClassList, aClass) ? NS_OK : 
NS_COMFALSE;

Comment 6

16 years ago
All remaining instances of NS_COMFALSE in the rdf code followed XUL into
content/; inspection of rdf/ yields no further instances.  Unless
nsXULElement.cpp etc are still considered part of the RDF component, this bug
can be closed.

Comment 7

15 years ago
Some |NS_COMFALSE| still exists in the tree, but not much.  See the URL above
for a search.  Re-assigning to XPCOM owner.
Assignee: scc → dougt
Status: ASSIGNED → NEW
(Assignee)

Comment 8

15 years ago
not that important.  -> future
Target Milestone: --- → Future

*** This bug has been marked as a duplicate of 8929 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Verified dupe
Sorry for the spam
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.