Writing accented letters in Google Drive or Facebook comments makes Nightly crash

RESOLVED DUPLICATE of bug 1117087

Status

()

Firefox
Untriaged
--
critical
RESOLVED DUPLICATE of bug 1117087
3 years ago
3 years ago

People

(Reporter: Xavier Mouton-Dubosc, Unassigned, NeedInfo)

Tracking

({crash})

39 Branch
x86_64
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:39.0) Gecko/20100101 Firefox/39.0
Build ID: 20150424211423

Steps to reproduce:

Writing a document in Google Drive with a Firefox Nightly onto Linux, on a AZERTY keyboard. I redact a text in French, so I have to use circumflexed vowels.  


Actual results:

Hiting [^] and [e] makes (not every times) Nightly Crash.


Expected results:

Puting a "ê" in my text
(Reporter)

Comment 1

3 years ago
Puting a "û" with [^] [u] also makes crashes.
(Reporter)

Updated

3 years ago
OS: Unspecified → Linux
Hardware: Unspecified → x86_64

Comment 2

3 years ago
This bug also exists on Facebook, in "comment" (not "status") fields. The letters â, ẑ, ê, ŷ, û, ô, ŝ, ĝ, ĥ, ĵ, ŵ, ĉ, ^ (^+space) and their capital counterparts make the browser crash every time.

Tested under both Iceweasel 39.0a2 and Firefox Developer Edition 39.0a2 for Linux (Mozilla/5.0 (X11; Linux x86_64; rv:39.0) Gecko/20100101 Firefox/39.0).

When using Firefox Developer Edition, tested both under "normal mode" (after refreshing firefox) and "safe mode".

Copying and pasting the characters works as expected.

Comment 3

3 years ago
Do you have crash reports (bp-...) in about:crashes? If yes, could you post the links.
Does it crash on Windows too?
Flags: needinfo?(xaviermd)

Comment 4

3 years ago
Here's the crash report : https://crash-stats.mozilla.com/report/index/333043bb-1a8c-4519-8793-75d4f2140209
I can't test on windows.

Comment 5

3 years ago
I tried to comment a Facebook message with accented letters with FF40 on Win 7, no crash. I guess it's specific to Linux version.
Severity: normal → critical
Keywords: crash, regressionwindow-wanted
Summary: writing a circumflex e in google drive makes nightly crash → Writing accented letters in Google Drive or Facebook comments makes Nightly crash
Ghjuvan: The crash report you posted in Comment 4 shows a really old version of the browser running Aurora - 20140113004002. Are you sure that is the correct crash report?

Comment 7

3 years ago
Marcia : Sorry, this was an old crash report. I don't even know why it was in my crash reports since I'm using a clean, newly installed version of firefox.
Here's the actual crash report : https://crash-stats.mozilla.com/report/index/61782d92-7aa5-473c-a778-cdb612150428

Comment 8

3 years ago
If we can trust the crash signature, this bug is a dupe of bug 1117087.
Yes, it appears this is a dupe of Bug 1117087.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1117087
Flags: needinfo?(xaviermd)
Keywords: regressionwindow-wanted
I forgot to put in the initial comment that the reporter did not provide a crash report, and we are assuming that the reporter's crash is the same as Ghjuvan's. If it  isn't then the reporter should reopen the bug and let us know what his crash report was. I left a ni on him in case he wants to provide that.
Flags: needinfo?(xaviermd)
(Reporter)

Comment 11

3 years ago
about:crashes  : URL not valid

How can i get it ?
Xavier: Not sure what you are hitting with the URL not valid - when I type about:crashes in the URL bar, I get my list of Submitted Crash Reports. If there are no reports, the list would be empty.
You need to log in before you can comment on or make changes to this bug.