Closed Bug 1159303 Opened 5 years ago Closed 5 years ago

Reduce noise due to sort operations warnings

Categories

(Toolkit :: Storage, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla40
Tracking Status
firefox40 --- fixed

People

(Reporter: mak, Assigned: mak)

Details

Attachments

(1 file)

The current message is too long and very annoying when looking through test logs, I think we can shorten them without loosing too much value, regardless any serious Storage developer should either use PRLog or set MOZ_STORAGE_SORTWARNING_SQL_DUMP

I'd like it to be a 1-liner, as far as possible.
Summary: Reduce noice caused by the sort operations warnings → Reduce noise due to sort operations warnings
Attached patch patch v1Splinter Review
This is a bit less verbose than what we have.
Attachment #8598731 - Flags: review?(bent.mozilla)
Comment on attachment 8598731 [details] [diff] [review]
patch v1

Review of attachment 8598731 [details] [diff] [review]:
-----------------------------------------------------------------

::: storage/src/mozStoragePrivateHelpers.cpp
@@ +97,5 @@
>      return;
>  
> +  nsAutoCString message("Suboptimal indexes for the SQL statement ");
> +#ifdef MOZ_STORAGE_SORTWARNING_SQL_DUMP
> +  message.AppendLiteral("`");

Nit: Append('`')

@@ +106,5 @@
>  #else
>    nsPrintfCString address("0x%p", aStatement);
>    message.Append(address);
>  #endif
> +  message.Append("' (http://mzl.la/1FuID0j).");

Nit: Don't need the "'" any more
Attachment #8598731 - Flags: review?(bent.mozilla) → review+
ops sorry, I didn't notice ', I need better eyeglasses!
and while there, it should be an AppendLiteral...
https://hg.mozilla.org/mozilla-central/rev/2696c3d2ee51
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla40
You need to log in before you can comment on or make changes to this bug.