Closed Bug 1159368 Opened 4 years ago Closed 4 years ago

After queueing a tab, I get put into the search activity

Categories

(Firefox for Android Graveyard :: Search Activity, defect)

40 Branch
defect
Not set

Tracking

(firefox41 verified, fennecNightly+)

VERIFIED FIXED
Firefox 40
Tracking Status
firefox41 --- verified
fennec Nightly+ ---

People

(Reporter: snorp, Assigned: mhaigh)

References

Details

Attachments

(1 file)

I use search activity a lot. I also use tab queues. Frequently (always?), I get dumped into the search activity after queueing a tab. That's wrong.
The search activity is singleTop. BrowserApp is singleTask. Tab Queue prompt is singleTop, Tab Queue task is singleTask. 

Only BrowserApp specifies a task affinity.

My guess is that Tab Queue and the search activity are ending up in our package's default task; when the tab queue activity finishes, the search activity is the next thing in the task.

Either TQ should be sticking with the launching task, or we should be specifying a separate task affinity for the search activity, or both.
This should probably be tracking 41 with tab queues.
tracking-fennec: --- → ?
Component: General → Search Activity
Version: Firefox 34 → Firefox 40
I think this could end up getting duped with bug 1155911.
See Also: → 1155911
tracking-fennec: ? → Nightly+
Assignee: nobody → mhaigh
Attachment #8602060 - Flags: review?(rnewman)
Comment on attachment 8602060 [details] [diff] [review]
Add task affinity to search

Review of attachment 8602060 [details] [diff] [review]:
-----------------------------------------------------------------

My understanding of this behavior:

* The search activity will show as its own task in the task switcher, named @search_app_name.
* Links in the search activity will open Fennec, which -- by virtue of its own task settings -- will be a separate task.
* Any links that open apps directly, rather than via Fennec, will be rooted in the search activity task.

That seems fine to me.

::: mobile/android/search/manifests/SearchAndroidManifest_activities.xml.in
@@ +1,4 @@
>          <activity
>              android:name="org.mozilla.search.SearchActivity"
>              android:launchMode="singleTop"
> +            android:taskAffinity="org.mozilla.gecko.SEARCH"

@ANDROID_PACKAGE_NAME@.SEARCH

-- otherwise search activities for each installed Fennec will compete with each other!
Attachment #8602060 - Flags: review?(rnewman) → review+
https://hg.mozilla.org/mozilla-central/rev/c00751417808
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 40
Reproduced the issue with the 28-04 Nightly build using Nexus 7 (Android 5.1.1): Open search activity, minimize, tap a link from gmail app and open it with nightly => search activity is displayed 


Verified as fixed using latest 41,0a1 Nightly (2015-06-04)
Status: RESOLVED → VERIFIED
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.