Snippet Impressions has stopped at 4/22/2015

RESOLVED FIXED

Status

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: jcollings, Assigned: bensternthal)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
Hi Ben and Josephine,

If you look at this sheet here: https://dataviz.mozilla.org/authoring/SnippetHealth/Impressionsbytime/Impressions%20by%20time#5

(Need to break it down by day)

The last snippet impression update is as of 4/22/2015. I'm not sure if this is related to the data center issue or if this is a Tableau issue but I get a feeling that either a) no one is seeing snippets or b) impressions are just not being recorded for whatever reason after 4/22. 

If you both can investigate, that would be great! Thanks.

Jean
(Assignee)

Comment 1

4 years ago
Snippets as far as I can tell are being served. I tested the URL that my firefox generates and got snippets returned:

Request:
> https://snippets.cdn.mozilla.net/4/Firefox/37.0.2/20150415140819/Darwin_Universal-gcc3/en-US/release/Darwin%2014.3.0/default/default/

Response:
> https://snippets.mozilla.com/media/bundles/b7508d88ca89adc53b6d0ac024cd92ae29d89147.html

So next things to check:
1. Has anything changed regarding the code that sends impressions.
2. Investigate if something changed in tableau or where tableau gets its data.
(Assignee)

Comment 2

4 years ago
Refreshing a bunch on my local firefox I did see a snippet impression being sent:

> https://snippets-stats.mozilla.org/foo.html?snippet_name=5159&locale=en-US&country=&metric=impression

So let's confirm the issue is not with the report before diving deeper into the service side.
Flags: needinfo?(jtanumijaya)

Updated

4 years ago
Flags: needinfo?(jtanumijaya)

Comment 3

4 years ago
The last date in snippet_count table is April 22. This is the table in vertica used by Tableau report that Jean is looking at. 

I'm working with Matt (cc-ed) to check the source before it comes to snippet_count table.
I pushed the changes to add country in the ping on Fri 24th (Apr 24 2015 03:10:15 PST) and the last change before that was on the 20th, which was unrelated to the ping.  I don't think that this is related to any code change from my side. I continue to investigate.
Looks like the stats server is down

$ curl "https://snippets-stats.mozilla.org/foo.html?snippet_name=5140&locale=en-US&country=gr&metric=impression" 
curl: (7) Failed to connect to snippets-stats.mozilla.org port 443: Connection refused

I pinged #moc to look at this.
OK ignore my last comment #5. That was just me.

Stats server accepts connections and we send the ping.
(Reporter)

Comment 7

4 years ago
Hi Matt and Josephine, 

Any movement on this? Please keep me updated! Thanks.
Flags: needinfo?(mpressman)
Flags: needinfo?(jtanumijaya)
I've been able to identify that there is data in hadoop. We are now, looking into why it isn't being put into the table in vertica where tableau reads it and creates the reports
Flags: needinfo?(mpressman)
Hi there,

Yesterday we all looked into the issue, and it was due to a change I had made (which included a typo). I fixed it yesterday, and it looks like yesterday's #'s got in there this morning with no problems.
(Reporter)

Comment 10

4 years ago
Thanks all for investigating. Data is back!
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED

Updated

4 years ago
Flags: needinfo?(jtanumijaya)
You need to log in before you can comment on or make changes to this bug.