Remove hover state on Android and iOS global subnav

RESOLVED INVALID

Status

www.mozilla.org
Pages & Content
RESOLVED INVALID
3 years ago
3 years ago

People

(Reporter: malexis, Unassigned)

Tracking

Development/Staging

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
The issue is that both "for Android" and "for iOS" have Overview and Sync in the subnav and when hovering between the two, it is unclear that the links change.

The proposal discussed in today's check-in is to remove this hover state and subnav and just have the top nav links point to the landing pages.

Gareth, Holly, Jen, what do you think?
Jon & Holly - Thoughts?

I have seen this error.
Flags: needinfo?(jon)
Flags: needinfo?(hhabstritt.bugzilla)
Thoughts:
Agreed that once a hover action has occurred, it isn't always clear which top level nav item the displayed subnav relates to.

For example... In the following screenshot, Desktop is selected, but I've hovered over Android. Desktop still looks very strongly selected, though the Android subnav is displayed http://cl.ly/image/3t09200K3m1B



Concern: 
Removing the hover state could result in less cross-product navigation because revealing the subnav items on hover make the items more easily discoverable. 

However, leaving the interaction as-is can result in confusion for the user. 



Could we: 
Turn off the hover interaction. Then measure if cross-page navigation decreases? If it decreases, then explore a hover interaction that makes the subnav's related parent/global item more clear?
Flags: needinfo?(hhabstritt.bugzilla)

Comment 3

3 years ago
Ty and I talked a little bit about this issue before iOS got delayed. This work was planned to be part of the Spring Campaign, but now that iOS isn't shipping for 6/2, it got pushed.

The current hover state is not good, but it's what we've had in production since the nav launched. Just want to state that it isn't really a bug...yet. It is definitely non-optimal UI though. (When iOS launches, which has a hover state exactly matching Android, I would consider it a bug.)

Perhaps the best next step is for Ty and I to resume this discussion, looking at different ways to make the hover state more distinct from the selected state?
Flags: needinfo?(jon)
We didn't ship iOS. Keeping the tracker open as it may prove helpful to use these bugs for reference when iOS does ship.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.