If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Save File window bug - Attempting to save a file with invalid characters in its name causes the window to display "No items match your search," and the Save button to stop working.

RESOLVED INVALID

Status

()

Firefox
Untriaged
RESOLVED INVALID
2 years ago
2 years ago

People

(Reporter: andyxu, Unassigned)

Tracking

37 Branch
Unspecified
Windows 8.1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:37.0) Gecko/20100101 Firefox/37.0
Build ID: 20150415140819

Steps to reproduce:

(Be sure to select the "Always ask me where to save files" option in the General tab of the Options dialog) 
1. Start a download. 
2. In the Save File window, type a character that is not allowed in file names into the "File name" text box (question mark, forward slash, backward slash, colon, asterisk, quotation mark, forward arrow, backward arrow; vertical bar).
3. Click the Save button.


Actual results:

The file did not save, and the files in the current directory of the Save File window were replaced with the message, "No items match your search."


Expected results:

The user should have been given a warning informing them that the file couldn't be saved because it contained an invalid character.
(Reporter)

Updated

2 years ago
OS: Unspecified → Windows 8.1
(Reporter)

Updated

2 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.