Closed Bug 1159539 Opened 5 years ago Closed 5 years ago

nothing happens when trying to open a link in a new private window

Categories

(Firefox OS Graveyard :: Gaia::System::Window Mgmt, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: nhirata, Assigned: kgrandon)

References

Details

(Keywords: regression)

Attachments

(1 file)

1. launch browser
2. go to news.google.com
3. long tap on a link and select open in new private window

Expected: new private window opens with the link
Actual: nothing.

logcat shows : 
D/wpa_supplicant(  971): RX ctrl_iface - hexdump(len=11): 53 49 47 4e 41 4c 5f 50 4f 4c 4c
D/wpa_supplicant(  971): wlan0: Control interface command 'SIGNAL_POLL'
D/wpa_supplicant(  971): nl80211: survey data missing!
I/GeckoDump(  212): XXX FIXME : Got a mozContentEvent: activity-choice
I/(Preallocated app)( 1654): PAC file installed from data: URI
V/WLAN_PSA(  216): NL MSG, len[048], NL type[0x11] WNI type[0x5050] len[028]
D/wpa_supplicant(  971): RX ctrl_iface - hexdump(len=11): 53 49 47 4e 41 4c 5f 50 4f 4c 4c
D/wpa_supplicant(  971): wlan0: Control interface command 'SIGNAL_POLL'
D/wpa_supplicant(  971): nl80211: survey data missing!
V/WLAN_PSA(  216): NL MSG, len[048], NL type[0x11] WNI type[0x5050] len[028]


Gaia-Rev        c4906650e20265dfdb4807bf3cbeb323da8bfed9
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/caf25344f73e
Build-ID        20150428010206
Version         40.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150428.043923
FW-Date         Tue Apr 28 04:39:34 EDT 2015
Bootloader      L1TC000118D0

[ used releng build userdebug with custom gaia ]
Need to wait til tomorrow's build.  I can't reproduce in today's build with the releng gaia.
Flags: needinfo?(nhirata.bugzilla)
Happens on :
Gaia-Rev        6e35b0948c42a4398b8a5916015de167121683a1
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/1ad65cbeb2f4
Build-ID        20150429010205
Version         40.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150429.044126
FW-Date         Wed Apr 29 04:41:37 EDT 2015
Bootloader      L1TC000118D0
Flags: needinfo?(nhirata.bugzilla)
QA Contact: ychung
I'm going to look into this initially.
Assignee: nobody → kgrandon
b2g-inbound Regression Window:

Last Working Environmental Variables:
Device: Flame 3.0
BuildID: 20150427130818
Gaia: 649d6ea599bbcba11d11032d85267c99837831e8
Gecko: b4e8a35e2f2e
Version: 40.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

First Broken Environmental Variables:
Device: Flame 3.0
BuildID: 20150427132515
Gaia: 5d7cd877353dd3bd43f4719ae6a076a92edda717
Gecko: 5f61fd869672
Version: 40.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

Last Working Gaia First Broken Gecko: Issue does NOT reproduce 
Gaia: 649d6ea599bbcba11d11032d85267c99837831e8
Gecko: 5f61fd869672

First Broken Gaia Last Working Gecko: Issue DOES reproduce
Gaia: 5d7cd877353dd3bd43f4719ae6a076a92edda717
Gecko: b4e8a35e2f2e

https://github.com/mozilla-b2g/gaia/compare/649d6ea599bbcba11d11032d85267c99837831e8...5d7cd877353dd3bd43f4719ae6a076a92edda717

Caused by bug 1158238
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Contact: ychung
Blocks: 1158238
Fixed now that bug 1158238 was backed out.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
According to the STR of Comment 0, I can't repro this bug on latest Flame v2.2&3.0 build. New private window opens with the link normally.

See attachment: verified_v2.2&3.0.mp4.
Reproduce rate: 0/5


Device: Flame 2.2 build(Unaffected)
Build ID               20150503002500
Gaia Revision          8d14361337e608c8cdf165ea5034db5eda23b618
Gaia Date              2015-05-01 18:23:46
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/cb7cb6597c91
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150503.040203
Firmware Date          Sun May  3 04:02:15 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 3.0 build(Unaffected)
Build ID               20150503160200
Gaia Revision          e18cce173840d6ff07fb6f1f0e0ffb58b99aab3e
Gaia Date              2015-05-02 04:27:01
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/dc5f85980a82
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150503.193941
Firmware Date          Sun May  3 19:39:52 EDT 2015
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
Keywords: qawanted, verifyme
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
You need to log in before you can comment on or make changes to this bug.