multiple emails in one line + address book + autocomplete suggestion

RESOLVED DUPLICATE of bug 440377

Status

Thunderbird
Mail Window Front End
RESOLVED DUPLICATE of bug 440377
3 years ago
3 years ago

People

(Reporter: bugtime, Unassigned)

Tracking

31 Branch

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:37.0) Gecko/20100101 Firefox/37.0
Build ID: 20150415140819

Steps to reproduce:

Thunderbird 31.6.0, win7-32bit.
Write (create new message)>To: user1@domain.com;  user2@domain.com;  user3@domain.com;  



Actual results:

Not work autocomplete suggestion for multiple email addresses from address book. Address book contains them, and sending only to one recipient autocomplete suggestion works. If multiple emails in one line not work. Just works to first email.




Expected results:

add some letters of email address and get autocomplete suggestion from address book, for any number entered emails in one [To:] line.

Comment 1

3 years ago
(In reply to bugtime from comment #0)
> User Agent: Mozilla/5.0 (Windows NT 6.1; rv:37.0) Gecko/20100101 Firefox/37.0
> Build ID: 20150415140819
> 
> Steps to reproduce:
> 
> Thunderbird 31.6.0, win7-32bit.
> Write (create new message)>To: user1@domain.com;  user2@domain.com; 
> user3@domain.com;  
> 
> 
> 
> Actual results:
> 
> Not work autocomplete suggestion for multiple email addresses from address
> book. Address book contains them, and sending only to one recipient
> autocomplete suggestion works. If multiple emails in one line not work. Just
> works to first email.

Iirc using ";" for splitting up multiple recipients on single recipients input is not supported because ";" has another meaning per RFCs.

However, the following will work:

To: user1@domain.com,  user2@domain.com, user3@domain.com [Enter]

> Expected results:
> 
> add some letters of email address and get autocomplete suggestion from
> address book, for any number entered emails in one [To:] line.

Yes, that's bug 440377, which includes bug 392932.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 440377
You need to log in before you can comment on or make changes to this bug.