Status

()

P3
normal
VERIFIED DUPLICATE of bug 8929
19 years ago
16 years ago

People

(Reporter: warrensomebody, Assigned: braddr)

Tracking

Trunk
All
Other
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
We should eliminate the NS_COMFALSE madness once and for all. Here's a list of
offending uses in your module -- please pass the bug along if there's someone
else who should deal with it.

      widget/src/xpwidgets/nsBaseWidget.cpp:
            View change log or Blame annotations
            line 566

Updated

19 years ago
Blocks: 8929

Comment 1

19 years ago
I don't know anything about this.  I've never written any code in this file.
(Reporter)

Updated

19 years ago
Assignee: hyatt → mjudge
(Reporter)

Comment 2

19 years ago
I looked up the author, looks like Mike Judge.

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WONTFIX

Comment 3

19 years ago
yeah yeah we need to remove it since the javascript calls cant handle it. thats
fine but I dont think i will get to this anytime soon seeing how pervasive the
use of nsIEnumerators are now. the nsIBasicEnumerator is a "basic" version of a
javascript happy interface that should be usable. if anyone REALLY needs this
change then lets start a client wide acknowlegement to use nsIEnumerator2 for
example.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 4

19 years ago
Based on mike's comments, marking as verified won't fix.

Updated

19 years ago
Status: VERIFIED → REOPENED

Updated

19 years ago
Assignee: mjudge → brendan
Status: REOPENED → NEW

Updated

19 years ago
Status: NEW → ASSIGNED

Updated

19 years ago
Resolution: WONTFIX → ---

Comment 5

19 years ago
If no one minds, I'll fix this after beta.  There is a client-wide move toward
nsISimpleEnumerator, it's been all over the xpcom newsgroup and in the mozilla
architecture meeting.  It isn't going to get constant fanfare, but it has
already happened to a great degree (query bugzilla for resolved bugs to do with
NS_COMFALSE).  The mailnews guys have done much great work.  Why stop short of
completion?

/be
(Reporter)

Comment 6

19 years ago
Good. We should get rid of all this crap like NS_COMFALSE and nsIEnumerator.
I'm glad someone's doing it.

Updated

19 years ago
Target Milestone: M15

Updated

19 years ago
Assignee: brendan → braddr
Status: ASSIGNED → NEW
I think braddr is driving this to a good conclusion throughout the tree.

/be
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED

Comment 8

19 years ago
Since this cleanup task is not an M15 stability blocker, I'm pushing it off to 
M16 (to help allow us to branch for M15).
Target Milestone: M15 → M16

Comment 9

19 years ago
NS_COMFALSE is no longer in /widget/src/xpwidgets/nsbasewidget.cpp

Search shows NO listing for NS_COMFALSE in /widget branch

This bug can be resolved fixed.

Comment 10

18 years ago
M16 has been out for a while now, these bugs target milestones need to be 
updated.
(Assignee)

Comment 11

18 years ago
Moving out a few milestones.
Target Milestone: M16 → M18

Comment 12

18 years ago
Milestone 0.8 has been released. We should either resolve this bug or update its
milestone.

Updated

18 years ago
Target Milestone: M18 → ---

Comment 13

18 years ago
Moving to XP Toolkit/Widgets component.
Component: Layout → XP Toolkit/Widgets: Trees

Updated

18 years ago
Component: XP Toolkit/Widgets: Trees → XP Toolkit/Widgets

Comment 14

17 years ago
I think this one was fixed long ago, so could we close it now ? 
and perhaps #11592, #11595 and some more in #8929...

/jc

Comment 15

17 years ago
i count 20 users that usually doesn't match my definition of eliminate (it 
might match decimate but ...)

*** This bug has been marked as a duplicate of 8929 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago16 years ago
Resolution: --- → DUPLICATE

Comment 17

16 years ago
v
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.