Closed Bug 1159813 Opened 5 years ago Closed 5 years ago

Make sure service worker tests clean up after themselves

Categories

(Core :: DOM: Core & HTML, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla40
Tracking Status
firefox40 --- fixed

People

(Reporter: ehsan, Assigned: ehsan)

References

Details

Attachments

(1 file)

This makes it possible to run the service workers tests using
--run-until-failure, which will hopefully help with reproducing
intermittent test failures.
Attachment #8599410 - Flags: review?(amarchesini)
Assignee: nobody → ehsan
Attachment #8599410 - Flags: review?(amarchesini) → review+
Backed out in https://hg.mozilla.org/integration/mozilla-inbound/rev/4344c0378fe6 for failing like https://treeherder.mozilla.org/logviewer.html#?job_id=9430017&repo=mozilla-inbound.

Wish I could tell you the platforms where it fails, but we've gotten so stupid cheap that we hardly run any tests at all on most platforms now. Android and Mulet consistently failed, as did Linux64 opt the one time we ran tests on you there. Other than that, it's anybody's (or rather, try: -p all -u all's) guess where else it fails.
Flags: needinfo?(ehsan)
This failure happened because with my change unregister() would no longer return a value, so sometimes the promise chain would resolve down to the SimpleTest.finish() call faster than unregister would finish its work, in which case the test would fail.
Flags: needinfo?(ehsan)
https://hg.mozilla.org/mozilla-central/rev/57fc3025cf99
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla40
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.