Proxy: HTTP 1.1 compliant

VERIFIED DUPLICATE of bug 38488

Status

()

Core
Networking
--
enhancement
VERIFIED DUPLICATE of bug 38488
16 years ago
15 years ago

People

(Reporter: Alexander Skwar, Assigned: neeti)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
At work, we've got to use a proxy to connect to the internet.  Sometimes, I get
the following error message from the proxy:

Your client has attempted to perform a request in a manner not allowed by the
HTTP protocol standard. If you are using Microsoft Internet Explorer, make sure
the "Use HTTP 1.1 through proxy connections" option is disabled, and click
reload to try again. This error may also be caused by using MIE version 4
without Service Pack 2 (or HotFix #2798) installed.


When I set the HTTP version to 1.0 at Debug->Networking, I do not get this error
message.  However, since this setting is at the Debug prefs pane, I "fear" that
the setting will go away once a final will be released.

Because I suppose quite some people might need this setting, it should always be
accessible thru the prefs dialog.

Comment 1

16 years ago
Bug 38488 discusses this issue and the possibility of a new pref in the proxy
dialog for HTTP 1.0 compatibility.

*** This bug has been marked as a duplicate of 38488 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

15 years ago
VERIFIED/dupe.
Status: RESOLVED → VERIFIED
Summary: Not HTTP 1.1 compliant proxy → Proxy: HTTP 1.1 compliant
You need to log in before you can comment on or make changes to this bug.