Can't play locally stored videos anymore

RESOLVED WORKSFORME

Status

()

Firefox
Untriaged
RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: steven.goss, Unassigned)

Tracking

36 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20150305021524

Steps to reproduce:

Used address:
   file://localhost/Volumes/xyz/VideoFile.MP4 
in the browser URL/address window to attempt to play a locally stored video on my Mac.  Now, instead of playing back the video file, it pops up a dialog box for saving the target of that URL.   (But it certainly never plays back the video file like it used to).


Actual results:

Where I expected video playback (in the browser) to begin, instead I was greeted with a file save dialog box.

Bottom line, disappointment, no video playback.


Expected results:

Somewhere in the last few major revisions Firefox must have been changed so that local multi-media content (like .MP4) is handled differently.  (At least on the Mac OsX version).  I'm running Mac OsX 10.9.2.

Comment 1

3 years ago
1. Update Firefox to the latest version.
https://support.mozilla.org/kb/update-firefox-latest-version

2. In the address bar, paste the following, then press Enter:
about:config?filter=media.play-stand-alone

3. To bypass the warning, press the big button labeled “I'll be careful, I promise!”.

4. In the search results, make sure “media.play-stand-alone” is at its default value, “true”. If it isn't, right-click it (or Ctrl+click it) and choose Reset.

5. If the problem persists, check if you have the same issue when you start Firefox in a brand new profile.
https://support.mozilla.org/kb/profile-manager-create-and-remove-firefox-profiles
Flags: needinfo?(steven.goss)
(Reporter)

Comment 2

3 years ago
Problem remains (after):

1. Updated from Firefox 36.x to 37.0.2
2. Insured the "filter=media.play-stand-alone" was set to true (per your #2 above)
      a. Was already there, but I set it to false (reloaded browser), then back to true (reloaded again)
3. Created new profile, still, no change, file-save dialog still pops up on attempting to play local video.


At this point, I think there is something more obscure going on.  (possibly some new bug in Firefox).
Flags: needinfo?(steven.goss)

Comment 3

3 years ago
I've tested both Windows 7 x64 and Linux Mint KDE 17.1, and it works for me. This may be Mac-specific.

(In reply to steven.goss from comment #0)
> Somewhere in the last few major revisions Firefox must have been changed so
> that local multi-media content (like .MP4) is handled differently.  (At
> least on the Mac OsX version).
(In reply to steven.goss from comment #2)
> At this point, I think there is something more obscure going on.  (possibly
> some new bug in Firefox).

Could you try to find the regression range?
http://mozilla.github.io/mozregression/
Keywords: regressionwindow-wanted
OS: Unspecified → Mac OS X
Hardware: Unspecified → x86
Steven, does this still reproduce for you? If so, would you be willing to try narrowing down this problem with the mozregression tool so we can get a better handle on what changed? Looks like attempts to reproduce on other platforms haven't gone well :(
(Reporter)

Comment 5

2 years ago
After learning of the "extension" signing fiasco on Firefox, via my own huge fiasco here trying to get extensions working on browsers, I've decided to leave the Mozilla camp.  This was just the last straw for me.  Firefox used to be a great browser, but in the last 2 years the "pain threshold" of keeping it running without losing productivity has grown to great.  It's no longer a useful tool in my camp.

It's too bad that decision makers at Mozilla have progressively made worse and worse choices.

Please close me out on this case.

Best of luck! I know there are a lot of developers that have really put a lot of work into the products over the years.   

(Maybe, with some luck, you'll get some better decision makers, b4 the current ones drive Mozilla into the abyss, but sometimes things have to get really bad b4 someone says we've got to change directions).
Sorry to hear that, but thanks for the reply.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Keywords: regressionwindow-wanted
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.