Closed Bug 1160070 Opened 5 years ago Closed 4 years ago

Display issues since FF37 with D2D 1.1

Categories

(Core :: Graphics, defect)

37 Branch
Unspecified
Windows
defect
Not set

Tracking

()

VERIFIED FIXED
mozilla41
Tracking Status
firefox40 --- verified
firefox41 --- verified

People

(Reporter: milka16, Assigned: bas.schouten)

References

Details

(Keywords: regression, Whiteboard: gfx-noted)

Attachments

(4 files, 2 obsolete files)

User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:37.0) Gecko/20100101 Firefox/37.0
Build ID: 20150415140819

Steps to reproduce:

Entering text on websites that have text fields (like http://reiseauskunft.bahn.de/bin/query2.exe/en?ld=96252&country=DEU&rt=1&newrequest=yes&&country=USA). Then entering text into the next field (with tab or a mouse click).

Selecting text on random websites.



Actual results:

- Text fields dissapear.
- Selected text disappears.


Expected results:


- Text field should have not disappeared
- When selecting text, the text should not disappear
Possibly related: bug 1157342.

1. Type about:support into the location bar and press Enter.
2. Click the Copy Text to Cliboard button.
3. Paste the clipboard contents in a comment reply here.
4. Do you have the same problem when you start Firefox in a brand new profile?
https://support.mozilla.org/kb/profile-manager-create-and-remove-firefox-profiles

―――――――

I can't reproduce this on Windows 7 x64.

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:37.0) Gecko/20100101 Firefox/37.0
Version: 37.0.2

Adapter Description: NVIDIA GeForce 210
Adapter Drivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
Adapter RAM: 128
Device ID: 0x0a65
Direct2D Enabled: true
DirectWrite Enabled: true (6.2.9200.16571)
Driver Date: 7-2-2014
Driver Version: 9.18.13.4052
GPU #2 Active: false
GPU Accelerated Windows: 1/1 Direct3D 11 (OMTC)
Subsys ID: 34ee1458
Vendor ID: 0x10de
WebGL Renderer: Google Inc. -- ANGLE (NVIDIA GeForce 210 Direct3D11 vs_4_1 ps_4_1)
windowLayerManagerRemote: true
AzureCanvasBackend: direct2d 1.1
AzureContentBackend: direct2d 1.1
AzureFallbackCanvasBackend: cairo
AzureSkiaAccelerated: 0
Flags: needinfo?(milka16)
Hi,

thanks for getting back. I have created a new profile and the problem is visible there, too. This issue wasn't there in FF36 and earlier.

Here are is the config info (from the profile I use all the time):

Application Basics
------------------

Name: Firefox
Version: 37.0.2
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:37.0) Gecko/20100101 Firefox/37.0
Multiprocess Windows: 0/1

Crash Reports for the Last 3 Days
---------------------------------

All Crash Reports

Extensions
----------

Name: Adblock Edge
Version: 2.1.9
Enabled: true
ID: {fe272bd1-5f76-4ea4-8501-a05d35d823fc}

Name: Flagfox
Version: 5.0.14
Enabled: true
ID: {1018e4d6-728f-4b20-ad56-37578a4de76b}

Name: Ghostery
Version: 5.4.5
Enabled: true
ID: firefox@ghostery.com

Name: NoScript
Version: 2.6.9.22
Enabled: true
ID: {73a6fe31-595d-460b-a920-fcc0f8843232}

Name: Status-4-Evar
Version: 2015.02.06.23
Enabled: true
ID: status4evar@caligonstudios.com

Name: Web Developer
Version: 1.2.5
Enabled: true
ID: {c45c406e-ab73-11d8-be73-000a95be3b12}

Name: WorldIP
Version: 3.0.8
Enabled: true
ID: {f36c6cd1-da73-491d-b290-8fc9115bfa55}

Name: Adobe Acrobat - Create PDF
Version: 2.0
Enabled: false
ID: web2pdfextension@web2pdf.adobedotcom

Graphics
--------

Adapter Description: Intel(R) HD Graphics
Adapter Drivers: igdumd64 igd10umd64 igd10umd64 igdumd32 igd10umd32 igd10umd32
Adapter RAM: Unknown
Device ID: 0x0102
Direct2D Enabled: true
DirectWrite Enabled: true (6.3.9600.17415)
Driver Date: 1-30-2015
Driver Version: 9.17.10.4101
GPU #2 Active: false
GPU Accelerated Windows: 1/1 Direct3D 11 (OMTC)
Subsys ID: 047e1028
Vendor ID: 0x8086
WebGL Renderer: Google Inc. -- ANGLE (Intel(R) HD Graphics Direct3D9Ex vs_3_0 ps_3_0)
windowLayerManagerRemote: true
AzureCanvasBackend: direct2d 1.1
AzureContentBackend: direct2d 1.1
AzureFallbackCanvasBackend: cairo
AzureSkiaAccelerated: 0

Important Modified Preferences
------------------------------

accessibility.typeaheadfind.flashBar: 0
browser.cache.disk.capacity: 358400
browser.cache.disk.smart_size.first_run: false
browser.cache.disk.smart_size.use_old_max: false
browser.cache.frecency_experiment: 3
browser.fixup.domainwhitelist.nas: true
browser.places.smartBookmarksVersion: 7
browser.search.useDBForOrder: true
browser.sessionstore.upgradeBackup.latestBuildID: 20150415140819
browser.startup.homepage: about:home
browser.startup.homepage_override.buildID: 20150415140819
browser.startup.homepage_override.mstone: 37.0.2
browser.tabs.warnOnClose: false
dom.mozApps.used: true
extensions.lastAppVersion: 37.0.2
font.internaluseonly.changed: true
gfx.direct3d.last_used_feature_level_idx: 0
media.gmp-gmpopenh264.lastUpdate: 1423247989
media.gmp-gmpopenh264.version: 1.3
media.gmp-manager.lastCheck: 1430379594
network.cookie.prefsMigrated: true
places.database.lastMaintenance: 1430325198
places.history.expiration.transient_current_max_pages: 104858
plugin.disable_full_page_plugin_for_types: application/pdf
plugin.importedState: true
plugin.state.npadobeaamdetect: 0
plugin.state.npctrl: 1
plugin.state.npgoogleupdate: 0
plugin.state.npitunes: 0
plugin.state.npmeetingjoinpluginoc: 1
plugin.state.nppdf: 1
plugin.state.npspwrap: 1
print.printer_Adobe_PDF.print_bgcolor: false
print.printer_Adobe_PDF.print_bgimages: false
print.printer_Adobe_PDF.print_colorspace:
print.printer_Adobe_PDF.print_command:
print.printer_Adobe_PDF.print_downloadfonts: false
print.printer_Adobe_PDF.print_duplex: 1515870810
print.printer_Adobe_PDF.print_edge_bottom: 0
print.printer_Adobe_PDF.print_edge_left: 0
print.printer_Adobe_PDF.print_edge_right: 0
print.printer_Adobe_PDF.print_edge_top: 0
print.printer_Adobe_PDF.print_evenpages: true
print.printer_Adobe_PDF.print_footercenter:
print.printer_Adobe_PDF.print_footerleft: &PT
print.printer_Adobe_PDF.print_footerright: &D
print.printer_Adobe_PDF.print_headercenter:
print.printer_Adobe_PDF.print_headerleft: &T
print.printer_Adobe_PDF.print_headerright: &U
print.printer_Adobe_PDF.print_in_color: true
print.printer_Adobe_PDF.print_margin_bottom: 0.5
print.printer_Adobe_PDF.print_margin_left: 0.5
print.printer_Adobe_PDF.print_margin_right: 0.5
print.printer_Adobe_PDF.print_margin_top: 0.5
print.printer_Adobe_PDF.print_oddpages: true
print.printer_Adobe_PDF.print_orientation: 0
print.printer_Adobe_PDF.print_page_delay: 50
print.printer_Adobe_PDF.print_paper_data: 9
print.printer_Adobe_PDF.print_paper_height: 11.00
print.printer_Adobe_PDF.print_paper_name:
print.printer_Adobe_PDF.print_paper_size_type: 0
print.printer_Adobe_PDF.print_paper_size_unit: 1
print.printer_Adobe_PDF.print_paper_width: 8.00
print.printer_Adobe_PDF.print_plex_name:
print.printer_Adobe_PDF.print_resolution: 1515870810
print.printer_Adobe_PDF.print_resolution_name:
print.printer_Adobe_PDF.print_reversed: false
print.printer_Adobe_PDF.print_scaling: 1.00
print.printer_Adobe_PDF.print_shrink_to_fit: true
print.printer_Adobe_PDF.print_to_file: false
print.printer_Adobe_PDF.print_unwriteable_margin_bottom: 0
print.printer_Adobe_PDF.print_unwriteable_margin_left: 0
print.printer_Adobe_PDF.print_unwriteable_margin_right: 0
print.printer_Adobe_PDF.print_unwriteable_margin_top: 0
print.printer_HP_Officejet_Pro_L7500_Series.print_bgcolor: false
print.printer_HP_Officejet_Pro_L7500_Series.print_bgimages: false
print.printer_HP_Officejet_Pro_L7500_Series.print_colorspace:
print.printer_HP_Officejet_Pro_L7500_Series.print_command:
print.printer_HP_Officejet_Pro_L7500_Series.print_downloadfonts: false
print.printer_HP_Officejet_Pro_L7500_Series.print_duplex: 1515870810
print.printer_HP_Officejet_Pro_L7500_Series.print_edge_bottom: 0
print.printer_HP_Officejet_Pro_L7500_Series.print_edge_left: 0
print.printer_HP_Officejet_Pro_L7500_Series.print_edge_right: 0
print.printer_HP_Officejet_Pro_L7500_Series.print_edge_top: 0
print.printer_HP_Officejet_Pro_L7500_Series.print_evenpages: true
print.printer_HP_Officejet_Pro_L7500_Series.print_footercenter:
print.printer_HP_Officejet_Pro_L7500_Series.print_footerleft: &PT
print.printer_HP_Officejet_Pro_L7500_Series.print_footerright: &D
print.printer_HP_Officejet_Pro_L7500_Series.print_headercenter:
print.printer_HP_Officejet_Pro_L7500_Series.print_headerleft: &T
print.printer_HP_Officejet_Pro_L7500_Series.print_headerright: &U
print.printer_HP_Officejet_Pro_L7500_Series.print_in_color: true
print.printer_HP_Officejet_Pro_L7500_Series.print_margin_bottom: 0.5
print.printer_HP_Officejet_Pro_L7500_Series.print_margin_left: 0.5
print.printer_HP_Officejet_Pro_L7500_Series.print_margin_right: 0.5
print.printer_HP_Officejet_Pro_L7500_Series.print_margin_top: 0.5
print.printer_HP_Officejet_Pro_L7500_Series.print_oddpages: true
print.printer_HP_Officejet_Pro_L7500_Series.print_orientation: 0
print.printer_HP_Officejet_Pro_L7500_Series.print_page_delay: 50
print.printer_HP_Officejet_Pro_L7500_Series.print_paper_data: 9
print.printer_HP_Officejet_Pro_L7500_Series.print_paper_height: 11.00
print.printer_HP_Officejet_Pro_L7500_Series.print_paper_name:
print.printer_HP_Officejet_Pro_L7500_Series.print_paper_size_type: 0
print.printer_HP_Officejet_Pro_L7500_Series.print_paper_size_unit: 1
print.printer_HP_Officejet_Pro_L7500_Series.print_paper_width: 8.00
print.printer_HP_Officejet_Pro_L7500_Series.print_plex_name:
print.printer_HP_Officejet_Pro_L7500_Series.print_resolution: 1515870810
print.printer_HP_Officejet_Pro_L7500_Series.print_resolution_name:
print.printer_HP_Officejet_Pro_L7500_Series.print_reversed: false
print.printer_HP_Officejet_Pro_L7500_Series.print_scaling: 1.00
print.printer_HP_Officejet_Pro_L7500_Series.print_shrink_to_fit: true
print.printer_HP_Officejet_Pro_L7500_Series.print_to_file: false
print.printer_HP_Officejet_Pro_L7500_Series.print_unwriteable_margin_bottom: 0
print.printer_HP_Officejet_Pro_L7500_Series.print_unwriteable_margin_left: 0
print.printer_HP_Officejet_Pro_L7500_Series.print_unwriteable_margin_right: 0
print.printer_HP_Officejet_Pro_L7500_Series.print_unwriteable_margin_top: 0
privacy.donottrackheader.enabled: true
privacy.sanitize.migrateFx3Prefs: true
storage.vacuum.last.index: 1
storage.vacuum.last.places.sqlite: 1427899761

Important Locked Preferences
----------------------------

JavaScript
----------

Incremental GC: true

Accessibility
-------------

Activated: false
Prevent Accessibility: 0

Library Versions
----------------

NSPR
Expected minimum version: 4.10.8
Version in use: 4.10.8

NSS
Expected minimum version: 3.17.4 Basic ECC
Version in use: 3.17.4 Basic ECC

NSSSMIME
Expected minimum version: 3.17.4 Basic ECC
Version in use: 3.17.4 Basic ECC

NSSSSL
Expected minimum version: 3.17.4 Basic ECC
Version in use: 3.17.4 Basic ECC

NSSUTIL
Expected minimum version: 3.17.4
Version in use: 3.17.4

Experimental Features
---------------------
Flags: needinfo?(milka16)
If FF36 worked but not FF37, could you install the tool mozregression to find a regression range, please.
See http://mozilla.github.io/mozregression/

FF37 nightlies started in Nov 2014, so --good=2014-11-01 is a good start.
No need to bisect, just copy the console outpout when you have the good and the bad builds with the pushlog.
Flags: needinfo?(milka16)
So I ran this. But why is it downloading FF38? Anyways the FF that opens with that command has the same issue.


C:\Users\user>mozregression --good=2014-11-01
C:\Python27\lib\site-packages\requests\packages\urllib3\util\ssl_.py:90: Insecur
ePlatformWarning: A true SSLContext object is not available. This prevents urlli
b3 from configuring SSL appropriately and may cause certain SSL connections to f
ail. For more information, see https://urllib3.readthedocs.org/en/latest/securit
y.html#insecureplatformwarning.
  InsecurePlatformWarning
 0:00.36 LOG: MainThread INFO No 'bad' date specified, using 2015-05-02
 0:16.69 LOG: MainThread Bisector INFO Downloading build from: http://ftp.mozill
a.org/pub/mozilla.org/firefox/nightly/2015/01/2015-01-31-03-02-30-mozilla-centra
l/firefox-38.0a1.en-US.win64-x86_64.zip
===== Downloaded 100% =====
 0:58.43 LOG: MainThread Test Runner INFO Running nightly for 2015-01-31
 0:59.36 LOG: MainThread Test Runner INFO Launching c:\users\user\appdata\local\
temp\tmpfpx3q2\firefox\firefox.exe
 0:59.38 LOG: MainThread mozversion INFO application_buildid: 20150131030230
 0:59.38 LOG: MainThread mozversion INFO application_changeset: d7e156a7a0a6
 0:59.38 LOG: MainThread mozversion INFO application_display_name: Nightly
 0:59.38 LOG: MainThread mozversion INFO application_id: {ec8030f7-c20a-464f-9b0
e-13a3a9e97384}
 0:59.38 LOG: MainThread mozversion INFO application_name: Firefox
 0:59.38 LOG: MainThread mozversion INFO application_remotingname: firefox
 0:59.38 LOG: MainThread mozversion INFO application_repository: https://hg.mozi
lla.org/mozilla-central
 0:59.38 LOG: MainThread mozversion INFO application_vendor: Mozilla
 0:59.38 LOG: MainThread mozversion INFO application_version: 38.0a1
 0:59.38 LOG: MainThread mozversion INFO platform_buildid: 20150131030230
 0:59.38 LOG: MainThread mozversion INFO platform_changeset: d7e156a7a0a6
 0:59.38 LOG: MainThread mozversion INFO platform_repository: https://hg.mozilla
.org/mozilla-central
 0:59.38 LOG: MainThread mozversion INFO platform_version: 38.0a1
Was this nightly build good, bad, or broken? (type 'good', 'bad', 'skip', 'retry
' or 'exit' and press Enter):
Flags: needinfo?(milka16)
So I typed bad for all versions it offered since the issue was visible for all versions:

https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=b695d9575654&tochange=0e631971b841

 0:00.45 LOG: MainThread INFO No 'bad' date specified, using 2015-05-02
 0:11.83 LOG: MainThread Bisector INFO Downloading build from: http://ftp.mozill
a.org/pub/mozilla.org/firefox/nightly/2015/01/2015-01-31-03-02-30-mozilla-centra
l/firefox-38.0a1.en-US.win64-x86_64.zip
===== Downloaded 100% =====
 0:38.33 LOG: MainThread Test Runner INFO Running nightly for 2015-01-31
 0:39.16 LOG: MainThread Test Runner INFO Launching c:\users\user\appdata\local\
temp\tmpzcgh4y\firefox\firefox.exe
 0:39.18 LOG: MainThread mozversion INFO application_buildid: 20150131030230
 0:39.18 LOG: MainThread mozversion INFO application_changeset: d7e156a7a0a6
 0:39.18 LOG: MainThread mozversion INFO application_display_name: Nightly
 0:39.18 LOG: MainThread mozversion INFO application_id: {ec8030f7-c20a-464f-9b0
e-13a3a9e97384}
 0:39.18 LOG: MainThread mozversion INFO application_name: Firefox
 0:39.18 LOG: MainThread mozversion INFO application_remotingname: firefox
 0:39.18 LOG: MainThread mozversion INFO application_repository: https://hg.mozi
lla.org/mozilla-central
 0:39.18 LOG: MainThread mozversion INFO application_vendor: Mozilla
 0:39.18 LOG: MainThread mozversion INFO application_version: 38.0a1
 0:39.18 LOG: MainThread mozversion INFO platform_buildid: 20150131030230
 0:39.18 LOG: MainThread mozversion INFO platform_changeset: d7e156a7a0a6
 0:39.18 LOG: MainThread mozversion INFO platform_repository: https://hg.mozilla
.org/mozilla-central
 0:39.18 LOG: MainThread mozversion INFO platform_version: 38.0a1
Was this nightly build good, bad, or broken? (type 'good', 'bad', 'skip', 'retry
' or 'exit' and press Enter): retry
 2:03.68 LOG: MainThread Bisector INFO Using local file: c:\users\user\appdata\l
ocal\temp\tmpset71q\2015-01-31--mozilla-central--firefox-38.0a1.en-US.win64-x86_
64.zip
 2:03.68 LOG: MainThread Test Runner INFO Running nightly for 2015-01-31
 2:04.55 LOG: MainThread Test Runner INFO Launching c:\users\user\appdata\local\
temp\tmptw16ot\firefox\firefox.exe
 2:04.58 LOG: MainThread mozversion INFO application_buildid: 20150131030230
 2:04.58 LOG: MainThread mozversion INFO application_changeset: d7e156a7a0a6
 2:04.58 LOG: MainThread mozversion INFO application_display_name: Nightly
 2:04.58 LOG: MainThread mozversion INFO application_id: {ec8030f7-c20a-464f-9b0
e-13a3a9e97384}
 2:04.58 LOG: MainThread mozversion INFO application_name: Firefox
 2:04.58 LOG: MainThread mozversion INFO application_remotingname: firefox
 2:04.58 LOG: MainThread mozversion INFO application_repository: https://hg.mozi
lla.org/mozilla-central
 2:04.58 LOG: MainThread mozversion INFO application_vendor: Mozilla
 2:04.58 LOG: MainThread mozversion INFO application_version: 38.0a1
 2:04.58 LOG: MainThread mozversion INFO platform_buildid: 20150131030230
 2:04.59 LOG: MainThread mozversion INFO platform_changeset: d7e156a7a0a6
 2:04.59 LOG: MainThread mozversion INFO platform_repository: https://hg.mozilla
.org/mozilla-central
 2:04.59 LOG: MainThread mozversion INFO platform_version: 38.0a1
Was this nightly build good, bad, or broken? (type 'good', 'bad', 'skip', 'retry
' or 'exit' and press Enter): Traceback (most recent call last):
  File "C:\Python27\Scripts\mozregression-script.py", line 9, in <module>
    load_entry_point('mozregression==0.36', 'console_scripts', 'mozregression')(
)


C:\Users\user>mozregression --good=2014-11-01
C:\Python27\lib\site-packages\requests\packages\urllib3\util\ssl_.py:90: Insecur
ePlatformWarning: A true SSLContext object is not available. This prevents urlli
b3 from configuring SSL appropriately and may cause certain SSL connections to f
ail. For more information, see https://urllib3.readthedocs.org/en/latest/securit
y.html#insecureplatformwarning.
  InsecurePlatformWarning
 0:00.36 LOG: MainThread INFO No 'bad' date specified, using 2015-05-02
 0:16.69 LOG: MainThread Bisector INFO Downloading build from: http://ftp.mozill
a.org/pub/mozilla.org/firefox/nightly/2015/01/2015-01-31-03-02-30-mozilla-centra
l/firefox-38.0a1.en-US.win64-x86_64.zip
===== Downloaded 100% =====
 0:58.43 LOG: MainThread Test Runner INFO Running nightly for 2015-01-31
 0:59.36 LOG: MainThread Test Runner INFO Launching c:\users\user\appdata\local\
temp\tmpfpx3q2\firefox\firefox.exe
 0:59.38 LOG: MainThread mozversion INFO application_buildid: 20150131030230
 0:59.38 LOG: MainThread mozversion INFO application_changeset: d7e156a7a0a6
 0:59.38 LOG: MainThread mozversion INFO application_display_name: Nightly
 0:59.38 LOG: MainThread mozversion INFO application_id: {ec8030f7-c20a-464f-9b0
e-13a3a9e97384}
 0:59.38 LOG: MainThread mozversion INFO application_name: Firefox
 0:59.38 LOG: MainThread mozversion INFO application_remotingname: firefox
 0:59.38 LOG: MainThread mozversion INFO application_repository: https://hg.mozi
lla.org/mozilla-central
 0:59.38 LOG: MainThread mozversion INFO application_vendor: Mozilla
 0:59.38 LOG: MainThread mozversion INFO application_version: 38.0a1
 0:59.38 LOG: MainThread mozversion INFO platform_buildid: 20150131030230
 0:59.38 LOG: MainThread mozversion INFO platform_changeset: d7e156a7a0a6
 0:59.38 LOG: MainThread mozversion INFO platform_repository: https://hg.mozilla
.org/mozilla-central
 0:59.38 LOG: MainThread mozversion INFO platform_version: 38.0a1
Was this nightly build good, bad, or broken? (type 'good', 'bad', 'skip', 'retry
' or 'exit' and press Enter): bad
 3:46.06 LOG: MainThread Bisector INFO Narrowed nightly regression window from [
2014-11-01, 2015-05-01] (181 days) to [2014-11-01, 2015-01-31] (91 days) (~6 ste
ps left)
 3:46.06 LOG: MainThread Bisector INFO Using local file: c:\users\user\appdata\l
ocal\temp\tmpkpb7dm\2014-12-17--mozilla-central--firefox-37.0a1.en-US.win64-x86_
64.zip (downloaded in background)
 3:54.26 LOG: MainThread Test Runner INFO Running nightly for 2014-12-17
 3:55.14 LOG: MainThread Test Runner INFO Launching c:\users\user\appdata\local\
temp\tmptvhtcs\firefox\firefox.exe
 3:55.16 LOG: MainThread mozversion INFO application_buildid: 20141217030202
 3:55.16 LOG: MainThread mozversion INFO application_changeset: b7eb1ce0237d
 3:55.16 LOG: MainThread mozversion INFO application_display_name: Nightly
 3:55.16 LOG: MainThread mozversion INFO application_id: {ec8030f7-c20a-464f-9b0
e-13a3a9e97384}
 3:55.16 LOG: MainThread mozversion INFO application_name: Firefox
 3:55.16 LOG: MainThread mozversion INFO application_remotingname: firefox
 3:55.16 LOG: MainThread mozversion INFO application_repository: https://hg.mozi
lla.org/mozilla-central
 3:55.16 LOG: MainThread mozversion INFO application_vendor: Mozilla
 3:55.16 LOG: MainThread mozversion INFO application_version: 37.0a1
 3:55.16 LOG: MainThread mozversion INFO platform_buildid: 20141217030202
 3:55.16 LOG: MainThread mozversion INFO platform_changeset: b7eb1ce0237d
 3:55.16 LOG: MainThread mozversion INFO platform_repository: https://hg.mozilla
.org/mozilla-central
 3:55.17 LOG: MainThread mozversion INFO platform_version: 37.0a1
Was this nightly build good, bad, or broken? (type 'good', 'bad', 'skip', 'retry
', 'back' or 'exit' and press Enter): bad
 4:27.51 LOG: MainThread Bisector INFO Narrowed nightly regression window from [
2014-11-01, 2015-01-31] (91 days) to [2014-11-01, 2014-12-17] (46 days) (~5 step
s left)
 4:27.51 LOG: MainThread Bisector INFO Using local file: c:\users\user\appdata\l
ocal\temp\tmpkpb7dm\2014-11-24--mozilla-central--firefox-36.0a1.en-US.win64-x86_
64.zip (downloaded in background)
 4:34.62 LOG: MainThread Test Runner INFO Running nightly for 2014-11-24
 4:35.50 LOG: MainThread Test Runner INFO Launching c:\users\user\appdata\local\
temp\tmpgylth9\firefox\firefox.exe
 4:35.52 LOG: MainThread mozversion INFO application_buildid: 20141124100136
 4:35.52 LOG: MainThread mozversion INFO application_changeset: be4ba3d5ca9a
 4:35.52 LOG: MainThread mozversion INFO application_display_name: Nightly
 4:35.52 LOG: MainThread mozversion INFO application_id: {ec8030f7-c20a-464f-9b0
e-13a3a9e97384}
 4:35.52 LOG: MainThread mozversion INFO application_name: Firefox
 4:35.52 LOG: MainThread mozversion INFO application_remotingname: firefox
 4:35.53 LOG: MainThread mozversion INFO application_repository: https://hg.mozi
lla.org/mozilla-central
 4:35.53 LOG: MainThread mozversion INFO application_vendor: Mozilla
 4:35.53 LOG: MainThread mozversion INFO application_version: 36.0a1
 4:35.53 LOG: MainThread mozversion INFO platform_buildid: 20141124100136
 4:35.53 LOG: MainThread mozversion INFO platform_changeset: be4ba3d5ca9a
 4:35.53 LOG: MainThread mozversion INFO platform_repository: https://hg.mozilla
.org/mozilla-central
 4:35.53 LOG: MainThread mozversion INFO platform_version: 36.0a1
Was this nightly build good, bad, or broken? (type 'good', 'bad', 'skip', 'retry
', 'back' or 'exit' and press Enter): bad
 5:00.99 LOG: MainThread Bisector INFO Narrowed nightly regression window from [
2014-11-01, 2014-12-17] (46 days) to [2014-11-01, 2014-11-24] (23 days) (~4 step
s left)
 5:00.99 LOG: MainThread Bisector INFO Using local file: c:\users\user\appdata\l
ocal\temp\tmpkpb7dm\2014-11-13--mozilla-central--firefox-36.0a1.en-US.win64-x86_
64.zip (downloaded in background)
 5:23.96 LOG: MainThread Test Runner INFO Running nightly for 2014-11-13
 5:24.78 LOG: MainThread Test Runner INFO Launching c:\users\user\appdata\local\
temp\tmpzkppa6\firefox\firefox.exe
 5:24.80 LOG: MainThread mozversion INFO application_buildid: 20141113030201
 5:24.80 LOG: MainThread mozversion INFO application_changeset: ab137ddd3746
 5:24.80 LOG: MainThread mozversion INFO application_display_name: Nightly
 5:24.80 LOG: MainThread mozversion INFO application_id: {ec8030f7-c20a-464f-9b0
e-13a3a9e97384}
 5:24.80 LOG: MainThread mozversion INFO application_name: Firefox
 5:24.80 LOG: MainThread mozversion INFO application_remotingname: firefox
 5:24.80 LOG: MainThread mozversion INFO application_repository: https://hg.mozi
lla.org/mozilla-central
 5:24.80 LOG: MainThread mozversion INFO application_vendor: Mozilla
 5:24.80 LOG: MainThread mozversion INFO application_version: 36.0a1
 5:24.80 LOG: MainThread mozversion INFO platform_buildid: 20141113030201
 5:24.80 LOG: MainThread mozversion INFO platform_changeset: ab137ddd3746
 5:24.80 LOG: MainThread mozversion INFO platform_repository: https://hg.mozilla
.org/mozilla-central
 5:24.80 LOG: MainThread mozversion INFO platform_version: 36.0a1
Was this nightly build good, bad, or broken? (type 'good', 'bad', 'skip', 'retry
', 'back' or 'exit' and press Enter): bad
 5:39.50 LOG: MainThread Bisector INFO Narrowed nightly regression window from [
2014-11-01, 2014-11-24] (23 days) to [2014-11-01, 2014-11-13] (12 days) (~3 step
s left)
 5:39.50 LOG: MainThread Bisector INFO Using local file: c:\users\user\appdata\l
ocal\temp\tmpkpb7dm\2014-11-07--mozilla-central--firefox-36.0a1.en-US.win64-x86_
64.zip (downloaded in background)
 5:43.39 LOG: MainThread Test Runner INFO Running nightly for 2014-11-07
 5:44.20 LOG: MainThread Test Runner INFO Launching c:\users\user\appdata\local\
temp\tmpkcibiy\firefox\firefox.exe
 5:44.22 LOG: MainThread mozversion INFO application_buildid: 20141107073659
 5:44.22 LOG: MainThread mozversion INFO application_changeset: b62ccf3228ba
 5:44.23 LOG: MainThread mozversion INFO application_display_name: Nightly
 5:44.23 LOG: MainThread mozversion INFO application_id: {ec8030f7-c20a-464f-9b0
e-13a3a9e97384}
 5:44.23 LOG: MainThread mozversion INFO application_name: Firefox
 5:44.23 LOG: MainThread mozversion INFO application_remotingname: firefox
 5:44.23 LOG: MainThread mozversion INFO application_repository: https://hg.mozi
lla.org/mozilla-central
 5:44.23 LOG: MainThread mozversion INFO application_vendor: Mozilla
 5:44.23 LOG: MainThread mozversion INFO application_version: 36.0a1
 5:44.23 LOG: MainThread mozversion INFO platform_buildid: 20141107073659
 5:44.23 LOG: MainThread mozversion INFO platform_changeset: b62ccf3228ba
 5:44.23 LOG: MainThread mozversion INFO platform_repository: https://hg.mozilla
.org/mozilla-central
 5:44.23 LOG: MainThread mozversion INFO platform_version: 36.0a1
Was this nightly build good, bad, or broken? (type 'good', 'bad', 'skip', 'retry
', 'back' or 'exit' and press Enter): bad
 6:00.88 LOG: MainThread Bisector INFO Narrowed nightly regression window from [
2014-11-01, 2014-11-13] (12 days) to [2014-11-01, 2014-11-07] (6 days) (~2 steps
 left)
 6:00.88 LOG: MainThread Bisector INFO Downloading build from: http://ftp.mozill
a.org/pub/mozilla.org/firefox/nightly/2014/11/2014-11-04-03-02-02-mozilla-centra
l/firefox-36.0a1.en-US.win64-x86_64.zip
===== Downloaded 100% =====
 6:13.18 LOG: MainThread Test Runner INFO Running nightly for 2014-11-04
 6:13.96 LOG: MainThread Test Runner INFO Launching c:\users\user\appdata\local\
temp\tmp4pcaxj\firefox\firefox.exe
 6:13.99 LOG: MainThread mozversion INFO application_buildid: 20141104030202
 6:13.99 LOG: MainThread mozversion INFO application_changeset: 5dde8ea48fef
 6:13.99 LOG: MainThread mozversion INFO application_display_name: Nightly
 6:13.99 LOG: MainThread mozversion INFO application_id: {ec8030f7-c20a-464f-9b0
e-13a3a9e97384}
 6:13.99 LOG: MainThread mozversion INFO application_name: Firefox
 6:13.99 LOG: MainThread mozversion INFO application_remotingname: firefox
 6:13.99 LOG: MainThread mozversion INFO application_repository: https://hg.mozi
lla.org/mozilla-central
 6:13.99 LOG: MainThread mozversion INFO application_vendor: Mozilla
 6:13.99 LOG: MainThread mozversion INFO application_version: 36.0a1
 6:13.99 LOG: MainThread mozversion INFO platform_buildid: 20141104030202
 6:13.99 LOG: MainThread mozversion INFO platform_changeset: 5dde8ea48fef
 6:13.99 LOG: MainThread mozversion INFO platform_repository: https://hg.mozilla
.org/mozilla-central
 6:13.99 LOG: MainThread mozversion INFO platform_version: 36.0a1
Was this nightly build good, bad, or broken? (type 'good', 'bad', 'skip', 'retry
', 'back' or 'exit' and press Enter): bad
 6:30.55 LOG: MainThread Bisector INFO Narrowed nightly regression window from [
2014-11-01, 2014-11-07] (6 days) to [2014-11-01, 2014-11-04] (3 days) (~1 steps
left)
 6:30.55 LOG: MainThread Bisector INFO Using local file: c:\users\user\appdata\l
ocal\temp\tmpkpb7dm\2014-11-03--mozilla-central--firefox-36.0a1.en-US.win64-x86_
64.zip (downloaded in background)
 6:33.03 LOG: MainThread Test Runner INFO Running nightly for 2014-11-03
 6:33.78 LOG: MainThread Test Runner INFO Launching c:\users\user\appdata\local\
temp\tmph_mdra\firefox\firefox.exe
 6:33.80 LOG: MainThread mozversion INFO application_buildid: 20141103030205
 6:33.80 LOG: MainThread mozversion INFO application_changeset: 0b81c10a9074
 6:33.80 LOG: MainThread mozversion INFO application_display_name: Nightly
 6:33.80 LOG: MainThread mozversion INFO application_id: {ec8030f7-c20a-464f-9b0
e-13a3a9e97384}
 6:33.80 LOG: MainThread mozversion INFO application_name: Firefox
 6:33.80 LOG: MainThread mozversion INFO application_remotingname: firefox
 6:33.80 LOG: MainThread mozversion INFO application_repository: https://hg.mozi
lla.org/mozilla-central
 6:33.80 LOG: MainThread mozversion INFO application_vendor: Mozilla
 6:33.80 LOG: MainThread mozversion INFO application_version: 36.0a1
 6:33.80 LOG: MainThread mozversion INFO platform_buildid: 20141103030205
 6:33.80 LOG: MainThread mozversion INFO platform_changeset: 0b81c10a9074
 6:33.80 LOG: MainThread mozversion INFO platform_repository: https://hg.mozilla
.org/mozilla-central
 6:33.80 LOG: MainThread mozversion INFO platform_version: 36.0a1
Was this nightly build good, bad, or broken? (type 'good', 'bad', 'skip', 'retry
', 'back' or 'exit' and press Enter): bad
 6:52.60 LOG: MainThread Bisector INFO Narrowed nightly regression window from [
2014-11-01, 2014-11-04] (3 days) to [2014-11-01, 2014-11-03] (2 days) (~1 steps
left)
 6:52.60 LOG: MainThread Bisector INFO Using local file: c:\users\user\appdata\l
ocal\temp\tmpkpb7dm\2014-11-02--mozilla-central--firefox-36.0a1.en-US.win64-x86_
64.zip (downloaded in background)
 6:52.60 LOG: MainThread Test Runner INFO Running nightly for 2014-11-02
 6:53.42 LOG: MainThread Test Runner INFO Launching c:\users\user\appdata\local\
temp\tmp2cj0vy\firefox\firefox.exe
 6:53.45 LOG: MainThread mozversion INFO application_buildid: 20141102030204
 6:53.45 LOG: MainThread mozversion INFO application_changeset: 0e631971b841
 6:53.45 LOG: MainThread mozversion INFO application_display_name: Nightly
 6:53.45 LOG: MainThread mozversion INFO application_id: {ec8030f7-c20a-464f-9b0
e-13a3a9e97384}
 6:53.45 LOG: MainThread mozversion INFO application_name: Firefox
 6:53.45 LOG: MainThread mozversion INFO application_remotingname: firefox
 6:53.45 LOG: MainThread mozversion INFO application_repository: https://hg.mozi
lla.org/mozilla-central
 6:53.45 LOG: MainThread mozversion INFO application_vendor: Mozilla
 6:53.46 LOG: MainThread mozversion INFO application_version: 36.0a1
 6:53.46 LOG: MainThread mozversion INFO platform_buildid: 20141102030204
 6:53.46 LOG: MainThread mozversion INFO platform_changeset: 0e631971b841
 6:53.46 LOG: MainThread mozversion INFO platform_repository: https://hg.mozilla
.org/mozilla-central
 6:53.46 LOG: MainThread mozversion INFO platform_version: 36.0a1
Was this nightly build good, bad, or broken? (type 'good', 'bad', 'skip', 'retry
', 'back' or 'exit' and press Enter): bad
 7:18.06 LOG: MainThread Bisector INFO Narrowed nightly regression window from [
2014-11-01, 2014-11-03] (2 days) to [2014-11-01, 2014-11-02] (1 days) (~0 steps
left)
 7:18.06 LOG: MainThread Bisector INFO Got as far as we can go bisecting nightli
es...
 7:18.06 LOG: MainThread Bisector INFO Last good revision: b695d9575654
 7:18.06 LOG: MainThread Bisector INFO First bad revision: 0e631971b841
 7:18.06 LOG: MainThread Bisector INFO Pushlog:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=b695d9575654&tocha
nge=0e631971b841

 7:18.06 LOG: MainThread Bisector INFO ... attempting to bisect inbound builds (
starting from 4 days ago, to make sure no inbound revision is missed)
 7:25.67 LOG: MainThread Bisector INFO Getting inbound builds between a255a23494
6e and 0e631971b841
 7:33.97 LOG: MainThread Bisector INFO No inbound data found.
 7:33.97 LOG: MainThread Bisector INFO There are no build dirs on inbound for th
ese changesets.
I have tested more. So it seems like this was broken in FF36 already (maybe I hadn't noticed). Some of the FF35 versions it presented were good. The FF32 and FF34 were good, too.

C:\Users\user>mozregression --good=2014-01-01 --bad=2014-11-01
C:\Python27\lib\site-packages\requests\packages\urllib3\util\ssl_.py:90: Insecur
ePlatformWarning: A true SSLContext object is not available. This prevents urlli
b3 from configuring SSL appropriately and may cause certain SSL connections to f
ail. For more information, see https://urllib3.readthedocs.org/en/latest/securit
y.html#insecureplatformwarning.
  InsecurePlatformWarning
 0:16.39 LOG: MainThread Bisector INFO Downloading build from: http://ftp.mozill
a.org/pub/mozilla.org/firefox/nightly/2014/06/2014-06-03-03-02-20-mozilla-centra
l/firefox-32.0a1.en-US.win64-x86_64.zip
===== Downloaded 100% =====
 0:40.59 LOG: MainThread Test Runner INFO Running nightly for 2014-06-03
 0:41.27 LOG: MainThread Test Runner INFO Launching c:\users\user\appdata\local\
temp\tmpofsacw\firefox\firefox.exe
 0:41.28 LOG: MainThread mozversion INFO application_buildid: 20140603030220
 0:41.28 LOG: MainThread mozversion INFO application_changeset: f28005b84ed0
 0:41.28 LOG: MainThread mozversion INFO application_display_name: Nightly
 0:41.28 LOG: MainThread mozversion INFO application_id: {ec8030f7-c20a-464f-9b0
e-13a3a9e97384}
 0:41.28 LOG: MainThread mozversion INFO application_name: Firefox
 0:41.28 LOG: MainThread mozversion INFO application_repository: https://hg.mozi
lla.org/mozilla-central
 0:41.28 LOG: MainThread mozversion INFO application_vendor: Mozilla
 0:41.28 LOG: MainThread mozversion INFO application_version: 32.0a1
 0:41.28 LOG: MainThread mozversion INFO platform_buildid: 20140603030220
 0:41.28 LOG: MainThread mozversion INFO platform_changeset: f28005b84ed0
 0:41.28 LOG: MainThread mozversion INFO platform_repository: https://hg.mozilla
.org/mozilla-central
 0:41.28 LOG: MainThread mozversion INFO platform_version: 32.0a1
Was this nightly build good, bad, or broken? (type 'good', 'bad', 'skip', 'retry
' or 'exit' and press Enter): good
 1:18.50 LOG: MainThread Bisector INFO Narrowed nightly regression window from [
2014-01-02, 2014-11-01] (303 days) to [2014-06-03, 2014-11-01] (151 days) (~7 st
eps left)
 1:18.50 LOG: MainThread Bisector INFO Using local file: c:\users\user\appdata\l
ocal\temp\tmpaat0h2\2014-08-18--mozilla-central--firefox-34.0a1.en-US.win64-x86_
64.zip (downloaded in background)
 1:30.33 LOG: MainThread Test Runner INFO Running nightly for 2014-08-18
 1:32.16 LOG: MainThread Test Runner INFO Launching c:\users\user\appdata\local\
temp\tmpm1hqse\firefox\firefox.exe
 1:32.18 LOG: MainThread mozversion INFO application_buildid: 20140818030205
 1:32.18 LOG: MainThread mozversion INFO application_changeset: 0aaa2d3d15cc
 1:32.18 LOG: MainThread mozversion INFO application_display_name: Nightly
 1:32.18 LOG: MainThread mozversion INFO application_id: {ec8030f7-c20a-464f-9b0
e-13a3a9e97384}
 1:32.18 LOG: MainThread mozversion INFO application_name: Firefox
 1:32.18 LOG: MainThread mozversion INFO application_repository: https://hg.mozi
lla.org/mozilla-central
 1:32.18 LOG: MainThread mozversion INFO application_vendor: Mozilla
 1:32.18 LOG: MainThread mozversion INFO application_version: 34.0a1
 1:32.18 LOG: MainThread mozversion INFO platform_buildid: 20140818030205
 1:32.18 LOG: MainThread mozversion INFO platform_changeset: 0aaa2d3d15cc
 1:32.18 LOG: MainThread mozversion INFO platform_repository: https://hg.mozilla
.org/mozilla-central
 1:32.18 LOG: MainThread mozversion INFO platform_version: 34.0a1
Was this nightly build good, bad, or broken? (type 'good', 'bad', 'skip', 'retry
', 'back' or 'exit' and press Enter): good
 1:52.11 LOG: MainThread Bisector INFO Narrowed nightly regression window from [
2014-06-03, 2014-11-01] (151 days) to [2014-08-18, 2014-11-01] (75 days) (~6 ste
ps left)
 1:52.11 LOG: MainThread Bisector INFO Using local file: c:\users\user\appdata\l
ocal\temp\tmpaat0h2\2014-09-25--mozilla-central--firefox-35.0a1.en-US.win64-x86_
64.zip (downloaded in background)
 1:59.73 LOG: MainThread Test Runner INFO Running nightly for 2014-09-25
 2:00.50 LOG: MainThread Test Runner INFO Launching c:\users\user\appdata\local\
temp\tmp8df7ig\firefox\firefox.exe
 2:00.51 LOG: MainThread mozversion INFO application_buildid: 20140925030203
 2:00.51 LOG: MainThread mozversion INFO application_changeset: 1735ff2bb23e
 2:00.51 LOG: MainThread mozversion INFO application_display_name: Nightly
 2:00.51 LOG: MainThread mozversion INFO application_id: {ec8030f7-c20a-464f-9b0
e-13a3a9e97384}
 2:00.51 LOG: MainThread mozversion INFO application_name: Firefox
 2:00.51 LOG: MainThread mozversion INFO application_repository: https://hg.mozi
lla.org/mozilla-central
 2:00.51 LOG: MainThread mozversion INFO application_vendor: Mozilla
 2:00.51 LOG: MainThread mozversion INFO application_version: 35.0a1
 2:00.51 LOG: MainThread mozversion INFO platform_buildid: 20140925030203
 2:00.51 LOG: MainThread mozversion INFO platform_changeset: 1735ff2bb23e
 2:00.52 LOG: MainThread mozversion INFO platform_repository: https://hg.mozilla
.org/mozilla-central
 2:00.52 LOG: MainThread mozversion INFO platform_version: 35.0a1
Was this nightly build good, bad, or broken? (type 'good', 'bad', 'skip', 'retry
', 'back' or 'exit' and press Enter): good
 2:22.19 LOG: MainThread Bisector INFO Narrowed nightly regression window from [
2014-08-18, 2014-11-01] (75 days) to [2014-09-25, 2014-11-01] (37 days) (~5 step
s left)
 2:22.19 LOG: MainThread Bisector INFO Using local file: c:\users\user\appdata\l
ocal\temp\tmpaat0h2\2014-10-14--mozilla-central--firefox-36.0a1.en-US.win64-x86_
64.zip (downloaded in background)
 2:27.03 LOG: MainThread Test Runner INFO Running nightly for 2014-10-14
 2:27.80 LOG: MainThread Test Runner INFO Launching c:\users\user\appdata\local\
temp\tmphafgpo\firefox\firefox.exe
 2:27.82 LOG: MainThread mozversion INFO application_buildid: 20141014030201
 2:27.82 LOG: MainThread mozversion INFO application_changeset: 54217864bae9
 2:27.82 LOG: MainThread mozversion INFO application_display_name: Nightly
 2:27.82 LOG: MainThread mozversion INFO application_id: {ec8030f7-c20a-464f-9b0
e-13a3a9e97384}
 2:27.82 LOG: MainThread mozversion INFO application_name: Firefox
 2:27.82 LOG: MainThread mozversion INFO application_repository: https://hg.mozi
lla.org/mozilla-central
 2:27.82 LOG: MainThread mozversion INFO application_vendor: Mozilla
 2:27.82 LOG: MainThread mozversion INFO application_version: 36.0a1
 2:27.82 LOG: MainThread mozversion INFO platform_buildid: 20141014030201
 2:27.82 LOG: MainThread mozversion INFO platform_changeset: 54217864bae9
 2:27.82 LOG: MainThread mozversion INFO platform_repository: https://hg.mozilla
.org/mozilla-central
 2:27.82 LOG: MainThread mozversion INFO platform_version: 36.0a1
Was this nightly build good, bad, or broken? (type 'good', 'bad', 'skip', 'retry
', 'back' or 'exit' and press Enter): bad
 2:46.33 LOG: MainThread Bisector INFO Narrowed nightly regression window from [
2014-09-25, 2014-11-01] (37 days) to [2014-09-25, 2014-10-14] (19 days) (~4 step
s left)
 2:46.33 LOG: MainThread Bisector INFO Downloading build from: http://ftp.mozill
a.org/pub/mozilla.org/firefox/nightly/2014/10/2014-10-05-03-02-05-mozilla-centra
l/firefox-35.0a1.en-US.win64-x86_64.zip
===== Downloaded 100% =====
 3:00.07 LOG: MainThread Test Runner INFO Running nightly for 2014-10-05
 3:00.98 LOG: MainThread Test Runner INFO Launching c:\users\user\appdata\local\
temp\tmpjyb3iu\firefox\firefox.exe
 3:01.00 LOG: MainThread mozversion INFO application_buildid: 20141005030205
 3:01.00 LOG: MainThread mozversion INFO application_changeset: 4b3d816c21fd
 3:01.00 LOG: MainThread mozversion INFO application_display_name: Nightly
 3:01.00 LOG: MainThread mozversion INFO application_id: {ec8030f7-c20a-464f-9b0
e-13a3a9e97384}
 3:01.00 LOG: MainThread mozversion INFO application_name: Firefox
 3:01.00 LOG: MainThread mozversion INFO application_repository: https://hg.mozi
lla.org/mozilla-central
 3:01.00 LOG: MainThread mozversion INFO application_vendor: Mozilla
 3:01.00 LOG: MainThread mozversion INFO application_version: 35.0a1
 3:01.00 LOG: MainThread mozversion INFO platform_buildid: 20141005030205
 3:01.00 LOG: MainThread mozversion INFO platform_changeset: 4b3d816c21fd
 3:01.00 LOG: MainThread mozversion INFO platform_repository: https://hg.mozilla
.org/mozilla-central
 3:01.00 LOG: MainThread mozversion INFO platform_version: 35.0a1
Was this nightly build good, bad, or broken? (type 'good', 'bad', 'skip', 'retry
', 'back' or 'exit' and press Enter): bad
 3:17.68 LOG: MainThread Bisector INFO Narrowed nightly regression window from [
2014-09-25, 2014-10-14] (19 days) to [2014-09-25, 2014-10-05] (10 days) (~3 step
s left)
 3:17.68 LOG: MainThread Bisector INFO Downloading build from: http://ftp.mozill
a.org/pub/mozilla.org/firefox/nightly/2014/09/2014-09-30-03-02-02-mozilla-centra
l/firefox-35.0a1.en-US.win64-x86_64.zip
===== Downloaded 100% =====
 3:32.43 LOG: MainThread Test Runner INFO Running nightly for 2014-09-30
 3:33.18 LOG: MainThread Test Runner INFO Launching c:\users\user\appdata\local\
temp\tmp4jkfeq\firefox\firefox.exe
 3:33.21 LOG: MainThread mozversion INFO application_buildid: 20140930030202
 3:33.21 LOG: MainThread mozversion INFO application_changeset: 7c24470b6b3a
 3:33.21 LOG: MainThread mozversion INFO application_display_name: Nightly
 3:33.21 LOG: MainThread mozversion INFO application_id: {ec8030f7-c20a-464f-9b0
e-13a3a9e97384}
 3:33.21 LOG: MainThread mozversion INFO application_name: Firefox
 3:33.21 LOG: MainThread mozversion INFO application_repository: https://hg.mozi
lla.org/mozilla-central
 3:33.21 LOG: MainThread mozversion INFO application_vendor: Mozilla
 3:33.21 LOG: MainThread mozversion INFO application_version: 35.0a1
 3:33.21 LOG: MainThread mozversion INFO platform_buildid: 20140930030202
 3:33.21 LOG: MainThread mozversion INFO platform_changeset: 7c24470b6b3a
 3:33.21 LOG: MainThread mozversion INFO platform_repository: https://hg.mozilla
.org/mozilla-central
 3:33.21 LOG: MainThread mozversion INFO platform_version: 35.0a1
Was this nightly build good, bad, or broken? (type 'good', 'bad', 'skip', 'retry
', 'back' or 'exit' and press Enter): good
 3:52.67 LOG: MainThread Bisector INFO Narrowed nightly regression window from [
2014-09-25, 2014-10-05] (10 days) to [2014-09-30, 2014-10-05] (5 days) (~2 steps
 left)
 3:52.68 LOG: MainThread Bisector INFO Downloading build from: http://ftp.mozill
a.org/pub/mozilla.org/firefox/nightly/2014/10/2014-10-03-03-02-04-mozilla-centra
l/firefox-35.0a1.en-US.win64-x86_64.zip
===== Downloaded 100% =====
 4:02.06 LOG: MainThread Test Runner INFO Running nightly for 2014-10-03
 4:02.79 LOG: MainThread Test Runner INFO Launching c:\users\user\appdata\local\
temp\tmpkwckyf\firefox\firefox.exe
 4:02.82 LOG: MainThread mozversion INFO application_buildid: 20141003030204
 4:02.82 LOG: MainThread mozversion INFO application_changeset: b85c260821ab
 4:02.82 LOG: MainThread mozversion INFO application_display_name: Nightly
 4:02.82 LOG: MainThread mozversion INFO application_id: {ec8030f7-c20a-464f-9b0
e-13a3a9e97384}
 4:02.82 LOG: MainThread mozversion INFO application_name: Firefox
 4:02.82 LOG: MainThread mozversion INFO application_repository: https://hg.mozi
lla.org/mozilla-central
 4:02.82 LOG: MainThread mozversion INFO application_vendor: Mozilla
 4:02.82 LOG: MainThread mozversion INFO application_version: 35.0a1
 4:02.82 LOG: MainThread mozversion INFO platform_buildid: 20141003030204
 4:02.82 LOG: MainThread mozversion INFO platform_changeset: b85c260821ab
 4:02.82 LOG: MainThread mozversion INFO platform_repository: https://hg.mozilla
.org/mozilla-central
 4:02.82 LOG: MainThread mozversion INFO platform_version: 35.0a1
Was this nightly build good, bad, or broken? (type 'good', 'bad', 'skip', 'retry
', 'back' or 'exit' and press Enter): bad
 4:30.10 LOG: MainThread Bisector INFO Narrowed nightly regression window from [
2014-09-30, 2014-10-05] (5 days) to [2014-09-30, 2014-10-03] (3 days) (~1 steps
left)
 4:30.10 LOG: MainThread Bisector INFO Using local file: c:\users\user\appdata\l
ocal\temp\tmpaat0h2\2014-10-02--mozilla-central--firefox-35.0a1.en-US.win64-x86_
64.zip (downloaded in background)
 4:33.55 LOG: MainThread Test Runner INFO Running nightly for 2014-10-02
 4:34.39 LOG: MainThread Test Runner INFO Launching c:\users\user\appdata\local\
temp\tmpuvq7rw\firefox\firefox.exe
 4:34.40 LOG: MainThread mozversion INFO application_buildid: 20141002093155
 4:34.40 LOG: MainThread mozversion INFO application_changeset: 5d6ec4dddf14
 4:34.40 LOG: MainThread mozversion INFO application_display_name: Nightly
 4:34.40 LOG: MainThread mozversion INFO application_id: {ec8030f7-c20a-464f-9b0
e-13a3a9e97384}
 4:34.41 LOG: MainThread mozversion INFO application_name: Firefox
 4:34.41 LOG: MainThread mozversion INFO application_repository: https://hg.mozi
lla.org/mozilla-central
 4:34.41 LOG: MainThread mozversion INFO application_vendor: Mozilla
 4:34.41 LOG: MainThread mozversion INFO application_version: 35.0a1
 4:34.41 LOG: MainThread mozversion INFO platform_buildid: 20141002093155
 4:34.41 LOG: MainThread mozversion INFO platform_changeset: 5d6ec4dddf14
 4:34.41 LOG: MainThread mozversion INFO platform_repository: https://hg.mozilla
.org/mozilla-central
 4:34.41 LOG: MainThread mozversion INFO platform_version: 35.0a1
Was this nightly build good, bad, or broken? (type 'good', 'bad', 'skip', 'retry
', 'back' or 'exit' and press Enter): bad
 4:48.82 LOG: MainThread Bisector INFO Narrowed nightly regression window from [
2014-09-30, 2014-10-03] (3 days) to [2014-09-30, 2014-10-02] (2 days) (~1 steps
left)
 4:48.82 LOG: MainThread Bisector INFO Using local file: c:\users\user\appdata\l
ocal\temp\tmpaat0h2\2014-10-01--mozilla-central--firefox-35.0a1.en-US.win64-x86_
64.zip (downloaded in background)
 4:48.82 LOG: MainThread Test Runner INFO Running nightly for 2014-10-01
 4:49.58 LOG: MainThread Test Runner INFO Launching c:\users\user\appdata\local\
temp\tmprvbhd9\firefox\firefox.exe
 4:49.60 LOG: MainThread mozversion INFO application_buildid: 20141001030205
 4:49.60 LOG: MainThread mozversion INFO application_changeset: 14665b1de5ee
 4:49.60 LOG: MainThread mozversion INFO application_display_name: Nightly
 4:49.60 LOG: MainThread mozversion INFO application_id: {ec8030f7-c20a-464f-9b0
e-13a3a9e97384}
 4:49.60 LOG: MainThread mozversion INFO application_name: Firefox
 4:49.60 LOG: MainThread mozversion INFO application_repository: https://hg.mozi
lla.org/mozilla-central
 4:49.60 LOG: MainThread mozversion INFO application_vendor: Mozilla
 4:49.60 LOG: MainThread mozversion INFO application_version: 35.0a1
 4:49.60 LOG: MainThread mozversion INFO platform_buildid: 20141001030205
 4:49.60 LOG: MainThread mozversion INFO platform_changeset: 14665b1de5ee
 4:49.60 LOG: MainThread mozversion INFO platform_repository: https://hg.mozilla
.org/mozilla-central
 4:49.60 LOG: MainThread mozversion INFO platform_version: 35.0a1
Was this nightly build good, bad, or broken? (type 'good', 'bad', 'skip', 'retry
', 'back' or 'exit' and press Enter): good
 5:06.60 LOG: MainThread Bisector INFO Narrowed nightly regression window from [
2014-09-30, 2014-10-02] (2 days) to [2014-10-01, 2014-10-02] (1 days) (~0 steps
left)
 5:06.60 LOG: MainThread Bisector INFO Got as far as we can go bisecting nightli
es...
 5:06.60 LOG: MainThread Bisector INFO Last good revision: 14665b1de5ee
 5:06.60 LOG: MainThread Bisector INFO First bad revision: 5d6ec4dddf14
 5:06.60 LOG: MainThread Bisector INFO Pushlog:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=14665b1de5ee&tocha
nge=5d6ec4dddf14

 5:06.60 LOG: MainThread Bisector INFO ... attempting to bisect inbound builds (
starting from 4 days ago, to make sure no inbound revision is missed)
 5:09.08 LOG: MainThread Bisector INFO Getting inbound builds between 818f353b7a
a6 and 5d6ec4dddf14
 5:17.24 LOG: MainThread Bisector INFO No inbound data found.
 5:17.24 LOG: MainThread Bisector INFO There are no build dirs on inbound for th
ese changesets.
tks, so pushlog:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=14665b1de5ee&tochange=5d6ec4dddf14

Suspect: Bug 902952


@milka16, Could you test with the following preferences in about:config?
gfx.direct2d.use1_1 = false
gfx.canvas.azure.backends = direct2d,cairo
gfx.content.azure.backends = direct2d,cairo
Blocks: 902952
Component: Untriaged → Graphics
Flags: needinfo?(milka16)
Keywords: regression
Product: Firefox → Core
After setting it to the issue seems to be gone.
Flags: needinfo?(milka16)
I mean after setting it to:

gfx.direct2d.use1_1 = false
gfx.canvas.azure.backends = direct2d,cairo
gfx.content.azure.backends = direct2d,cairo
Sounds like a D2D 1.1 bug.
Whiteboard: gfx-noted
Assignee: nobody → bas
(In reply to milka16 from comment #12)
> Problem is gone with FF38.

Does the problem still occur on latest nightly?
Duplicate of this bug: 1165261
(In reply to Bas Schouten (:bas.schouten) from comment #14)
> Does the problem still occur on latest nightly?

See bug 1165261, comment 5.
Hrm, 38 has D2D 1.1 as well as nightly.. I wonder what's going on here.
Sorry my account had been disabled. The issue is present in nightly 41.0a1 (2015-05-18), too.
Hi everyone, I just wanted to see if you have any news here? This is a massive problem and affects so many sites...
We're having trouble reproducing this locally on a number of different machines; this is a Dell?
Yes a Dell Optiplex 990
Bug 1169023 reports something that seems similar to this happening on an HD3000, I just checked my machines and I didn't have one of those. Do we have one of those perhaps that might reproduce the issue? With any luck it's the same bug.
Flags: needinfo?(milan)
The bug appeared on my Intel HD2000, but unfurtunately display from that PC is in repair service.
(In reply to Bas Schouten (:bas.schouten) from comment #22)
> Bug 1169023 reports something that seems similar to this happening on an
> HD3000, I just checked my machines and I didn't have one of those. Do we
> have one of those perhaps that might reproduce the issue? With any luck it's
> the same bug.

We do have an HD3000, we'll try to reproduce.
Flags: needinfo?(milan)
Summary: Display issues since FF37 → Display issues since FF37 with D2D 1.1
I've reproduced the issue on an Intel HD 3000 on Windows 8.1. It seems you don't always need to enter text into boxes for boxes to disappear. The page also seems to sometimes load wrong (missing boxes) to begin with. Also, scrolling up and down seems to be a reliable way to make boxes disappear as well.
Test case (works on Windows 8.1 with HD 3000):
<style>
#container input{
	 border: 3px solid rgb(256, 0, 0);
	 min-height: 14px;
	 vertical-align: middle;
	 margin-right: 8px;
 }
html, body {
	 background-color: rgb(0, 0, 0);
	 color: rgb(256, 256, 256);
 }
</style>

<div id="container">

<input type="radio"><label>Station/Stop</label>

<div>
<input style="width:300px;" maxlength="60" type="text">

</div>
</body>
</div>
Can confirm that the issue can be reproduced with this test case on my HD2000.
OS: Unspecified → Windows
Attached file index.htm
Fixed a syntax error from the pasted test case.
It seems to not be reproducible if the radio button is not there. Any ideas Bas?
Flags: needinfo?(bas)
(In reply to kfung from comment #28)
> Created attachment 8614206 [details]
> index.htm
> 
> Fixed a syntax error from the pasted test case.
> It seems to not be reproducible if the radio button is not there. Any ideas
> Bas?

I'd still very much believe it will have to do with gfxWindowsNativeDrawing.
Flags: needinfo?(bas)
Thanks everyone for looking into this. What are the next steps and when will this be fixed?
https://downloadcenter.intel.com/download/24971/Intel-HD-Graphics-Driver-for-Windows-7-8-8-1-64-bit

Intel 9.17.10.4229 driver for Sandy Bridge. Might or might not fix anything but please test if possible.
Installed it but no change visible.
I tried it too but bug still appears.
Attached file firefox.trace
Having taken an apitrace of loading the reduced test case on startup in fullscreen, the textbox in the test case does not render on an HD 3000 but does render on a different card, as seen in call 7005 of the trace. Thus, it seems to be a driver issue that causes this problem.
Are you sure? This issue came up with a FF update but not with a driver update. So if it was working with FF36 and doesn't work with FF37 how can you blame a graphics driver?
The trace records a sequence of API calls that can be played back on a different computer. Playing back the same calls on a different computer yields different results, so there must be something different about the drivers. FF36 and FF37 must be invoking a different sequence of calls.
(In reply to milka16 from comment #35)
> Are you sure? This issue came up with a FF update but not with a driver
> update. So if it was working with FF36 and doesn't work with FF37 how can
> you blame a graphics driver?

We are doing something different in FF37, and that is exposing a driver bug.  Our options in these situations are usually to either blocklist the driver, or look for a different way to do what we need to do, that doesn't hit the same driver paths.
Attached patch force-bitmap-brush.patch (obsolete) — Splinter Review
Forcing CreateBrushForPattern to use BitmapBrush instead of ImageBrush in DrawTargetD2D1.cpp seems to fix the problem on my machine for the reduced test case and also the web site reported to have the problem.
Attachment #8621840 - Flags: review?(bas)
Attached patch force-bitmap-brush-v2.patch (obsolete) — Splinter Review
Eliminated some extra cruft.
Attachment #8621840 - Attachment is obsolete: true
Attachment #8621840 - Flags: review?(bas)
Attachment #8621856 - Flags: review?(bas)
Comment on attachment 8621856 [details] [diff] [review]
force-bitmap-brush-v2.patch

Review of attachment 8621856 [details] [diff] [review]:
-----------------------------------------------------------------

::: gfx/2d/DrawTargetD2D1.cpp
@@ +1462,5 @@
>      }
>  
> +    bool useSamplingRect = false;
> +    if (pat->mSamplingRect.IsEmpty()) {
> +      RefPtr<ID2D1Bitmap> bitmap = nullptr;

RefPtr already inits to nullptr, remove this assignment.
Attachment #8621856 - Flags: review?(bas) → review+
Removed nullptr assignment.

Try:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=20c00adc213b
Attachment #8621856 - Attachment is obsolete: true
Keywords: checkin-needed
Comment on attachment 8622035 [details] [diff] [review]
force-bitmap-brush-v3.patch

Approval Request Comment
[Feature/regressing bug #]: Text boxes are disappearing on Intel HD 3000
[User impact if declined]: Some pages will not render properly on Intel HD 3000
[Describe test coverage new/current, TreeHerder]: Manual testing
[Risks and why]: Low risk as it just makes a slight alteration to rendering path
[String/UUID change made/needed]: None
Attachment #8622035 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/8d87fb4830b5
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla41
Great! When will FF41 be released?
FF41 will be in release on September 22, 2015. It also will be in Aurora on June 23, 2015.
Comment on attachment 8622035 [details] [diff] [review]
force-bitmap-brush-v3.patch

Taking it as display issues are a pain.
The fix will be in 40 too.
Attachment #8622035 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Hmm I just tried Aurora 40.0a2 (2015-06-16) but it still has the issue...
You're right, it Aurora 40.0a2 doesn't work for me either. However, the latest nightly build (http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla-central/) is working fine. Maybe the change isn't in Aurora 40.0a2? Can you try the latest nightly build to see if it works?
It literally landed an hour ago. The change won't be reflected in an Aurora nightly build until tomorrow.
I have tried the newest Aurora version just now and it really seems to be fixed. I can't tell you what a relief this is. The message section in Facebook was almost unusable due to this bug. Now it works nicely. However, I have checked only a couple of sites. But it looks very good.
Popping in a little late to the party but just wanted to confirm that on Nightly this bug does appear to be fixed. 

OS: Windows 8.1 Pro x64 + all published WU to date
Fx: July 6th 2015 EN-GB 64-bit Nightly
GPU: Intel HD 3000 / driver: 9.17.10.4229

Very glad to be able to use Firefox again. Looking forward to it hitting mainline in September. Cheers all great job!

Morgan
Marking this verified fixed based on the last two comments.
Status: RESOLVED → VERIFIED
After updating to Windows 10 the issue seems to be gone
You need to log in before you can comment on or make changes to this bug.