[SMS][Text Selection] Attempting to 'select all' in the TO: field of a new message will select text from both the TO: field and the message area

VERIFIED FIXED in 2.2 S12 (15may)

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: jmitchell, Assigned: steveck)

Tracking

unspecified
2.2 S12 (15may)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [3.0-Daily-Testing][p=1], )

Attachments

(3 attachments)

Reporter

Description

4 years ago
Description:
With the focus in the TO: field, when the user selects 'select all' from the text selection choices text in the message area will also be selected.
This is in contrast to selecting 'select all' from the message area, where only the text in the message area is selected.


Repro Steps:
1) Update a Flame to 20150430010201
2) Launch SMS
3) Add a contact or type some text in the TO: field, and some text into the message body
4) Long press on the TO: field text to get the text selection options
5) Select 'select all' (first icon)


Actual:
Text from the message area is also included in the selection

Expected:
Text from only the TO: field should be included in the selection


Environmental Variables:
Device: Flame 3.0
Build ID: 20150430010201
Gaia: db8ea705c0fd1b1684807f5a8e837bb9a36a6f96
Gecko: 4b9b12c248dc
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0



Repro frequency: 5/5

See attached: logcat, video clip: http://youtu.be/0Qb2G1oxswE
Reporter

Comment 1

4 years ago
This issue also reproduces in Flame KK 2.2; text selection is not supported prior to that

Device: Flame 2.2 (KK - Nightly - Full Flash - 319mem)
Build ID: 20150429002501
Gaia: 1b7aa7e60788668ed09abf76022dfa231dbe88d4
Gecko: d38ff4717f39
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?][COM=Text Selection]
Flags: needinfo?(pbylenga)
Seems like broken functionality of a feature. NI component owner to weigh in on this
QA Whiteboard: [QAnalyst-Triage?][COM=Text Selection] → [QAnalyst-Triage+][COM=Text Selection]
Flags: needinfo?(pbylenga) → needinfo?(gchang)
Keywords: polish
This is something we can likely fix without much risk.
blocking-b2g: --- → 2.2?
NI EPM to make decision.
Flags: needinfo?(gchang) → needinfo?(hochang)

Comment 5

4 years ago
Blocking, only the TO: field should be included in the selection. 

Hi Julien, do you mind helping with this? Thanks :)
blocking-b2g: 2.2? → 2.2+
Flags: needinfo?(hochang) → needinfo?(felash)
We'll take it in next sprint.
Flags: needinfo?(felash)
Target Milestone: --- → 2.2 S13 (29may)
Assignee

Comment 7

4 years ago
Will take a look in next sprint
Assignee: nobody → schung
Assignee

Comment 8

4 years ago
After some test I found this issue only happens when selecting on the recipients which is wrapped already. If user select on the pure text in the field, it works perfectly and select all won't affect the wrapped recipients and composer. Hi Jenny, could you please confirm the selection behavior for the wrapped recipient? Thanks!
Flags: needinfo?(jelee)
Assignee

Comment 10

4 years ago
Comment on attachment 8601989 [details] [review]
[gaia] steveck-chung:message-text-selection-recipient > mozilla-b2g:master

Quick fix based on the offline discussion with Jenny. Selection for the recipient pill will be disabled.
Attachment #8601989 - Flags: review?(felash)
Whiteboard: [3.0-Daily-Testing] → [3.0-Daily-Testing][p=1]
Comment on attachment 8601989 [details] [review]
[gaia] steveck-chung:message-text-selection-recipient > mozilla-b2g:master

r=me, this works perfect :)
don't forget to ask the approval !
Attachment #8601989 - Flags: review?(felash) → review+
Assignee

Comment 12

4 years ago
In master: https://github.com/mozilla-b2g/gaia/commit/96d658f8afb2608378b9260e0a30cff313284537

I'll create another patch for 2.2
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Assignee

Comment 13

4 years ago
Comment on attachment 8601989 [details] [review]
[gaia] steveck-chung:message-text-selection-recipient > mozilla-b2g:master

I forgot that there's no need to create specific patch for 2.2 yet

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Text selection feature
[User impact] if declined: Text selection will be triggered by long press on recipient pill unexpectedly with broken select all function
[Testing completed]: N/A
[Risk to taking this patch] (and alternatives if risky): Low
[String changes made]: N/A
Attachment #8601989 - Flags: approval-gaia-v2.2?

Comment 14

4 years ago
(In reply to Steve Chung [:steveck] from comment #8)
> After some test I found this issue only happens when selecting on the
> recipients which is wrapped already. If user select on the pure text in the
> field, it works perfectly and select all won't affect the wrapped recipients
> and composer. Hi Jenny, could you please confirm the selection behavior for
> the wrapped recipient? Thanks!

Hi Steve,

Wrapped recipient shouldn't trigger text selection and shouldn't be included in text selection (triggered by pure text part), thanks!
Flags: needinfo?(jelee)
Attachment #8601989 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
This issue is verified fixed on Flame 3.0. Long tapping on wrapped recipient in To field now cancels the wrapped effect and enters edit mode of that particular recipient, basically avoiding triggering of the bug.

Device: Flame
BuildID: 20150512010209
Gaia: 6089234ace8b294a8feef064387604bae16254e3
Gecko: 502e1a5e722f
Gonk: 040bb1e9ac8a5b6dd756fdd696aa37a8868b5c67
Version: 41.0a1 (3.0 Master) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0

Adding verifyme for 2.2 verification. 2.2 has just landed today.
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+][COM=Text Selection] → [QAnalyst-Triage?][COM=Text Selection]
Flags: needinfo?(ktucker)
Keywords: verifyme
QA Whiteboard: [QAnalyst-Triage?][COM=Text Selection] → [QAnalyst-Triage+][COM=Text Selection]
Flags: needinfo?(ktucker)

Comment 17

4 years ago
This issue has been verified fixed on latest Nightly build of Flame v2.2.
STR: 
1. Invoke MSM from contact detail view/Launch SMS and add a contact or type some text in the TO: field, and some text into the message body.
2. Long press on the TO: field text to get the text selection options.
3. Long tapping on wrapped recipient in To field now cancels the wrapped effect and enters edit mode of that particular recipient.
4. Select 'select all'.
Actually result: Only the recipient which canceled the wrapped effect in step 3 will be selected.
See video: "Verify.MP4".

Flame2.2 build(Pass):
Build ID               20150513162505
Gaia Revision          aac58a063e3e6acae6ba77fe4cec224fb69450bc
Gaia Date              2015-05-13 12:59:48
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/7a4f3cb5bf7b
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150513.205814
Firmware Date          Wed May 13 20:58:25 EDT 2015
Bootloader             L1TC000118D0

Updated

4 years ago
You need to log in before you can comment on or make changes to this bug.