Fennec 38.0b8 has release channel set to "release" instead of "beta"

RESOLVED DUPLICATE of bug 1158124

Status

--
major
RESOLVED DUPLICATE of bug 1158124
3 years ago
3 years ago

People

(Reporter: kairo, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
In bug 1159993 we found out that Firefox for Android 38.0b8 has the release channel set to "release" instead of "beta", which throws off at least crash stats, possibly other things.

I guess that's more fallout from building betas off mozilla-release.

We should fix this before we build b10 (gtb on Sunday).
Hal and I noticed another symptom yesterday, which is no autopush to mobile/releases and having to force the release-mozilla-release-fennec_push_to_mirrors builder in buildbot (NB, not release-mozilla-beta-....).

I think both of these come down to using buildbot-configs/mozilla/release-fennec-mozilla-release.py instead of release-fennec-mozilla-beta.py, eg 38.0b8 build3 config bump:
  https://hg.mozilla.org/build/buildbot-configs/rev/82032370429d

Suspect there is a bug in release-runner in selecting the config to use.
The hack in bug 1158124 only covered Firefox. Lets fix it over there to keep all the patches in one place.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1158124
You need to log in before you can comment on or make changes to this bug.