[l12y][Email] The string 'Delete the draft' is not translated

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::E-Mail
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: YeojinC, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.2 unaffected, b2g-master affected)

Details

(Whiteboard: [3.0-Daily-Testing])

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8599991 [details]
Translate.png

Description:
The string "Delete the draft" is not translated. This used to be translated in the earlier build in Master (e.g.20150402051034), but the latest build displays the string in English.

Pre-requisite: Have an email account set up in Email app.

Repro Steps:
1) Update a Flame to 20150430010201.
2) Go to Settings > Language, and set the device language in French.
3) Open Email app from the home screen.
4) Select the Compose  icon.
5) Type any letter in any field, and tap the Back button. 
6) Observe the 'Delete the draft' string on the menu. 

Actual:
The string appears in English.

Expected:
The string is properly transtated in French.

Environmental Variables:
Device: Flame Master (KK, 319mb, full flash)
Build ID: 20150430010201
Gaia: db8ea705c0fd1b1684807f5a8e837bb9a36a6f96
Gecko: 4b9b12c248dc
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (Master)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

Repro frequency: 5/5
See attached: screenshot, logcat

Note:
Bug 1155421 might be the cause of this bug. Regression-window is needed to confirm.
(Reporter)

Comment 1

3 years ago
This issue does NOT reproduce on Flame 2.2.

Result: The 'Delete the draft' string is properly translated in French.

Environmental Variables:
Device: Flame 2.2 (KK, 319mb, full flash)
Build ID: 20150430002504
Gaia: aa1da5036f9425c25d515d14243d3473bfefb4fd
Gecko: 38b2838d43e1
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
(Reporter)

Comment 2

3 years ago
Created attachment 8599994 [details]
logcat.txt
The string has been updated, it can be localized, it's just not translated yet because we don't translate 3.0.

See https://github.com/mozilla-b2g/gaia/commit/a2e5a4c786f163ab5941961c967f4b3ebc487fc5
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(ktucker)
Keywords: regression
Resolution: --- → INVALID
I'm changing this to works-for-me from a l12y standpoint.  When we eventually run l10n on 3.0, this bug in an invalid state may give the wrong impression that this string should not be translated.
Resolution: INVALID → WORKSFORME
You need to log in before you can comment on or make changes to this bug.