Closed Bug 1160249 Opened 5 years ago Closed 1 year ago

We should clear the netmonitor's stats when we move back in history

Categories

(DevTools :: Netmonitor, defect, P2)

40 Branch
defect

Tracking

(firefox40 affected)

RESOLVED WORKSFORME
Tracking Status
firefox40 --- affected

People

(Reporter: canuckistani, Unassigned)

References

Details

(Whiteboard: [polish-backlog][difficulty=easy])

See also bug 1160184.

1. open a page ( eg https://developer.mozilla.org/en-US/Add-ons/SDK )
2. click on any link
3. open the netmonitor and hit reload
4. hit the back button

Expected: we should clear out the previous page's statistics in the bottom info bar ( eg '$x requests, 240kb, 21s' )

Actual: we continue to show the previous page's stats until an actual network request happens
Whiteboard: [devedition-40][difficulty=easy]
Priority: -- → P2
Whiteboard: [devedition-40][difficulty=easy] → [polish-backlog][difficulty=easy]
Assignee: nobody → jsantell
Blocks: de-44-polish
Status: NEW → ASSIGNED
Assignee: jsantell → nobody
Status: ASSIGNED → NEW
Product: Firefox → DevTools
I can't reproduce this bug anymore (Firefox 65)
Closing.

Feel free to reopen if you still see the problem!

Honza
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.