GCF TC 31.4.3.4 : Terminate held multiparty call failed

RESOLVED FIXED in Firefox OS v2.2

Status

Firefox OS
Gaia::Dialer
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: pgravel, Assigned: gsvelto, NeedInfo)

Tracking

(Blocks: 1 bug)

unspecified
2.2 S12 (15may)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 fixed, b2g-master fixed)

Details

(Whiteboard: [caf priority: p2][CR 830269])

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Test is from 3GPP TS 51.010, section 31.4.3.4
This test checks that the phone correctly terminates a held MultiParty call by initiating call clearance for each party in turn.

Scenario for TC 31.4.3.4:
1.	Phone has held multiparty call
2.	Pressing END call button should disconnect both calls, but it currently only disconnects only a single call. 

This is due to bug in calls_handler end() function where it only calls endConferenceCall() if conference is active, whereas in this scenario the conference is on hold.

Updated

3 years ago
Whiteboard: [CR 830269]

Updated

3 years ago
Whiteboard: [CR 830269] → [caf priority: p2][CR 830269]

Comment 1

3 years ago
Hi! Sean,

Have you fixed this before?

--
Keven
Flags: needinfo?(selee)
Hi Keven, Sorry that I have not fixed this before.
Flags: needinfo?(selee)

Comment 3

3 years ago
I don't think there is a "end all call" behavior by single gaia action.
Unless there is a UI to end all calls, this test case can not get passed.
I can't reproduce on 2.2 [1]. Here are the steps I followed:

1. From the device under test, call another device.
2. Once the call is established, from the device under test, call the voicemail
3. Merge the 2 calls.
4. Once the calls are properly merged, press the "end call" button => Each call is hung up. 

[1] Build ID               20150503162504
Gaia Revision          8d14361337e608c8cdf165ea5034db5eda23b618
Gaia Date              2015-05-01 18:23:46
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/cb7cb6597c91
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150503.200206
Firmware Date          Sun May  3 20:02:17 EDT 2015
Bootloader             L1TC000118D0
(In reply to Johan Lorenzo [:jlorenzo] (QA) from comment #4)
> 4. Once the calls are properly merged, press the "end call" button => Each
> call is hung up. 
And I forgot a step: Once the calls are properly merged, put these calls on hold.
5. Press the "end call" button => Each call is hung up.
(Assignee)

Comment 6

3 years ago
What I see is that we terminate one of the calls in the group and this causes the conference to be ended too. I'm not sure if we can rely on this though so I'll prepare a patch to properly hang up the conference group instead of one of its calls.
(Assignee)

Updated

3 years ago
Assignee: nobody → gsvelto
Status: NEW → ASSIGNED
Created attachment 8600887 [details] [review]
[gaia] gabrielesvelto:bug-1160337-end-held-conference-group > mozilla-b2g:master
(Assignee)

Comment 8

3 years ago
Comment on attachment 8600887 [details] [review]
[gaia] gabrielesvelto:bug-1160337-end-held-conference-group > mozilla-b2g:master

Quick fix for the problem with unit-tests added. I've tried to make the whole procedure more robust rather than having it work happenchance.
Attachment #8600887 - Flags: review?(drs)
Comment on attachment 8600887 [details] [review]
[gaia] gabrielesvelto:bug-1160337-end-held-conference-group > mozilla-b2g:master

Looks good, thanks.
Attachment #8600887 - Flags: review?(drs) → review+
See Also: → bug 1159958
(Assignee)

Comment 10

3 years ago
Thanks for the review, ready to land.
Keywords: checkin-needed

Updated

3 years ago
Keywords: checkin-needed
(Assignee)

Comment 11

3 years ago
Ooops, I missed the review comment on GitHub. I'll open a follow up if Autolander manages to land this.

Updated

3 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED

Comment 13

3 years ago
Comment on attachment 8600887 [details] [review]
[gaia] gabrielesvelto:bug-1160337-end-held-conference-group > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
[User impact] if declined:
[Testing completed]:
[Risk to taking this patch] (and alternatives if risky):
[String changes made]:
Flags: needinfo?(bbajaj)
Attachment #8600887 - Flags: approval-gaia-v2.2?
Comms triage: Certification blocker on a new feature added in 2.2.
blocking-b2g: 2.2? → 2.2+

Updated

3 years ago
Attachment #8600887 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
(Assignee)

Updated

3 years ago
status-b2g-v2.2: --- → affected
status-b2g-master: --- → fixed
(Assignee)

Updated

3 years ago
Blocks: 1161957
v2.2: https://github.com/mozilla-b2g/gaia/commit/c6a6996841860ab335bf46b273477dc4bef19c95
status-b2g-v2.2: affected → fixed
Target Milestone: --- → 2.2 S12 (15may)
Blocks: 977588
You need to log in before you can comment on or make changes to this bug.