Closed Bug 1160363 Opened 5 years ago Closed 5 years ago

[Calendar][Week Bar] Tapping on the bar at the top with the initials of the days of the week will bring the user to the 1st day of the month

Categories

(Firefox OS Graveyard :: Gaia::Calendar, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:-, b2g-v2.1 unaffected, b2g-v2.2 verified, b2g-master verified)

VERIFIED FIXED
2.2 S12 (15may)
blocking-b2g -
Tracking Status
b2g-v2.1 --- unaffected
b2g-v2.2 --- verified
b2g-master --- verified

People

(Reporter: dharris, Assigned: mmedeiros)

References

()

Details

(Keywords: regression, Whiteboard: [3.0-Daily-Testing])

Attachments

(3 files)

Description:
The bar at the top of the calendar that has a letter for each day of the week (M,T,W,T,F,S,S) will bring the user to the first day of the week when tapped. This will occur on any month and when tapping anywhere on the "week bar"


Repro Steps:
1) Update a Flame to 20150430010201
2) Open Calendar app
3) Tap on any day of the month that is not the 1st day
4) Tap on the bar at the top that has the initials off the days of the week


Actual:
User is randomly brought to the 1st day of the month


Expected:
Nothing happens

Environmental Variables:
Device: Flame 3.0 (319mb)(Kitkat)(Full Flash)
Build ID: 20150430010201
Gaia: db8ea705c0fd1b1684807f5a8e837bb9a36a6f96
Gecko: 4b9b12c248dc
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0


Repro frequency: 20/20
See attached: Logcat, Video - https://youtu.be/vBMYZDUcyjY
This issue DOES occur on Flame 2.2

User is randomly brought to the 1st day of the month

Environmental Variables:
Device: Flame 2.2 (319mb)(Kitkat)(Full Flash)
Build ID: 20150430002504
Gaia: aa1da5036f9425c25d515d14243d3473bfefb4fd
Gecko: 38b2838d43e1
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

==================================================================================================

This issue does NOT occur on Flame 2.1

Nothing happens when the bar is selected

Environmental Variables:
Device: Flame 2.1 (319mb)(Kitkat)(Full Flash)
Build ID: 20150427001201
Gaia: bbe983b4e8bebfec26b3726b79568a22d667223c
Gecko: 82a14be0462c
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 34.0 (2.1)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Keywords: regression
Functional regression of a core app.  Requesting a window.
blocking-b2g: --- → 2.2?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
QA Contact: ychung
b2g-inbound Regression Window:

Last Working Environmental Variables:
Device: Flame 2.2
BuildID: 20141219061747
Gaia: 25ed6542f13098b37ebb063861dab97d73e358f4
Gecko: c1b3206236b6
Version: 37.0a1 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

First Broken Environmental Variables:
Device: Flame 2.2
BuildID: 20141219072247
Gaia: 85c5d7d5f7cbf5d3261197d571a0e2215b51d4ee
Gecko: cb54f0d3ab57
Version: 37.0a1 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Last Working Gaia First Broken Gecko: Issue does NOT reproduce 
Gaia: 25ed6542f13098b37ebb063861dab97d73e358f4
Gecko: cb54f0d3ab57

First Broken Gaia Last Working Gecko: Issue DOES reproduce
Gaia: 85c5d7d5f7cbf5d3261197d571a0e2215b51d4ee
Gecko: c1b3206236b6

https://github.com/mozilla-b2g/gaia/compare/25ed6542f13098b37ebb063861dab97d73e358f4...85c5d7d5f7cbf5d3261197d571a0e2215b51d4ee

Caused by bug 1084014
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Contact: ychung
Miller, can you take a look at this please? This looks to have been caused by the work done on bug 1084014.
Blocks: 1084014
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(mmedeiros)
Assignee: nobody → mmedeiros
Flags: needinfo?(mmedeiros)
Target Milestone: --- → 2.2 S12 (15may)
Comment on attachment 8601044 [details] [review]
[gaia] millermedeiros:1160363-tap-dow-month-view > mozilla-b2g:master

the `.month` wrapper also have `[data-date]`, so the delegated event was being triggered with the wrong element.

found it easier to add a new new class name instead of removing the `[data-date]` from the `.month` (less changes to the tests and less likely to re-introduce the same bug in the future)

not sure if this bug should be considered a blocker (doesn't really affect the UX that much), but it's simple and should not cause regressions so I decided to go ahead and fix it.
Attachment #8601044 - Flags: review?(gaye)
Comment on attachment 8601044 [details] [review]
[gaia] millermedeiros:1160363-tap-dow-month-view > mozilla-b2g:master

LGTM! Random bug...
Attachment #8601044 - Flags: review?(gaye) → review+
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
triage: we can request 2.2 approval but wouldn't block on this.
blocking-b2g: 2.2? → -
Comment on attachment 8601044 [details] [review]
[gaia] millermedeiros:1160363-tap-dow-month-view > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Bug 1084014
[User impact] if declined: unexpected behavior when clicking the month calendar heading (selects first day of the month), it's a minor issue tho
[Testing completed]: manual + unit
[Risk to taking this patch] (and alternatives if risky): very low risk, changes are minimal and isolated
[String changes made]: none
Attachment #8601044 - Flags: approval-gaia-v2.2?
Comment on attachment 8601044 [details] [review]
[gaia] millermedeiros:1160363-tap-dow-month-view > mozilla-b2g:master

Given its low risk, approving this.
Attachment #8601044 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
This bug has been verified as "pass" on latest Nightly build of Flame v2.2&3.0 by the STR in Comment 0.

Actual results: When tapping on the month calendar heading with the initials of the days of the week, nothing happens and it doesn't bring user to the 1st day.
See attachment: verified_v2.2&3.0.3gp
Reproduce rate: 0/10


Device: Flame v2.2 build(Verified) 
Build ID               20150628002505
Gaia Revision          0179935627012dfde3ca036c9a71035be463b7ad
Gaia Date              2015-06-26 21:13:44
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/35e09270da3a
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150628.035537
Firmware Date          Sun Jun 28 03:55:48 EDT 2015
Bootloader             L1TC000118D0

Device: Flame v3.0 build(Verified)
Build ID               20150629134017
Gaia Revision          27fe0f4261e3685187769411f2f74cff19287b19
Gaia Date              2015-06-29 14:29:00
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/c26dbd63604d
Gecko Version          42.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150629.170951
Firmware Date          Mon Jun 29 17:10:03 EDT 2015
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
You need to log in before you can comment on or make changes to this bug.