Type 1 error when printing from site with QuicKeys/Mozilla 0.9.6 (2001112011)

VERIFIED FIXED in mozilla1.0

Status

()

Core
Printing: Output
P1
major
VERIFIED FIXED
16 years ago
16 years ago

People

(Reporter: Michael_Henry, Assigned: dcone (gone))

Tracking

Trunk
mozilla1.0
PowerPC
Mac System 9.x
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [adt2 RTM] [ETA 06/12], URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
When printing certain pages from the browser, the Mozilla browser crashes with a
Type 1 error. If I disable QuicKeys, I am able to print without error. There
appears to be a conflict between QuicKeys and Mozilla. We have tested this with
QuicKeys 4.1 and 5, with the same results. I have included a URL for
verification purposes.
(Reporter)

Comment 1

16 years ago
Included are notes from CE Software's tech support group. They tested QuicKeys 5
with the Netscape 6.2 client (0.9.4 - 20011022):

-------- Original Message -------- 
Subject: 	Re: netscape
Date: 	17 Dec 2001 16:32:38 -0600
From: 	David Williams <david.williams@mail.cesoft.com>
Reply-To: 	David Williams <david.williams@mail.cesoft.com>
To: 	<anne_jackley@timeinc.com>


Hi Anne,

This is what I've found out:

1. With QK's running and printing the page you sent crashes the browser...just
as you stated.
If you click on the 'print this' option for printer friendly version...it
doesn't crash Netscape.

2. Internet Explorer will print the page with no problems either way.

3. Netscape is causing the issue..whether it be bad instructions with java
(javascript) on this page or animation of some kind causing the crash. By going
to the printer friendly option it bypasses all the scripting that Netscape puts
in there.

QuicKeys is loaded at the system level and Netscape is basically doing something
at the system level it shouldn't be. QK's should not interfere either
way..unless the java machine at the system level is trying to do something it
shouldn't be when asked by Netscape.


-- 
Peace,

David
=================================

David Williams, Technical Advisor

CE Software, Inc.

Comment 2

16 years ago
Sujay - can you try to obtain a copy of QuickKeys (evaluation?). If not, let me 
know and we can order a copy for testing purposes. 
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: nsenterprise

Comment 3

16 years ago
reassigning
Assignee: rods → dcone

Updated

16 years ago
Keywords: nsbeta1
Setting nsbeta1+, and setting milestone to mozilla0.9.9
Keywords: nsbeta1 → nsbeta1+
Target Milestone: --- → mozilla0.9.9
(Assignee)

Updated

16 years ago
Target Milestone: mozilla0.9.9 → mozilla1.0.1

Updated

16 years ago
Target Milestone: mozilla1.0.1 → mozilla1.0
(Assignee)

Comment 5

16 years ago
Are you using the Carbon Mozilla.. or the 8.6 Mozilla?  

Comment 6

16 years ago
I installed QK on my 9.x system, I crash using commercial trunk
build on Win 98 when QK is enabled. However, when I select the
"Disable until Restart" option, I still crash on that page.
And when I de-install(remove all files from system folder that
have QuickKey reference) QK from my system and restart, I still crash.

Also two people in QA are able to print that SI page from their Mac OSX
machines that don't even have QK installed on their system.

Don, can you try and print that SI page?

Comment 7

16 years ago
I don't know what QK is but with standard installation of this mornings os9
build 2002-02-27-03-trunk i can't print the listed SI page.

Comment 8

16 years ago
ok now I can print that page on my OS 9 box w/o QK installed/enabled...

I will try again to install QK on my system...I wish there was
an easy way to de-install QK. I had to delete directories and files
to de-install it last time.

Comment 9

16 years ago
I don't have QK installed under OS X but I did receive a crash on the url
mentioned. It occurred after printing the page successfully (the first time)
then reloading page and choosing print again. Unfortunately, I can't reproduce
the crash again.

Tested under Feb 27th OS build (2002-02-27-08)

Comment 10

16 years ago
This page prints for me (without crashing) under Mac OS 9.1 with the Feb 28th
build (2002-02-28-08). Printed to a LaserJet 5SImx.
(Reporter)

Comment 11

16 years ago
OS X was not considered for the purposes of this bug as we do not use it 
in our environment (and the page printed properly in OS X with QuicKeys 
X).

By the way, when did the target milestone change to 1.0? I thought it was 
0.9.9...
(Assignee)

Comment 12

16 years ago
Is this the only page that crashes... with quick keys.. and is this only a OS 9 
issue?
(Reporter)

Comment 13

16 years ago
It is an 8.6 - 9.x issue, and not a X issue, if that's what you mean.

And no, that is not the only page that crashes the browser. I will submit 
some other sites shortly.

Comment 14

16 years ago
adt2 per adt triage
Whiteboard: [adt2]

Comment 15

16 years ago
using 3/28 commercial trunk build on Mac OS 9.x, here are my testing results.
SI page refers to the URL in this bug report.

w/o QK installed, that SI page prints fine

with QK installed, that SI page crashes, but so does cnn.com, abcnews.com.
But                      mozilla.org does print fine w/o crash.

re-installing Netscape with QK still installed, then trying to print that
SI                   page = crash again... cnn.com also crash; mozilla.org does
not                   crash.

choosing disable until restart option in QK yields same problems...crashes on
pages(SI page, cnn.com)

un-install QK(removing all files) followed by restart, then trying to print that
SI page does not print, however no crash.

uninstall QK followed by re-install of netscape, SI page does not print, but no
crash.
Per conversation with dcone: It sounds like an installation issue. 

From Don: "I found that installing quickkeys messes up Mozilla.  If I uninstall
quickkey.. without running mozilla.. it still messes up. If I re-install mozilla
it will work.. as long as quickkeys is not installed.. or installed while
mozilla is installed."

Per dcone: with carbon build it works fine.
(Assignee)

Comment 18

16 years ago
Created attachment 86444 [details] [diff] [review]
This fixes the crash.  Hard to find.. simple to fix.

Comment 19

16 years ago
Comment on attachment 86444 [details] [diff] [review]
This fixes the crash.  Hard to find.. simple to fix.

r=rods
Attachment #86444 - Flags: review+

Comment 20

16 years ago
Comment on attachment 86444 [details] [diff] [review]
This fixes the crash.  Hard to find.. simple to fix.

sr=waterson
Attachment #86444 - Flags: superreview+

Updated

16 years ago
Keywords: adt1.0.1, approval
Priority: -- → P1

Comment 21

16 years ago
Comment on attachment 86444 [details] [diff] [review]
This fixes the crash.  Hard to find.. simple to fix.

a=asa (on behalf of drivers) for checkin to the 1.1 trunk.
Attachment #86444 - Flags: approval+
(Assignee)

Updated

16 years ago
Summary: Type 1 error when printing from site with QuicKeys/Mozilla 0.9.6 (2001112011) → [FIXED TRUNK] Type 1 error when printing from site with QuicKeys/Mozilla 0.9.6 (2001112011)
(Assignee)

Comment 22

16 years ago
fixed
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
Summary: [FIXED TRUNK] Type 1 error when printing from site with QuicKeys/Mozilla 0.9.6 (2001112011) → Type 1 error when printing from site with QuicKeys/Mozilla 0.9.6 (2001112011)

Comment 23

16 years ago
sujay/shrir - can one of you verify this on the trunk? thanks!
Blocks: 143047
Keywords: mozilla1.0.1
Whiteboard: [adt2] → [adt2 RTM] [ETA 06/12]

Comment 24

16 years ago
adt1.0.1+ (on ADT's behalf) for approval to check in to the 1.0 branch. pls
check this in asap, then add the "fixed1.0.1" keyword.

Updated

16 years ago
Keywords: adt1.0.1 → adt1.0.1+

Comment 25

16 years ago
please checkin to the 1.0.1 branch. once there, remove the "mozilla1.0.1+"
keyword and add the "fixed1.0.1" keyword. 
Keywords: mozilla1.0.1 → mozilla1.0.1+
Comment on attachment 86444 [details] [diff] [review]
This fixes the crash.  Hard to find.. simple to fix.

(re)Approval granted for 1.0.1 checkin.  Please change mozilla1.0.1+ to
fixed1.0.1 after you check into the branch

Comment 27

16 years ago
Verified on trunk 06/13/02 Mac 9.1.
I installed today's trunk build, retrieved above page - no problem.
Then installed QuicKeys 5.0, restarted,  opened today's trunk build and checked
that page again - no problem. Also checked cnn, abcnews, mozilla.org. No problem.
Status: RESOLVED → VERIFIED

Comment 28

16 years ago
When printing these pages no Error no crash.
(Assignee)

Comment 29

16 years ago
checked into the branch.
Keywords: mozilla1.0.1+ → fixed1.0.1

Comment 30

16 years ago
Initially I had troubles after I installed branch build on Friday - could not
print anything from Mac 9.1. Tried IE, Comm, Netscape 7. Everywhere get the
error -3150. 
The error message: "Document "Netscape.com - Netscape" failed to print on the
printer "SAILFISH" because of the error.   -3150"
Then I installed today's build - the same. Re-started machine - and started
getting printouts. So far, only Mozilla page can not be printed. The error
message: "The document "mozilla.org - Netscape" could not be printed. the LPR
printer 'SAILFISH' could not be found. Please check that the printer is not
turned off or busy.  -8885". After pushing 1 printing job (which somehow did not
bother previous print jobs) I was able to get printout for Mozilla.org page.
Great, finally I can say Verified!
Keywords: fixed1.0.1 → verified1.0.1
You need to log in before you can comment on or make changes to this bug.