Closed Bug 1160452 Opened 6 years ago Closed 6 years ago

The automatic update does not work on OS X.

Categories

(Toolkit :: Application Update, defect)

37 Branch
Unspecified
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1171792

People

(Reporter: alexander.kjeldaas, Unassigned)

Details

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:37.0) Gecko/20100101 Firefox/37.0
Build ID: 20150402191859

Steps to reproduce:

I get a notice that a new release of firefox is available, 37.0.2.

After clicking on "Update" and then "Reboot" (roughly, maybe the buttons are called something else), then
The browser is restarted

(37.0.2 is not the only release this happened)


Actual results:

No update has happened


Expected results:

I should have been running 37.0.2 after the update
The version I run is 37.0.1
OS: Unspecified → Mac OS X
{
  "application": {
    "name": "Firefox",
    "version": "37.0.1",
    "buildID": "20150402191859",
    "userAgent": "Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:37.0) Gecko/20100101 Firefox/37.0",
    "updateChannel": "release",
    "supportURL": "https://support.mozilla.org/1/firefox/37.0.1/Darwin/en-US/",
    "numTotalWindows": 3,
    "numRemoteWindows": 0
  },
  "crashes": {
    "submitted": [],
    "pending": 0
  },
  "modifiedPreferences": {
    "accessibility.typeaheadfind.flashBar": 0,
    "browser.cache.disk.smart_size.first_run": false,
    "browser.cache.disk.smart_size_cached_value": 358400,
    "browser.cache.disk.smart_size.use_old_max": false,
    "browser.cache.disk.capacity": 358400,
    "browser.cache.frecency_experiment": 1,
    "browser.fixup.domainwhitelist.boot2docker": true,
    "browser.places.smartBookmarksVersion": 7,
    "browser.search.useDBForOrder": true,
    "browser.sessionstore.upgradeBackup.latestBuildID": "20150402191859",
    "browser.startup.homepage_override.mstone": "37.0.1",
    "browser.startup.homepage_override.buildID": "20150402191859",
    "dom.mozApps.used": true,
    "extensions.lastAppVersion": "37.0.1",
    "font.language.group": "x-western",
    "font.internaluseonly.changed": true,
    "media.gmp-gmpopenh264.lastUpdate": 1423214813,
    "media.gmp-gmpopenh264.version": "1.3",
    "media.gmp-manager.lastCheck": 1430462024,
    "network.cookie.prefsMigrated": true,
    "places.database.lastMaintenance": 1430424556,
    "places.history.expiration.transient_current_max_pages": 104858,
    "plugin.importedState": true,
    "plugin.disable_full_page_plugin_for_types": "application/pdf",
    "print.print_plex_name": "",
    "print.print_margin_top": "0.5",
    "print.print_paper_width": "  8.50",
    "print.print_orientation": 0,
    "print.print_to_file": false,
    "print.print_scaling": "  1.00",
    "print.print_unwriteable_margin_right": 25,
    "print.print_paper_height": " 11.00",
    "print.print_command": "",
    "print.print_reversed": false,
    "print.print_unwriteable_margin_left": 25,
    "print.print_unwriteable_margin_bottom": 57,
    "print.print_resolution_name": "",
    "print.print_duplex": 1515870810,
    "print.print_paper_size_unit": 0,
    "print.print_margin_right": "0.5",
    "print.print_oddpages": true,
    "print.print_bgcolor": false,
    "print.print_colorspace": "",
    "print.print_bgimages": false,
    "print.print_downloadfonts": false,
    "print.print_evenpages": true,
    "print.print_margin_left": "0.5",
    "print.print_shrink_to_fit": true,
    "print.print_unwriteable_margin_top": 25,
    "print.print_paper_name": "",
    "print.print_margin_bottom": "0.5",
    "print.print_in_color": true,
    "print.print_paper_size_type": 1,
    "print.print_page_delay": 50,
    "print.print_paper_data": 0,
    "print.print_resolution": 1515870810,
    "privacy.sanitize.migrateFx3Prefs": true,
    "storage.vacuum.last.places.sqlite": 1427841725,
    "storage.vacuum.last.index": 1
  },
  "lockedPreferences": {},
  "graphics": {
    "numTotalWindows": 3,
    "numAcceleratedWindows": 3,
    "windowLayerManagerType": "OpenGL",
    "windowLayerManagerRemote": true,
    "adapterDescription": "",
    "adapterVendorID": "0x10de",
    "adapterDeviceID": "0x fd5",
    "adapterRAM": "",
    "adapterDrivers": "",
    "driverVersion": "",
    "driverDate": "",
    "webglRenderer": "NVIDIA Corporation -- NVIDIA GeForce GT 650M OpenGL Engine",
    "info": {
      "AzureCanvasBackend": "quartz",
      "AzureSkiaAccelerated": 0,
      "AzureFallbackCanvasBackend": "none",
      "AzureContentBackend": "quartz"
    }
  },
  "javaScript": {
    "incrementalGCEnabled": true
  },
  "accessibility": {
    "isActive": false,
    "forceDisabled": 0
  },
  "libraryVersions": {
    "NSPR": {
      "minVersion": "4.10.8",
      "version": "4.10.8"
    },
    "NSS": {
      "minVersion": "3.17.4 Basic ECC",
      "version": "3.17.4 Basic ECC"
    },
    "NSSUTIL": {
      "minVersion": "3.17.4",
      "version": "3.17.4"
    },
    "NSSSSL": {
      "minVersion": "3.17.4 Basic ECC",
      "version": "3.17.4 Basic ECC"
    },
    "NSSSMIME": {
      "minVersion": "3.17.4 Basic ECC",
      "version": "3.17.4 Basic ECC"
    }
  },
  "userJS": {
    "exists": false
  },
  "extensions": [
    {
      "name": "ADB Helper",
      "version": "0.7.4",
      "isActive": true,
      "id": "adbhelper@mozilla.org"
    },
    {
      "name": "Flash and Video Download",
      "version": "1.70",
      "isActive": true,
      "id": "{bee6eb20-01e0-ebd1-da83-080329fb9a3a}"
    },
    {
      "name": "FoxyProxy Standard",
      "version": "4.5.4",
      "isActive": true,
      "id": "foxyproxy@eric.h.jung"
    },
    {
      "name": "FoxySpider",
      "version": "1.5.6",
      "isActive": true,
      "id": "{75df891f-e299-4725-b14f-7d52f086dea2}"
    },
    {
      "name": "Ghostery",
      "version": "5.4.5",
      "isActive": true,
      "id": "firefox@ghostery.com"
    },
    {
      "name": "google-no-tracking-url",
      "version": "1.3.1",
      "isActive": true,
      "id": "jid1-zUrvDCat3xoDSQ@jetpack"
    },
    {
      "name": "Translate This!",
      "version": "3.0.2",
      "isActive": true,
      "id": "jid0-k75TfRGfOXPHfEZmJ9cKu5eCgLc@jetpack"
    },
    {
      "name": "Valence",
      "version": "0.3.0",
      "isActive": true,
      "id": "fxdevtools-adapters@mozilla.org"
    }
  ],
  "experiments": []
}
Component: General → Application Update
Product: Firefox → Toolkit
This appears to be a combination of bug 1171792 and bug 394984 so duping to bug 1171792
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1171792
You need to log in before you can comment on or make changes to this bug.