Very long lag while stopping profiler on a WebIDE connected device

RESOLVED WORKSFORME

Status

()

Firefox
Developer Tools: Performance Tools (Profiler/Timeline)
RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: bgrins, Unassigned)

Tracking

(Blocks: 2 bugs)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
There are a variety of errors that happen when you take profiles on a device.  The STR are a little fuzzy and there seem to be a variety of errors that happen:

Open WebIDE
Connect to an android device
Start a profile and stop it
Start another profile and stop it.  Notice that it takes a very long time (sometimes > 10 second) to finalize.
If that all went well, try another one and while it's still trying to finish, press the button a couple more times.

At some point errors surface like "Protocol error (unknownError): Error: Wrong state while attaching to the debugger:Expected 'detached',but current state is 'attached'."1 protocol.js:20".

It's hard to tell exactly what is going on.  I doubt it's specific to the WebIDE connection but may be due to less resources on the server or a greater lag time for RDP
(Reporter)

Comment 1

3 years ago
Seems the button to stop a profile should disappear immediately after being clicked while results are collected.
The button is disabled. There's another bug for displaying a throbber. Shu is working on reducing the profile size tenfold.
Like victor said, I think the other bugs will fix this as well, but tracking this for release regardless
Blocks: 1160330
Duplicate of this bug: 921866
See Also: → bug 1177811
Blocks: 1199284
Brian, is this still an issue? I suspect that it's not due to profiler compression, and any long delays are most likely from rendering. Protocol errors should be fixed as well.
Flags: needinfo?(bgrinstead)
Closing, I don't think this is an issue any longer
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(bgrinstead)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.