Unrestored Reader View tabs display the about:reader path rather than a title

RESOLVED FIXED in Firefox 40

Status

()

Toolkit
Reader Mode
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: Caspy7, Assigned: ttaubert)

Tracking

unspecified
mozilla40
Points:
2
Bug Flags:
firefox-backlog +
in-testsuite +
qe-verify -

Firefox Tracking Flags

(firefox40 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
After a restart, we want unrestored tabs to look like normal tabs, but if the tab was in reader view at the time of the restart, instead of the original title the about:reader path is displayed. 
This looks messy and can be confusing to users.

Comment 1

3 years ago
I suspect this is because we use JS to set the reader view title after we get the article:
http://mxr.mozilla.org/mozilla-central/source/toolkit/components/reader/AboutReader.jsm?force=1#775

However, I would think that session restore would just try to restore the old title... maybe we have this functionality disabled for about: pages? ttaubert, do you know what's going on here?
Flags: needinfo?(ttaubert)
Assignee: nobody → ttaubert
Iteration: --- → 40.3 - 11 May
Points: --- → 2
Flags: qe-verify+
Flags: needinfo?(ttaubert)
Flags: firefox-backlog+
Status: NEW → ASSIGNED
Created attachment 8601542 [details] [diff] [review]
0001-Bug-1160556-Recollect-session-history-data-when-the-.patch

Rather trivial patch. Until now we didn't invalidate shistory data when the page title changed. Doesn't happen very often so no one noticied.
Attachment #8601542 - Flags: review?(gijskruitbosch+bugs)

Updated

3 years ago
Duplicate of this bug: 1153398

Comment 4

3 years ago
Comment on attachment 8601542 [details] [diff] [review]
0001-Bug-1160556-Recollect-session-history-data-when-the-.patch

Review of attachment 8601542 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/components/sessionstore/test/browser_page_title.js
@@ +29,5 @@
> +    content.document.title = "new title";
> +  });
> +
> +  // Remove the tab.
> +  yield promiseRemoveTab(tab);

Please rename this to something that says what it does. Might be a followup and have this just add a comment.
Attachment #8601542 - Flags: review?(gijskruitbosch+bugs) → review+
(In reply to :Gijs Kruitbosch from comment #4)
> > +  // Remove the tab.
> > +  yield promiseRemoveTab(tab);
> 
> Please rename this to something that says what it does. Might be a followup
> and have this just add a comment.

Added a comment to the function definition in the head.js file.

Comment 6

3 years ago
https://hg.mozilla.org/integration/fx-team/rev/d6e5fb263125
https://hg.mozilla.org/mozilla-central/rev/d6e5fb263125
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
status-firefox40: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla40
Depends on: 1163260
QA Contact: andrei.vaida

Comment 8

3 years ago
I am unable to reproduce this issue with Nightly from 2015-05-01 under Windows 8.1 32-bit and Ubuntu 12.04 64-bit - the correct title was displayed. Could you please provide some guidance in order to properly verify this fix? Thanks in advance!
Flags: needinfo?(ttaubert)
IIRC this wasn't too easy to reproduce and I did that only by writing a test. We have a test, so maybe we don't need manual QA here?
Flags: needinfo?(ttaubert) → in-testsuite+
(In reply to Tim Taubert [:ttaubert] from comment #9)
> IIRC this wasn't too easy to reproduce and I did that only by writing a
> test. We have a test, so maybe we don't need manual QA here?

I agree with the above, and setting as qe-verify- based on this. Thank you for your feedback Tim!
Flags: qe-verify+ → qe-verify-
You need to log in before you can comment on or make changes to this bug.