[Settings] The Feedback text box does not move text to the next line down after reaching the right side of the text box

VERIFIED FIXED in 2.2 S12 (15may)

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: jmitchell, Assigned: arthurcc)

Tracking

({regression})

unspecified
2.2 S12 (15may)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [3.0-Daily-Testing], URL)

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Description:
In the Improve Firefox OS section of the Settings menu is a send feedback function. This function leads to a text box where the user can enter their feedback. When typing into the box and reaching the far right side of the text box, the text does not break and move down to the next line. Instead the text scrolls to the left to allow more typing. The user is not able to scroll the box back to the left to review the text that has run off of the screen. Hitting the <enter> key on the keypad has no functionality and also does not move the text down to the next line.


Repro Steps:
1) Update a Flame to 20150501010203
2) Launch Settings > Improve Firefox OS > Send Mozilla Feedback
3) Select Happy or Sad (depending on you're current mood)
4) Enter enough text into the text box to run off the right side 

Actual:
Text Wrap is missing, text does not move to the next line, scrolls the text box to the right, but user can not scroll back to the left. Enter (on keyboard) is non-functional and does not create a ling break.


Expected:
Text will move to the next line when reaching the end of the text box



Environmental Variables:
Device: Flame 3.0
Build ID: 20150501010203
Gaia: 759a1f935a6a81c32ad66e39a6353b334dfa4f91
Gecko: 7723b15ea695
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0


Repro frequency: 7/7
See attached:  video clip: http://youtu.be/HwOss5V_SJ0
(Reporter)

Comment 1

4 years ago
This issue also occurs on Flame KK 2.2, with a slight difference: The enter key will dismiss the keyboard, but still not move the text cursor to the next line

Device: Flame 2.2 (KK - Nightly - Full Flash - 319mem)
Build ID: 20150430162504
Gaia: c077b9d502205cdb72ef9a4f425259dc2f990ff8
Gecko: 165c015e9fb6
Gonk: a9f3f8fb8b0844724de32426b7bcc4e6dc4fa2ed
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

---------------------------------------------------------------------------------------------

This issue does NOT reproduce in 2.1

Actual results: Reaching the end of the line with text will automatically move the cursor to the next line. Hitting the enter key will also move the cursor to the next line. All text stays within the left / right parameters of the text box. 

Device: Flame 2.1 (KK - Nightly - Full Flash - 319mem)
Build ID: 20150429001202
Gaia: 9fda4aec7f9495a27a335ccaf3b1a4dc9c4c6db0
Gecko: 38ab00c01159
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 34.0 (2.1)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Given the location and visibility of this functional regression nominating to block.

Requesting a window.
blocking-b2g: --- → 2.2?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
QA Contact: ychung
Mozilla-inbound Regression Window:

Last Working Environmental Variables:
Device: Flame 2.2
BuildID: 20141029013710
Gaia: 35e87ac4324f0f3abd93dcc70d61c9f37256a0f5
Gecko: d67de20b8612
Version: 36.0a1 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

First Broken Environmental Variables:
Device: Flame 2.2
BuildID: 20141029014811
Gaia: 35e87ac4324f0f3abd93dcc70d61c9f37256a0f5
Gecko: 249b822b256a
Version: 36.0a1 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Last Working Gaia First Broken Gecko: Issue DOES reproduce 
Gaia: 35e87ac4324f0f3abd93dcc70d61c9f37256a0f5
Gecko: 249b822b256a

First Broken Gaia Last Working Gecko: Issue does NOT reproduce
Gaia: 35e87ac4324f0f3abd93dcc70d61c9f37256a0f5
Gecko: d67de20b8612

http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=d67de20b8612&tochange=249b822b256a

Possibly caused by bug 82711
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Contact: ychung
Brian, can you take a look at this please? Looks like this was caused by the work done on bug 82711.
Blocks: 82711
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(bmarsd)

Comment 5

4 years ago
I think this "white-space: nowrap" CSS rule might be affecting the feedback textarea (with the selector "ul li > *"):

https://github.com/mozilla-b2g/gaia/blob/9eaea4fa809a4719dc3711cc59ad539aa07c9832/apps/settings/style/lists.css#L152
https://github.com/mozilla-b2g/gaia/blob/41e10422048a95a11255f2833cc7ab775e8bbc8e/apps/settings/elements/improve_browser_os_send_feedback.html

The solution could be to add another CSS rule to set white-space back to pre-wrap for the textarea, or to make the selector more specific so it doesn't affect the textarea. (I don't have a Firefox OS environment so this is just based on looking at the source files, BTW.)
Flags: needinfo?(bmarsd)

Comment 6

4 years ago
Regression blocking
Assignee: nobody → arthur.chen
blocking-b2g: 2.2? → 2.2+
Comment on attachment 8602532 [details] [review]
[gaia] crh0716:1160649 > mozilla-b2g:master

Note that this issue is actually fixed in bug 1158094 in which we allow multi-line menu items. The patch is going to be landed in v2.2.

However, I would still like to land the proposed patch to force wrapping in the text area. By doing this we can prevent the text area from being applied no-wrap by mistake.

Evelyn, could you help review this simple patch while EJ is on vacation? Thanks!
Attachment #8602532 - Flags: review?(ehung)

Comment 9

4 years ago
Comment on attachment 8602532 [details] [review]
[gaia] crh0716:1160649 > mozilla-b2g:master

Reasonable fix.
Attachment #8602532 - Flags: review?(ehung) → review+
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Comment on attachment 8602532 [details] [review]
[gaia] crh0716:1160649 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): N/A
[User impact] if declined: Bad user experience.
[Testing completed]: Testing on the device.
[Risk to taking this patch] (and alternatives if risky): Low
[String changes made]: None
Attachment #8602532 - Flags: approval-gaia-v2.2?
Attachment #8602532 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
This issue is verified fixed on Flame Master.

Result: Text appears in on the next line when the previous line goes over the width of the text field.

Environmental Variables:
Device: Flame 3.0 (KK, 319mb, full flash)
Build ID: 20150508010203
Gaia: bc5bfa18f795919b56b952bbf3637c235d0e13dc
Gecko: 356e735fa908
Gonk: a9f3f8fb8b0844724de32426b7bcc4e6dc4fa2ed
Version: 40.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

========================================
Adding verifyme for 2.2 verification.
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: verifyme
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)

Comment 14

4 years ago
This bug has been verified as pass on latest build of Flame 2.2 by the STR in Comment 0.
Result: Text appears in on the next line when the previous line goes over the width of the text field.
See attachment:1617.mp4

Flame 2.2 build(pass):
Build ID               20150513002507
Gaia Revision          e048df68f6f4853b5826a8816e143d95258149de
Gaia Date              2015-05-12 19:10:26
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/0e6b4aab2b94
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150513.041549
Firmware Date          Wed May 13 04:15:58 EDT 2015
Bootloader             L1TC000118D0

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+] [MGSEI-Triage+]
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.