Odd behaviour on ODS-5 volume

RESOLVED FIXED

Status

()

Core
Networking: File
RESOLVED FIXED
16 years ago
15 years ago

People

(Reporter: Colin Blake, Assigned: Colin Blake)

Tracking

Trunk
DEC
OpenVMS
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

16 years ago
When running Mozilla from an ODS-5 volume, the following behaviour is seen:

- the browser starts with a blank screen, even though a home page is defined
- clicking on "Home" displays this home page
- enter a URL into the URL bar, but hitting <Return> has no effect
- open the Edit --> Preferences... window and the "Navigator" preferences
  page appears with nothing selected (no radio button selected, no check
  boxes ticked; home page location empty)
- change some prefs, click OK, and open the Navigator preferences
  window again and all the changes are gone
- don't see any of the bookmarks defined in BOOKMARK.HTML

This problem does NOT always occur. On a cluster where the installation and
profile and cluster common, it only fails on some nodes.
(Assignee)

Comment 1

16 years ago
The problem occurs when DECC$EFS_CASE_PRESERVE is defined. For now, ensure that 
this logical is NOT defined when running Mozilla.

I need to track down why this is causing a problem and determine what the 
correct solution is.
Status: NEW → ASSIGNED
(Assignee)

Comment 2

16 years ago
Changing the QA contact to Jay. Am I allowed to do that? Jay is not a 
Netscape/Mozilla QA person, but a Compaq QA person. Unlike the Netcape/Mozilla 
QA person, Jay has access to OpenVMS systems :-)
QA Contact: doronr → jfarrell
(Assignee)

Comment 3

16 years ago
*** Bug 108682 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 4

16 years ago
As a bandaid so that other people don't run into this same problem, I'm going to 
modify MOZILLA.COM to ensure that DECC$EFS_CASE_PRESERVE is not defined when 
mozilla runs. This will be in M0.9.7.

I'll try to track down the real problem after Christmas.

Comment 5

16 years ago
you're encouraged to select a QA who can perform QA duties.  In the future, if 
I remember, I might even select this qa contact if you don't mind.
Component: Browser-General → Networking: File

Comment 6

16 years ago
I'm the default QA contact here, and I think this is a good idea.
Just remember to ask for help if you need it.
(Assignee)

Comment 7

15 years ago
Tried this again with 1.4 RC1 and didn't see the problem anymore. Tried both
Mozilla running from an ODS-5 disk and with the profile being on an ODS-5 disk.
Both with DECC$EFS_CASE_PRESERVE set to 1.

I believe whatever this problem was, is now fixed.

Closing.
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.