thumbnail image corruption on certain videos

RESOLVED FIXED in Firefox 40

Status

()

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: diego, Assigned: diego)

Tracking

unspecified
mozilla40
ARM
Gonk (Firefox OS)
Points:
---

Firefox Tracking Flags

(blocking-b2g:2.2+, firefox38 wontfix, firefox39 wontfix, firefox40 fixed, b2g-v2.2 fixed, b2g-master fixed)

Details

(Whiteboard: [caf priority: p2][CR 812421])

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

4 years ago
STR:
1. upload a QCIF MPEG4 video file
2. Open video app

Result: the thumbnail video is scrambled

I can only reproduce on a prototype Lollipop device, but I have a patch that I'm attaching.
(Assignee)

Comment 1

4 years ago
Created attachment 8600516 [details] [diff] [review]
Query stride when converting HAL_PIXEL_FORMAT_YCrCb_420_SP
Attachment #8600516 - Flags: review?(sotaro.ikeda.g)
(Assignee)

Updated

4 years ago
blocking-b2g: --- → 2.2?
No longer depends on: 1147763
Whiteboard: [CR 812421] → [caf priority: p2][CR 812421]
Comment on attachment 8600516 [details] [diff] [review]
Query stride when converting HAL_PIXEL_FORMAT_YCrCb_420_SP

Review of attachment 8600516 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good!
Attachment #8600516 - Flags: review?(sotaro.ikeda.g) → review+
(Assignee)

Comment 3

4 years ago
Created attachment 8601168 [details] [diff] [review]
Query stride when converting HAL_PIXEL_FORMAT_YCrCb_420_SP

Format patch for HG and carry over r=sotaro
Attachment #8601168 - Flags: review+
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
(Assignee)

Updated

4 years ago
Attachment #8600516 - Attachment is obsolete: true
can we get a try run for this changes, thanks!
Flags: needinfo?(dwilson)
Keywords: checkin-needed

Updated

4 years ago
Status: NEW → ASSIGNED
blocking-b2g: 2.2? → 2.2+

Comment 5

4 years ago
Hi! Diego,

Please file approval‑mozilla‑b2g37 before checkin.
Thanks

--
Keven
(Assignee)

Comment 6

4 years ago
Comment on attachment 8601168 [details] [diff] [review]
Query stride when converting HAL_PIXEL_FORMAT_YCrCb_420_SP

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 961713
User impact if declined: The thumbnails of certain H.264 videos will be scrambled
Testing completed: Verified the thumbnails of videos look correctly in FxOS video app
Risk to taking this patch (and alternatives if risky): This is a low risk patch
String or UUID changes made by this patch: None
Flags: needinfo?(dwilson)
Attachment #8601168 - Flags: approval-mozilla-b2g37?

Updated

4 years ago
Attachment #8601168 - Flags: approval-mozilla-b2g37? → approval-mozilla-b2g37+
(Assignee)

Comment 7

4 years ago
Tomcat,

Try build https://treeherder.mozilla.org/#/jobs?repo=try&revision=d8daf6ac7801

A couple of test failures but it seems like known intermittent failures. Does it look sane to you?
Flags: needinfo?(cbook)
https://hg.mozilla.org/mozilla-central/rev/819c760b572f
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
status-firefox40: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla40
https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/8a58f3410430
status-b2g-v2.2: --- → fixed
status-b2g-master: --- → fixed
status-firefox38: --- → wontfix
status-firefox39: --- → wontfix
Flags: needinfo?(cbook)
You need to log in before you can comment on or make changes to this bug.