No nsIFile::RenameToNative

RESOLVED FIXED in mozilla41

Status

()

--
enhancement
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: neil, Unassigned)

Tracking

Trunk
mozilla41
Points:
---

Firefox Tracking Flags

(firefox40 affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
While looking into bug 1155963 I noticed the following code pattern:

> NS_ConvertASCIItoUTF16 defDirName(NS_LITERAL_CSTRING(kDefaultDirectoryName));
> rv = persistentStorageDir->RenameTo(nullptr, defDirName);

kDefaultDirectoryName is currently a const char array, so for bug 1155963 I changed the code to use a #define and NS_LITERAL_STRING. However I noticed the awkwardness was in part caused by the lack of a RenameToNative function.

Nobody actually needs a RenameToNative at this point though.
(Reporter)

Comment 1

3 years ago
Created attachment 8600583 [details] [diff] [review]
1160743.diff
Attachment #8600583 - Flags: review?(nfroyd)
Attachment #8600583 - Flags: review?(nfroyd) → review+
(Reporter)

Comment 2

3 years ago
(In reply to comment #0)
> kDefaultDirectoryName is currently a const char array, so for bug 1155963 I
> changed the code to use a #define and NS_LITERAL_STRING. However I noticed
> the awkwardness was in part caused by the lack of a RenameToNative function.

Whoops, I seem to have accidentally landed this along with bug 1155963.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla41
You need to log in before you can comment on or make changes to this bug.