wrong --find-links URL in pip install in Makefile

RESOLVED FIXED

Status

RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: oleg84, Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/42.0.2311.135 Safari/537.36

Steps to reproduce:

I followed this insttruction: http://olympia.readthedocs.org/en/latest/topics/install-olympia/installation.html. The failing step is make full_update


Actual results:

I got the following error:

Downloading/unpacking django-pymemcache==0.1.1-fixserial (from -r requirements/prod.txt (line 32))
Could not find a version that satisfies the requirement django-pymemcache==0.1.1-fixserial (from -r requirements/prod.txt (line 32)) (from versions: )
No distributions matching the version for django-pymemcache==0.1.1-fixserial (from -r requirements/prod.txt (line 32))


Expected results:

The django-pymemcache==0.1.1-fixserial should have been installed. 

The issue is similar to the one described here (Zambony project): https://bugzilla.mozilla.org/show_bug.cgi?id=997224
(Reporter)

Comment 1

3 years ago
How do I specify the version in the version field? The commit hash is 1a0baf66ba5b53baf2ae6bf6ef1bb0ce2758eb1e
(Reporter)

Updated

3 years ago
OS: Unspecified → Linux
Hardware: Unspecified → x86_64
(Reporter)

Comment 2

3 years ago
Created attachment 8600638 [details] [diff] [review]
1160806_proposed_fix.patch

Here is a proposed patch. It just changes the URL in the Makefile.

Comment 3

3 years ago
Thanks for the patch, the URL has since changed to pyrepo.stage.mozaws.net, so this patch will no longer be invalid. Please note we prefer accept patches through github rather than bugzilla.

I'll note that in our site we currently use pyrepo three different ways:

https://pyrepo.stage.mozaws.net/olympia/
https://pyrepo.stage.mozaws.net/
https://pyrepo.stage.mozaws.net/wheelhouse

Assuming all those are ok? Need infoing jason because he changed this recently.
Flags: needinfo?(jthomas)
(In reply to Andy McKay [:andym] from comment #3)
> https://pyrepo.stage.mozaws.net/olympia/
I use this one to build our packages for deployment.

> https://pyrepo.stage.mozaws.net/
I don't think we should be using this anymore.

> https://pyrepo.stage.mozaws.net/wheelhouse
This is used by Travis IIRC.
Flags: needinfo?(jthomas)

Comment 5

3 years ago
This is being fixed in https://github.com/mozilla/olympia/pull/1442
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Assignee)

Updated

3 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.