Closed Bug 1160883 (Frisian-WordPrediction) Opened 5 years ago Closed 5 years ago

Add Frisian (fy or fy-NL) wordlist/dictionary

Categories

(Firefox OS Graveyard :: Gaia::Keyboard, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.2+, b2g-v2.2 fixed, b2g-master fixed)

RESOLVED FIXED
FxOS-S1 (26Jun)
blocking-b2g 2.2+
Tracking Status
b2g-v2.2 --- fixed
b2g-master --- fixed

People

(Reporter: fryskefirefox, Assigned: rudyl)

References

Details

Attachments

(4 files)

This is a request to add Frisian wordlist/dictionary to Firefox OS.
The XML-file made by Kevin Scannell is attached.
Attached file fy.zip
Zipped version of the xml-file
What is the way to process this request? 
Is there something I can do myself, like xml to dict with Python?
Hey Wim! I'll need info Kevin as I'm sure he has some tips :) thanks!
Flags: needinfo?(kscanne)
For the other dictionaries I've done, someone else has always landed the patch on github... not sure about the process.
Flags: needinfo?(kscanne)
Let's see if Rudy can help with this?
Flags: needinfo?(rlu)
We would need to get a keyboard layout implemented first, and then we could add the dictionary.
Could anyone on this provide a ref. to the keyboard layout we want for Frisian language?

If not, I'll try to find one from Android or other sources.
Flags: needinfo?(rlu)
Hi Rudy, you mean the one mentioned in https://bugzilla.mozilla.org/show_bug.cgi?id=1153136 ?
Yes, thanks for bringing this up.
Let's mark the dependency and I am going to take a look at that patch.
Depends on: 1153136
Assignee: nobody → rlu
Status: NEW → ASSIGNED
Comment on attachment 8611158 [details] [review]
[gaia] RudyLu:keyboard/Bug1153136-Add_Frisian_layout > mozilla-b2g:master

The layout and the dictionary are ready.

Tim, could you help review this?

Wim, if possible, please help take a look if the layout/dictionary is ok.

Thanks.
Attachment #8611158 - Flags: review?(timdream)
Attachment #8611158 - Flags: feedback?(fryskefirefox)
Hello Rudy Lu,

Thank you for all your hard work, really awesome!

I took the Dutch keyboard from github https://github.com/janjongboom/fxos-dutch-keyboard,
hacked it to the Frisian version and pushed it with WebIDE to my Flame.
And it works, both the wordsuggestions as well as the special characters.

If Tim agrees this bug and https://bugzilla.mozilla.org/show_bug.cgi?id=1153136 can be closed.
Comment on attachment 8611158 [details] [review]
[gaia] RudyLu:keyboard/Bug1153136-Add_Frisian_layout > mozilla-b2g:master

The dict need to be on the CDN too.
Attachment #8611158 - Flags: review?(timdream) → review+
Attached file pr to update the CDN
Hi Benson,

Could you please help review this, adding a new dictionary to our CDN?
Thanks.
Attachment #8612685 - Flags: review?(bwong)
Comment on attachment 8612685 [details] [review]
pr to update the CDN

Looks good. Merged
Attachment #8612685 - Flags: review?(bwong) → review+
Shall I deploy this to the CDN?
Benson,

Yes, please.
Thanks a lot for your help.
Flags: needinfo?(bwong)
Comment on attachment 8611158 [details] [review]
[gaia] RudyLu:keyboard/Bug1153136-Add_Frisian_layout > mozilla-b2g:master

File looks good.
Attachment #8611158 - Flags: feedback?(fryskefirefox) → feedback+
CDN has been updated with the new files.
Flags: needinfo?(bwong)
Benson, thanks.

Let's try to merge this.
Keywords: checkin-needed
http://docs.taskcluster.net/tools/task-graph-inspector/#ztZnQQTDTUStQsfEvWmf7g

The pull request failed to pass integration tests. It could not be landed, please try again.
Landed to Gaia master,
https://github.com/mozilla-b2g/gaia/commit/b6c5fda821dce99babf8b9d5799a95eb4aeca64a
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Josh: once more this is a locale that was 100% completed and tested on 2.2, and that we can sign-off on l10n side if they get the autocorrection in. Since this is minimal risk patch, can we get an approval to land on 2.2?
Flags: needinfo?(jocheng)
Flags: needinfo?(jocheng)
Hi Rudy,
Can you raise 2.2 Uplift approval? Thanks!
Flags: needinfo?(rlu)
Attached file Patch for v2.2
Flags: needinfo?(rlu)
Comment on attachment 8626498 [details] [review]
Patch for v2.2

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): New feature, a new keyboard layout
[User impact] if declined: The native Frisian user would not have keyboard to input.
[Testing completed]: Yes, manually
[Risk to taking this patch] (and alternatives if risky): Low, the newly added keyboard layout won't be enabled if not explicitly specified.
[String changes made]: N/A
Attachment #8626498 - Flags: approval-gaia-v2.2?
blocking-b2g: --- → 2.2+
Attachment #8626498 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
Alias: Frisian-WordPrediction
No longer depends on: 1153136
Duplicate of this bug: 1153136
You need to log in before you can comment on or make changes to this bug.