If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[RTL][Settings]Parentheses in song title are not displayed correctly on delete ringtone view.

RESOLVED WONTFIX

Status

Firefox OS
Gaia::Settings
RESOLVED WONTFIX
2 years ago
2 years ago

People

(Reporter: Sue, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.2 affected, b2g-master unaffected)

Details

(Whiteboard: [2.2-nexus-5-l])

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8600748 [details]
wrong_parentheses.png

[1.Description]:
[RTL][Flame v2.2][Nexus5 2.2][Settings]Parentheses in song title are not displayed correctly on the prompt message of delete ringtone view.
See attachment:wrong_parentheses.png

[2.Testing Steps]: 
Prerequisite: Have at least 1 song containing parentheses in the title in the Ringtones list.
1. Set system language as Arabic.
2. Launch Settings -> Sound -> Manage Tones.
3. Tap the "..." button at left side of the ringtone's name.
4. Select "Delete ringtone" and observe the prompt message. 

[3.Expected Result]: 
4. The parentheses should be displayed correctly.

[4.Actual Result]: 
4. The parentheses are not located correctly.

[5.Reproduction build]: 
Device: Flame 2.2 (affected)
Build ID               20150503162504
Gaia Revision          8d14361337e608c8cdf165ea5034db5eda23b618
Gaia Date              2015-05-01 18:23:46
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/cb7cb6597c91
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150503.200206
Firmware Date          Sun May  3 20:02:17 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 3.0 (unaffected)
Build ID               20150503160200
Gaia Revision          e18cce173840d6ff07fb6f1f0e0ffb58b99aab3e
Gaia Date              2015-05-02 04:27:01
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/dc5f85980a82
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150503.193941
Firmware Date          Sun May  3 19:39:52 EDT 2015
Bootloader             L1TC000118D0

Device: Nexus 5 2.2 (affected)
Build ID               20150503002500
Gaia Revision          8d14361337e608c8cdf165ea5034db5eda23b618
Gaia Date              2015-05-01 18:23:46
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/cb7cb6597c91
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150503.040229
Firmware Date          Sun May  3 04:02:46 EDT 2015
Bootloader             HHZ12f

Device: Nexus 5 3.0 (unaffected)
Build ID               20150503160200
Gaia Revision          e18cce173840d6ff07fb6f1f0e0ffb58b99aab3e
Gaia Date              2015-05-02 04:27:01
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/dc5f85980a82
Gecko Version          40.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150503.193953
Firmware Date          Sun May  3 19:40:11 EDT 2015
Bootloader             HHZ12f

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
(Reporter)

Updated

2 years ago
QA Whiteboard: [rtl-impact]
status-b2g-v2.2: --- → affected
status-b2g-master: --- → unaffected
See Also: → bug 1151496

Comment 1

2 years ago
Fixing this requires changing L10N strings, and it's far too late to do that for 2.2. Unfortunately, this means that there's not much we can do about this. Of course, anyone distributing v2.2 is (probably?) free to change the relevant strings to fix this bug. If you choose to go this route, you can consult the strings in v3.0 to see how they should be formatted now: <https://github.com/mozilla-b2g/gaia/blob/791da5c2004c5c36e276af599af39218ca9393fd/apps/ringtones/locales/ringtones.en-US.properties#L13-L15>.

:zibi, given the above, should this bug be resolved WONTFIX?
Flags: needinfo?(gandalf)
Jim: is this a regression from Bug 1151496?
Flags: needinfo?(squibblyflabbetydoo)

Comment 3

2 years ago
Delphine: No. This was fixed in bug 1151496, but because this part of the fix required an l10n change, I had to exclude it from the rest of the patch when I uplifted it to 2.2. Thus, on 2.2, this bug is still present (but the rest of bug 1151496 is fixed), and on 3.0, everything is ok.
Flags: needinfo?(squibblyflabbetydoo)
Correct I remember now, read through that bug too fast.
I would say let's close this as won't fix too given bug 1151496 was resolved in a way as to not break string freeze at this point. But let's wait for gandalf to give his final answer.
I believe we should mark it as WONTFIX.
Flags: needinfo?(gandalf)
Marking as wontfix as per comment 5.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.