Various layout reftest failures when Gecko 40 merges to beta

VERIFIED FIXED in Firefox 40

Status

()

Core
Layout
--
major
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: RyanVM, Assigned: jfkthame)

Tracking

Trunk
mozilla40
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox40 verified)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
+++ This bug was initially created as a clone of Bug #1157691 +++

https://treeherder.mozilla.org/logviewer.html#?job_id=7172243&repo=try

16:49:22 INFO - REFTEST TEST-UNEXPECTED-FAIL | file:///builds/slave/test/build/tests/reftest/tests/layout/reftests/forms/input/range/range-orient-inline.html | image comparison (==), max difference: 110, number of differing pixels: 510
16:49:23 INFO - REFTEST TEST-UNEXPECTED-FAIL | file:///builds/slave/test/build/tests/reftest/tests/layout/reftests/forms/input/range/range-vlr.html | image comparison (==), max difference: 110, number of differing pixels: 506
16:49:24 INFO - REFTEST TEST-UNEXPECTED-FAIL | file:///builds/slave/test/build/tests/reftest/tests/layout/reftests/forms/input/range/range-vlr-orient-inline.html | image comparison (==), max difference: 110, number of differing pixels: 506
16:49:26 INFO - REFTEST TEST-UNEXPECTED-FAIL | file:///builds/slave/test/build/tests/reftest/tests/layout/reftests/forms/input/range/range-vrl.html | image comparison (==), max difference: 110, number of differing pixels: 506
16:49:27 INFO - REFTEST TEST-UNEXPECTED-FAIL | file:///builds/slave/test/build/tests/reftest/tests/layout/reftests/forms/input/range/range-vrl-orient-inline.html | image comparison (==), max difference: 110, number of differing pixels: 506
(Reporter)

Updated

3 years ago
Flags: needinfo?(jfkthame)
(Assignee)

Comment 1

3 years ago
Created attachment 8601411 [details] [diff] [review]
Use -moz-margin-start/end rather than margin-inline-start/end in UA stylesheets, to avoid being dependent on the writing-mode pref

These tests fail when run as Beta because the dynamic pref setting in the reftest manifest is not sufficient to make us reload the UA stylesheets (including forms.css), which were previously parsed with vertical-text.enabled=false. And because margin-inline-start/end are currently aliases to the old prefixed -moz-margin-start/end, they aren't covered by a CSS_PROPERTY_ALWAYS_ENABLED_IN_UA_SHEETS flag in nsCSSPropList.h, which is what keeps the other logical properties working. So for now, we should just stick with the -moz-margin-* versions in forms.css.
Attachment #8601411 - Flags: review?(jwatt)
(Assignee)

Updated

3 years ago
Assignee: nobody → jfkthame
Status: NEW → ASSIGNED
(Assignee)

Updated

3 years ago
Flags: needinfo?(jfkthame)
That means the test failures are actually showing real bugs then, right?
(Assignee)

Comment 3

3 years ago
(In reply to David Baron [:dbaron] ⏰UTC+2 (busy, returning May 21) from comment #2)
> That means the test failures are actually showing real bugs then, right?

Yes, they're real bugs that would show up on beta (and release) where the vertical-text pref disabled by default. So the patch here fixes them and makes the CSS work as intended across all channels.
Attachment #8601411 - Flags: review?(jwatt) → review+
(Assignee)

Comment 4

3 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/a91f9bcf83e8
https://hg.mozilla.org/mozilla-central/rev/a91f9bcf83e8
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
status-firefox40: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla40
(Reporter)

Comment 6

3 years ago
These are verified to be fixed, but now there are new failures :(
Status: RESOLVED → VERIFIED
status-firefox40: fixed → verified
(Reporter)

Updated

3 years ago
Depends on: 1162485
You need to log in before you can comment on or make changes to this bug.