Various serviceworker web-platform tests are going to permafail when Gecko 40 merges to Beta due to "self.caches is undefined"

VERIFIED DUPLICATE of bug 1163829

Status

()

--
major
VERIFIED DUPLICATE of bug 1163829
4 years ago
4 years ago

People

(Reporter: RyanVM, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(firefox40 verified)

Details

(Reporter)

Description

4 years ago
https://treeherder.mozilla.org/logviewer.html#?job_id=7172227&repo=try

17:01:06 INFO - TEST-START | /service-workers/cache-storage/common.https.html
17:01:06 INFO - PROCESS | 2142 | WARNING: content window passed to PrivateBrowsingUtils.isWindowPrivate. Use isContentWindowPrivate instead (but only for frame scripts).
17:01:06 INFO - PROCESS | 2142 | pbu_isWindowPrivate@resource://gre/modules/PrivateBrowsingUtils.jsm:25:14
17:01:06 INFO - PROCESS | 2142 | nsBrowserAccess.prototype.openURI@chrome://browser/content/browser.js:15522:21
17:01:06 INFO - PROCESS | 2142 | __marionetteFunc@dummy file:19:30
17:01:06 INFO - PROCESS | 2142 | @dummy file:28:3
17:01:06 INFO - PROCESS | 2142 | executeWithCallback@chrome://marionette/content/listener.js:743:5
17:01:06 INFO - PROCESS | 2142 | executeAsyncScript@chrome://marionette/content/listener.js:642:3
17:01:07 INFO - TEST-UNEXPECTED-FAIL | /service-workers/cache-storage/common.https.html | Window sees cache puts by Worker - self.caches is undefined
17:01:07 INFO - @https://web-platform.test:8443/service-workers/cache-storage/common.https.html:20:5
17:01:07 INFO - Test.prototype.step@https://web-platform.test:8443/resources/testharness.js:1304:20
17:01:07 INFO - promise_test@https://web-platform.test:8443/resources/testharness.js:461:25
17:01:07 INFO - @https://web-platform.test:8443/service-workers/cache-storage/common.https.html:18:1
17:01:07 INFO - TEST-OK | /service-workers/cache-storage/common.https.html | took 868ms

etc...
I think we can either disable these tests in beta or add the dom.caches.enabled pref to every .ini file.  James, is there a way to do this without a ton of ini files?
Flags: needinfo?(james)
Ehsan fixed this in bug 1163829.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(james)
Resolution: --- → DUPLICATE
Duplicate of bug: 1163829
(Reporter)

Updated

4 years ago
Status: RESOLVED → VERIFIED
status-firefox40: affected → verified
You need to log in before you can comment on or make changes to this bug.