Intermittent service-workers/cache-storage/worker/cache-add.https.html | Cache.add called with relative URL specified as a string - Test timed out (and others after it)

RESOLVED FIXED in Firefox 40

Status

()

Core
DOM: Workers
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: RyanVM, Assigned: bkelly)

Tracking

({intermittent-failure})

Trunk
mozilla40
x86_64
Windows 8
intermittent-failure
Points:
---

Firefox Tracking Flags

(firefox38 unaffected, firefox38.0.5 unaffected, firefox39 unaffected, firefox40 fixed, firefox-esr31 unaffected, firefox-esr38 unaffected)

Details

(URL)

(Reporter)

Description

3 years ago
18:05:53 INFO - TEST-START | /service-workers/cache-storage/worker/cache-add.https.html
18:05:53 INFO - PROCESS | 4040 | WARNING: content window passed to PrivateBrowsingUtils.isWindowPrivate. Use isContentWindowPrivate instead (but only for frame scripts).
18:05:53 INFO - PROCESS | 4040 | pbu_isWindowPrivate@resource://gre/modules/PrivateBrowsingUtils.jsm:25:14
18:05:53 INFO - PROCESS | 4040 | nsBrowserAccess.prototype.openURI@chrome://browser/content/browser.js:15578:21
18:05:53 INFO - PROCESS | 4040 | __marionetteFunc@dummy file:19:30
18:05:53 INFO - PROCESS | 4040 | @dummy file:28:3
18:05:53 INFO - PROCESS | 4040 | executeWithCallback@chrome://marionette/content/listener.js:743:5
18:05:53 INFO - PROCESS | 4040 | executeAsyncScript@chrome://marionette/content/listener.js:642:3
18:06:03 INFO - PROCESS | 4040 | MARIONETTE LOG: INFO: Timeout fired
18:06:03 INFO - TEST-PASS | /service-workers/cache-storage/worker/cache-add.https.html | Cache.add called with no arguments
18:06:03 INFO - TEST-UNEXPECTED-TIMEOUT | /service-workers/cache-storage/worker/cache-add.https.html | Cache.add called with relative URL specified as a string - Test timed out
18:06:03 INFO - TEST-FAIL | /service-workers/cache-storage/worker/cache-add.https.html | Cache.add called with non-HTTP/HTTPS URL - assert_throws: Cache.add should throw a NetworkError for non-HTTP/HTTPS URLs. function "function () { throw e; }" threw object "TypeError: Request URL javascript://this-is-not-http-mmka..." that is not a DOMException NetworkError: property "code" is equal to undefined, expected 19
18:06:03 INFO - assert_promise_rejects/<@https://web-platform.test:8443/service-workers/cache-storage/resources/testharness-helpers.js:30:9
18:06:03 INFO - Promise*@https://web-platform.test:8443/service-workers/cache-storage/script-tests/cache-add.js:24:1
18:06:03 INFO - Promise*create_temporary_cache@https://web-platform.test:8443/service-workers/cache-storage/resources/test-helpers.js:14:1
18:06:03 INFO - cache_test/<@https://web-platform.test:8443/service-workers/cache-storage/resources/test-helpers.js:34:14
18:06:03 INFO - Test.prototype.step@https://web-platform.test:8443/resources/testharness.js:1304:20
18:06:03 INFO - promise_test@https://web-platform.test:8443/resources/testharness.js:461:25
18:06:03 INFO - cache_test@https://web-platform.test:8443/service-workers/cache-storage/resources/test-helpers.js:33:1
18:06:03 INFO - @https://web-platform.test:8443/service-workers/cache-storage/script-tests/cache-add.js:22:1
18:06:03 INFO - TEST-FAIL | /service-workers/cache-storage/worker/cache-add.https.html | Cache.add called with Request object - promise_test: Unhandled rejection with value: object "TypeError: Invalid request method POST."
18:06:03 INFO - cache_test@https://web-platform.test:8443/service-workers/cache-storage/resources/test-helpers.js:33:1
18:06:03 INFO - @https://web-platform.test:8443/service-workers/cache-storage/script-tests/cache-add.js:29:1
18:06:03 INFO - TEST-FAIL | /service-workers/cache-storage/worker/cache-add.https.html | Cache.add called with Request object with a used body - assert_false: expected false got true
18:06:03 INFO - @https://web-platform.test:8443/service-workers/cache-storage/script-tests/cache-add.js:42:11
18:06:03 INFO - Promise*@https://web-platform.test:8443/service-workers/cache-storage/script-tests/cache-add.js:40:12
18:06:03 INFO - Promise*create_temporary_cache@https://web-platform.test:8443/service-workers/cache-storage/resources/test-helpers.js:14:1
18:06:03 INFO - cache_test/<@https://web-platform.test:8443/service-workers/cache-storage/resources/test-helpers.js:34:14
18:06:03 INFO - Test.prototype.step@https://web-platform.test:8443/resources/testharness.js:1304:20
18:06:03 INFO - promise_test@https://web-platform.test:8443/resources/testharness.js:461:25
18:06:03 INFO - cache_test@https://web-platform.test:8443/service-workers/cache-storage/resources/test-helpers.js:33:1
18:06:03 INFO - @https://web-platform.test:8443/service-workers/cache-storage/script-tests/cache-add.js:38:1
18:06:03 INFO - TEST-FAIL | /service-workers/cache-storage/worker/cache-add.https.html | Cache.add called twice with the same Request object - promise_test: Unhandled rejection with value: object "TypeError: Invalid request method POST."
18:06:03 INFO - cache_test@https://web-platform.test:8443/service-workers/cache-storage/resources/test-helpers.js:33:1
18:06:03 INFO - @https://web-platform.test:8443/service-workers/cache-storage/script-tests/cache-add.js:49:1
18:06:03 INFO - TEST-UNEXPECTED-TIMEOUT | /service-workers/cache-storage/worker/cache-add.https.html | Cache.add with request that results in a status of 404 - Test timed out
18:06:03 INFO - TEST-UNEXPECTED-TIMEOUT | /service-workers/cache-storage/worker/cache-add.https.html | Cache.add with request that results in a status of 500 - Test timed out
18:06:03 INFO - TEST-PASS | /service-workers/cache-storage/worker/cache-add.https.html | Cache.addAll with no arguments
18:06:03 INFO - TEST-PASS | /service-workers/cache-storage/worker/cache-add.https.html | Cache.addAll with a mix of valid and undefined arguments
18:06:03 INFO - TEST-UNEXPECTED-TIMEOUT | /service-workers/cache-storage/worker/cache-add.https.html | Cache.addAll with string URL arguments - Test timed out
18:06:03 INFO - TEST-UNEXPECTED-TIMEOUT | /service-workers/cache-storage/worker/cache-add.https.html | Cache.addAll with Request arguments - Test timed out
18:06:03 INFO - TEST-UNEXPECTED-TIMEOUT | /service-workers/cache-storage/worker/cache-add.https.html | Cache.addAll with a mix of succeeding and failing requests - Test timed out
18:06:03 INFO - TEST-FAIL | /service-workers/cache-storage/worker/cache-add.https.html | Cache.addAll called with the same Request object specified twice - assert_throws: Cache.addAll should throw TypeError if the same request is added twice. function "function () { throw e; }" threw object "InvalidStateError: An attempt was made to use an object t..." ("InvalidStateError") expected object "TypeError" ("TypeError")
18:06:03 INFO - assert_promise_rejects/<@https://web-platform.test:8443/service-workers/cache-storage/resources/testharness-helpers.js:30:9
18:06:03 INFO - Promise*@https://web-platform.test:8443/service-workers/cache-storage/script-tests/cache-add.js:139:1
18:06:03 INFO - Promise*create_temporary_cache@https://web-platform.test:8443/service-workers/cache-storage/resources/test-helpers.js:14:1
18:06:03 INFO - cache_test/<@https://web-platform.test:8443/service-workers/cache-storage/resources/test-helpers.js:34:14
18:06:03 INFO - Test.prototype.step@https://web-platform.test:8443/resources/testharness.js:1304:20
18:06:03 INFO - promise_test@https://web-platform.test:8443/resources/testharness.js:461:25
18:06:03 INFO - cache_test@https://web-platform.test:8443/service-workers/cache-storage/resources/test-helpers.js:33:1
18:06:03 INFO - @https://web-platform.test:8443/service-workers/cache-storage/script-tests/cache-add.js:136:1
18:06:03 INFO - TEST-UNEXPECTED-TIMEOUT | /service-workers/cache-storage/worker/cache-add.https.html | expected OK
18:06:03 INFO - TEST-INFO took 10114ms
Comment hidden (Treeherder Robot)
(Assignee)

Updated

3 years ago
Assignee: nobody → bkelly
Status: NEW → ASSIGNED
(Reporter)

Comment 2

3 years ago
Probably a dupe of bug 1160013.
Depends on: 1160013
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Comment 5

3 years ago
The pattern of timeouts in bug 1160013 is different.  I don't think these are related.

I just think the default timeout in wpt for these tests is too low.  I've seen success cases take 7 seconds and the timeout is 10 seconds.

I've submitted a patch upstream to increase the timeout for all Cache API tests.  This try build is encouraging:

  https://treeherder.mozilla.org/#/jobs?repo=try&revision=3ee720899303
(Assignee)

Updated

3 years ago
Blocks: 1160389
(Assignee)

Updated

3 years ago
No longer blocks: 1160389
(Assignee)

Updated

3 years ago
Depends on: 1162090
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Updated

3 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Reporter)

Updated

3 years ago
status-firefox38: --- → unaffected
status-firefox38.0.5: --- → unaffected
status-firefox39: --- → unaffected
status-firefox40: affected → fixed
status-firefox-esr31: --- → unaffected
status-firefox-esr38: --- → unaffected
Target Milestone: --- → mozilla40
You need to log in before you can comment on or make changes to this bug.