2-5.4% Linux* tp5o_scroll/tp5o/tscrollx (tscroll-ASAP) regression on Mozilla-Inbound-Non-PGO (v.40) on May 01, 2015 from push b4fd9967aa85

RESOLVED DUPLICATE of bug 1160584

Status

Testing
Talos
RESOLVED DUPLICATE of bug 1160584
3 years ago
3 years ago

People

(Reporter: vaibhav1994, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
Talos has detected a Firefox performance regression from your commit b4fd9967aa85.  We need you to address this regression.

This is a list of all known regressions and improvements related to your bug:
http://alertmanager.allizom.org:8080/alerts.html?rev=b4fd9967aa85&showAll=1

On the page above you can see Talos alert for each affected platform as well as a link to a graph showing the history of scores for this test. There is also a link to a treeherder page showing the Talos jobs in a pushlog format.

To learn more about the regressing test, please see: https://wiki.mozilla.org/Buildbot/Talos/Tests#tp5

Reproducing and debugging the regression:
If you would like to re-run this Talos test on a potential fix, use try with the following syntax:
try: -b o -p linux -u none -t tp5o  # add "mozharness: --spsProfile" to generate profile data

To run the test locally and do a more in-depth investigation, first set up a local Talos environment:
https://wiki.mozilla.org/Buildbot/Talos/Running#Running_locally_-_Source_Code

Then run the following command from the directory where you set up Talos:
talos --develop -e <path>/firefox -a tp5o

Making a decision:
As the patch author we need your feedback to help us handle this regression.
*** Please let us know your plans by Thursday, or the offending patch will be backed out! ***

Our wiki page oulines the common responses and expectations:
https://wiki.mozilla.org/Buildbot/Talos/RegressionBugsHandling
(Reporter)

Comment 1

3 years ago
Hi Matthew and Matt, one of the two revisions, 
http://hg.mozilla.org/integration/fx-team/rev/b4fd9967aa85 or 
http://hg.mozilla.org/integration/fx-team/rev/6404e6d64787 is causing a regression on fx-team-non-pgo:
http://alertmanager.allizom.org:8080/alerts.html?rev=b4fd9967aa85&showAll=1&testIndex=0&platIndex=0

I have done retriggers on treeherder: https://treeherder.mozilla.org/#/jobs?repo=fx-team&fromchange=c732db3afd50&tochange=55826466dd7b&filter-searchStr=Ubuntu%20HW%2012.04%20x64%20fx-team%20talos%20g1 
and you can see that for b4fd9967aa85 push, values for tp5o_scroll has gone to >11.80 from ~11.40

Can you look into the issue, possibly do two pushes to try (one with your patch, one without) and find the offending patch causing the regression? Thanks
Flags: needinfo?(mking)
Flags: needinfo?(MattN+bmo)
thanks vaibhav, great work here, this looks like an issue and there are 3 patches in the push.
This is a dupe of bug 1160584.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(mking)
Flags: needinfo?(MattN+bmo)
Resolution: --- → DUPLICATE
Duplicate of bug: 1160584

Comment 4

3 years ago
Here's a try with my patch reverted. https://treeherder.mozilla.org/#/jobs?repo=try&revision=237365281603

Comment 5

3 years ago
Ah, nevermind, just saw the previous comment. Good to know!
You need to log in before you can comment on or make changes to this bug.