PlacesUIUtils.leftPaneFolderId and friends should use Bookmarks.jsm

RESOLVED DUPLICATE of bug 1310295

Status

()

defect
P3
normal
RESOLVED DUPLICATE of bug 1310295
4 years ago
Last year

People

(Reporter: mak, Unassigned)

Tracking

(Blocks 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [qf])

Reporter

Description

4 years ago
A lot of code depends on the synchronous behavior of PlacesUIUtils.leftPaneFolderId, among which other widely used utils:
PUIU.leftPaneQueries
PUIU.allBookmarksFolderId
PUIU.getLeftPaneQueryNameFromId
PUIU.isContentsReadOnly

We need to refactor these one by one and evaluate how we can make them async without breaking the world.
Reporter

Updated

4 years ago
Priority: -- → P3
Reporter

Updated

2 years ago
Depends on: 1310295
Whiteboard: [qf]
Reporter

Comment 1

2 years ago
bug 1310295 is a better path forward
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1310295
You need to log in before you can comment on or make changes to this bug.