If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

clicking add to pocket button - results in infinite spinner

RESOLVED INVALID

Status

()

Firefox
Pocket
RESOLVED INVALID
3 years ago
3 years ago

People

(Reporter: edwong, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(firefox40 affected)

Details

(Reporter)

Description

3 years ago
cloned from https://github.com/Pocket/Firefox/issues/15

1. run with latest Nightly build
2. set pocket prefs - browser.pocket.hostname=https://firefox.dev.readitlater.com and browser.pocket.enabled = true
3. restart
4. create an acct and add items
5. restart and click on the 'add to pocket' button

actual: door hanger has a infinite spinner
console prints:
"TypeError: doc.documentElement is null"

nate believes this is a Firefox issue.
(Reporter)

Comment 1

3 years ago
:dolske - not sure how dev wants to investigate.
Flags: needinfo?(dolske)

Comment 2

3 years ago
Convo on IRC:

1:07 PM <nate> edwong: Is your pocket hostname value include the "https://" part in it? If so, I think that might be the issue.
1:08 PM <nate> If I set the hostname to https://firefox.dev.readitlater.com I can repro. If I just use the domain firefox.dev.readitlater.com it works fine
1:19 PM <sphilp> nate, edwong: confirmed ^. i had the protocol-less url
1:22 PM <sphilp> via charles, it looks like it tries to request to https://https

Looks like it's related to the parsing of the browser.pocket.hostname pref
(Reporter)

Comment 3

3 years ago
Yup - the pref shouldn't have https:// in it -- closing
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(dolske)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.