Handle parentheses in RTL

RESOLVED WONTFIX

Status

Marketplace
Payments/Refunds
P3
normal
RESOLVED WONTFIX
3 years ago
2 years ago

People

(Reporter: krupa, Unassigned)

Tracking

x86
Gonk (Firefox OS)
Points:
---

Details

(URL)

(Reporter)

Description

3 years ago
steps to reproduce:
1. Load https://marketplace-dev.allizom.org/new?lang=ar
2. Notice app names which have parentheses 


expected behavior:
in RTL, we still retain ()


actual behavior:
in RTL, parentheses change to ) text )

screenshot: https://www.dropbox.com/s/fmhmap6qg0z5oc1/Screenshot%202015-05-04%2010.05.31.png?dl=0

screenshot: https://www.dropbox.com/s/z8aucsme3z6t3mn/Screenshot%202015-05-04%2009.57.31.png?dl=0
We should check this when we have Arabic in full.
Priority: -- → P3
To build on Comment 1, I don't know that this is too big of a deal.  There are some bidi overrides in AMO's CSS that we should investigate and see if they help, but parenthesis are broken in the same scenario on AMO as well.

Embedding LTR text on an RTL page is just going to hit this corner case and I don't think it's a problem because in the real world we'll have RTL text on RTL pages which works fine (tested on -dev).

Updated

3 years ago
No longer blocks: 1148594

Updated

3 years ago
Blocks: 1148594

Updated

3 years ago
No longer blocks: 1148594

Comment 3

2 years ago
Based on the recently announced future plans for the Marketplace to remove payments, closing these bugs.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.