Closed Bug 1161140 Opened 5 years ago Closed 5 years ago

[OTA] User cannot interact with 'Update Available prompt, inconsistent with other notifications

Categories

(Firefox OS Graveyard :: Gaia::System::Window Mgmt, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v2.0 fixed, b2g-v2.0M fixed, b2g-v2.1 verified, b2g-v2.1S fixed, b2g-v2.2 verified, b2g-master verified)

VERIFIED FIXED
2.2 S12 (15may)
Tracking Status
b2g-v2.0 --- fixed
b2g-v2.0M --- fixed
b2g-v2.1 --- verified
b2g-v2.1S --- fixed
b2g-v2.2 --- verified
b2g-master --- verified

People

(Reporter: onelson, Assigned: etsai)

References

()

Details

(Whiteboard: [3.0-Daily-Testing], [systemsfe])

Attachments

(5 files)

Description:
When a user is notified of a new update available for their device, a prompt will drop down from the top of the screen, while also resting in the user's notification tray. When the notification first appears, the user may try to tap this prompt, but will come to observe that this will have no affect. 


Repro Steps:
1) Update a Flame to 20150501010203
2) Connect to a Wi-Fi network
3) Wait at homescreen for 'Update Available' notification
4) When notification prompts from dropdown, tap the notification

Actual:
No tap event occurs, notification times away and recedes to tray

Expected:
Tap event occurs and the 'Update Request' prompt appears on screen


Environmental Variables:
---------------------------------

Device: Flame 3.0
Build ID: 20150501010203
Gaia: 759a1f935a6a81c32ad66e39a6353b334dfa4f91
Gecko: 7723b15ea695
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

Device: Flame 2.2
BuildID: 20150501002503
Gaia: 209bf4d6fcb16ea6834b8bd86976c012e5914fe6
Gecko: 79e7065ceefa
Gonk: a9f3f8fb8b0844724de32426b7bcc4e6dc4fa2ed
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Device: Flame 2.1
BuildID: 20150501001200
Gaia: b4a03b7ee61de5a479b3cf0916f47e91a43b0f50
Gecko: e488b1448f95
Gonk: a9f3f8fb8b0844724de32426b7bcc4e6dc4fa2ed
Version: 34.0 (2.1) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Device: Flame 2.0
BuildID: 20150501000202
Gaia: 84898cadf28b1a1fcd03b726cff658de470282f0
Gecko: 7df9a0f16261
Gonk: a9f3f8fb8b0844724de32426b7bcc4e6dc4fa2ed
Version: 32.0 (2.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
---------------------------------

Repro frequency: 5/5
See attached: 
video- https://youtu.be/siBeVMcmebA
logcat
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Whiteboard: [3.0-Daily-Testing] → [3.0-Daily-Testing], [systemsfe]
What would be the correct behavior according to spec?
Flags: needinfo?(firefoxos-ux-bugzilla)
NI component owner to make a blocking desicion on this bug once UX responds with expected behaviour for this
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga) → needinfo?(hcheng)
Tapping the prompt should work. This should block.
Flags: needinfo?(firefoxos-ux-bugzilla)
In my opinion, this is a blocker. NI OTA QA owner.
Flags: needinfo?(hcheng) → needinfo?(gchang)
NI UX to check if the behavior is correct or not. Add developer in CC.
Hi Jenny,
Can you help on this?
Flags: needinfo?(gchang) → needinfo?(jelee)
Hi Gerry,

The notification should be tappable. Please refer to spec p.7, thanks!
Flags: needinfo?(jelee)
Hi Eric,
Can you help on this?
Assignee: nobody → etsai
:jelee, tap on toaster is the same as tap on notification? When downloading->cancel download, when uncompressing->ignore tap, like bug 1079244 ? or show download update dialog directly?
Flags: needinfo?(jelee)
Hi Eric,

Per discussion, let's hide the "update available" notification when there's already an update being downloaded/uncompressed, then, after the update process is complete (install complete), show the notification that was hidden before, thanks!
Flags: needinfo?(jelee)
Attachment #8603126 - Flags: review?(alive)
Comment on attachment 8603126 [details] [review]
[gaia] MDTsai:bug1161140 > mozilla-b2g:master

Looks fine, could you add a test in update_manager_test and re-request review? thanks.
Attachment #8603126 - Flags: review?(alive) → feedback+
Comment on attachment 8603126 [details] [review]
[gaia] MDTsai:bug1161140 > mozilla-b2g:master

unit test added
Attachment #8603126 - Flags: feedback+ → review?(alive)
Comment on attachment 8603126 [details] [review]
[gaia] MDTsai:bug1161140 > mozilla-b2g:master

r=me thanks!
Attachment #8603126 - Flags: review?(alive) → review+
Gerry, would you need this for 2.0~2.2? Currently it's for 3.0 only
Status: NEW → ASSIGNED
Flags: needinfo?(gchang)
Keywords: checkin-needed
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Hi Eric,
Yes, we should land this for 2.0~2.2 per spec.
Flags: needinfo?(gchang)
Comment on attachment 8603126 [details] [review]
[gaia] MDTsai:bug1161140 > mozilla-b2g:master

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): this, bug 1161140
User impact if declined: low, user can't tap on notification to show download dialog
Testing completed: local and TPE-QA on m-c
Risk to taking this patch (and alternatives if risky): low, easy to backout
String or UUID changes made by this patch: no
Attachment #8603126 - Flags: approval-mozilla-b2g37?
Attachment #8603126 - Flags: approval-mozilla-b2g34?
Attachment #8603126 - Flags: approval-mozilla-b2g32?
Hi Norry,
please verify on m-c, thanks!
Flags: needinfo?(fan.luo)
This bug has been verified as pass on Flame v2.2.

See attachments: verify_Flamev3.0.MP4
Reproduce rate: 5/5
Device: Flame 3.0 build(Pass)
Build ID               20150520160208
Gaia Revision          b290c77ccb7ab0af599b3d8287b71b9970d8dcb0
Gaia Date              2015-05-20 10:19:05
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/8d8df22fe72d
Gecko Version          41.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150520.192608
Firmware Date          Wed May 20 19:26:18 EDT 2015
Bootloader             L1TC000118D0
Comment on attachment 8603126 [details] [review]
[gaia] MDTsai:bug1161140 > mozilla-b2g:master

Please verify on 2.0, 2.1 and 2.2.
Thanks
Attachment #8603126 - Flags: approval-mozilla-b2g37?
Attachment #8603126 - Flags: approval-mozilla-b2g37+
Attachment #8603126 - Flags: approval-mozilla-b2g34?
Attachment #8603126 - Flags: approval-mozilla-b2g34+
Attachment #8603126 - Flags: approval-mozilla-b2g32?
Attachment #8603126 - Flags: approval-mozilla-b2g32+
Attached video verify.mp4
Per comment 15,comment 16 of bug 1165195.
This bug has been verified as pass on latest build of Flame v2.1/v2.2
STR,
1.Flash device to yesterday‘s build.
2.Modify update Chanel and URL.
3.Check for update.
4.Wait 'Update Available' notification.
5.When notification prompts from dropdown, tap the notification.

Actually Result: Tap event occurs and the 'Update Request' prompt appears on screen.
Reproduce rate: 0/10
See attachment: verify.mp4

Device: Flame v2.1 build(pass)
Build ID               20150601001204
Gaia Revision          2304a1f6327c2ccf35d6995ee16f2231ed1f22a3
Gaia Date              2015-05-26 13:30:41
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/e52807dee101
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150601.035649
Firmware Date          Mon Jun  1 03:57:00 EDT 2015
Bootloader             L1TC000118D0

Device: Flame v2.2 build(pass)
Build ID               20150601002502
Gaia Revision          b4582cc394e0919623263997c0cdb0b4751a1403
Gaia Date              2015-05-31 11:06:34
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/78d8b0a4303d
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150601.040105
Firmware Date          Mon Jun  1 04:01:17 EDT 2015
Bootloader             L1TC000118D0
Flags: needinfo?(fan.luo)
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
Please set bug status as verified and remove verifyme keyword once it has been verified.
Status: RESOLVED → VERIFIED
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.