VITALS/CHECKLIST direct links don't work

RESOLVED FIXED

Status

Websites
Shape of the Web
P2
normal
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: Gregory Jost, Assigned: espressive)

Tracking

Details

(Reporter)

Description

3 years ago
The vital and checklist urls used for sharing don't seem to work for direct access:
- https://shapeoftheweb.mozilla.org/checklist
- https://shapeoftheweb.mozilla.org/vitals

Here is what I get: http://grab.by/GZfA

For now, I think it is fine to use the main url for sharing: https://shapeoftheweb.mozilla.org

Longer term, I believe the expected behavior was as follows:
- website can be entered via any view
- first entry point triggers the info panel to open (except for issue detail pages - no panel here)
(Reporter)

Updated

3 years ago
No longer depends on: 1161159
Priority: P3 → P2
(Assignee)

Updated

3 years ago
Assignee: nobody → schalk.neethling.bugs
Status: NEW → ASSIGNED
(Assignee)

Comment 1

3 years ago
The bug description is not correct here is it?
Flags: needinfo?(gjost)
Summary: Update tabzilla visual → VITALS/CHECKLIST direct links don't work
As Greg noted, we could do a temp workaround by making the "Share URL" = to shapeoftheweb.org without /vitals or /checklist
Flags: needinfo?(gjost)
(Assignee)

Comment 3

3 years ago
spoke to pmac, he had a look and those URLs are working now. Might take a few hours (~2) before it becomes active on shapeoftheweb.m.o
(Assignee)

Comment 4

3 years ago
Thanks pmac!
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Not sure why it changed, but Angular started expecting virtual urls with just a # instead of a #!. i.e. it used to convert shapeoftheweb.m.o/#!vitals to the correct thing, but now only works with shapeoftheweb.m.o/#vitals. These are important because the site is static and there is no "vitals" file, it's a virtual URL. So s3 knows to prepend any files it can't find with "#!" and let the Angular app work it out. I've changed the setting in s3 to only prepend with "#" and it seems to be working. It should work for everyone soon, like Schalk said, the old redirects are cached by the CDN for now.
You need to log in before you can comment on or make changes to this bug.