Setting hidden="false" on <outlinercols> should hide all columns

RESOLVED DUPLICATE of bug 117921

Status

()

Core
XUL
RESOLVED DUPLICATE of bug 117921
17 years ago
10 years ago

People

(Reporter: Håkan Waara, Assigned: David Hyatt)

Tracking

Trunk
Future
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Sometimes you don't want to show the columns in an outliner, so now that we 
have a mandatory <outlinercols> element, it would be useful to be able to set 
hidden="false" on that to hide them all.

Comment 1

17 years ago
Two questions that beg answering:

1. If we were to have such a capability, why would we use hidden="false"?  
False means NOT true.  That statement, if read aloud in English, would be "NOT 
hidden".  In Spanish, "NO ocultado."

2. In what cases do you want to hide all the outliner columns but not hide the 
outliner itself? What would be visible in the outliner if all of its columns 
were hidden?
(Reporter)

Comment 2

17 years ago
Setting hidden on an <outlinercols> would mean that you hid the actual column
_headers_. This is very useful when you don't support any kind of sort, and the
columns headers are just useless... It frees up some space.

Comment 3

17 years ago
The current implementation of outliner body depends on visible column headers.
We need headers to get width and order of columns.

Only workaround I know is to minimize headers height.
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → Future

Comment 4

16 years ago

*** This bug has been marked as a duplicate of 117921 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Updated

10 years ago
Component: XP Toolkit/Widgets: Trees → XUL
QA Contact: jrgmorrison → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.