files downloaded to temp location but never moved

VERIFIED WORKSFORME

Status

Core Graveyard
File Handling
VERIFIED WORKSFORME
17 years ago
2 years ago

People

(Reporter: Lei Ding, Assigned: Bill Law)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
every time I click on a download link(a program, gzip file or anything),
mozilla ask me where to save, BUT no matter what place I enter,
mozilla always saves it to /tmp/foo, where foo is a strange name, such as fn7l3d.gz
Everytime, I have to click the right button the link and choose "Save link
as....", then mozilla could download correctly
It is really anonnying.
Pleae fix it ASAP.
thanks
dupe of bug 69938 ?
Do you just get a filepicker right after clicking on the link?  Or do you get a 
dialog asking you whether to save the file or to open it with a helper?

What build are you using?

Does this affect _all_ files or just gzip files specifically?

What does 'grep gz /etc/mailcap' return?
(Reporter)

Comment 3

17 years ago
Build:
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.5) Gecko/20011013

It affects all files!

result of grep gz /etc/mailcap:
#application/x-wingz; Wingz %s; compose=Wingz %s; \
#
description="Wingz document"; \
#
x11-bitmap="/usr/lib/Zmail/bitmaps/wingz.xbm"
Leu, 0.9.5 is quite old.  There is a good chance that this is alredy fixed.  
Please try 0.9.7?
(Reporter)

Comment 5

17 years ago
Oh yes. I do should try the new one.
But, Do I have to download again this 12mb's huge stuff??!!
Where can I find a patch?
By the way, My name is "Lei" NOT "Leu". :D
Lei, if you have a source tarball you can just update via CVS... But that will 
take longer than downloading a new binary build by far.  There are no patches 
available unless you can find someone to just make one for you.  It will, 
however, require a functioning 0.9.5 tree (a rather large download itself).  
(And the name thing was a typo on my part).

Comment 7

17 years ago
->file handling
Assignee: asa → law
Component: Browser-General → File Handling
QA Contact: doronr → sairuh
(Assignee)

Comment 8

17 years ago
Updating summary.  This must be due to an error when moving the file to the
chosen destination from the temporary download location.
Summary: severe Download problem!!! → files downloaded to temp location but never moved
Lei, could you try a 0.9.8 build and see whether this is still a problem?

Updated

16 years ago
Blocks: 129923

Comment 10

16 years ago
worksforme linux trunk 2002040422

no response from reporter in 4 months -> marking worksforme

reporter, if you are still seeing this with a recent nightly or 0.9.9 please
reopen this bug
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
mass-verifying WorksForMe bugs.

reopen only if this bug is still a problem with a *recent trunk build*.

mail search string for bugspam: AchilleaMillefolium
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.