Closed Bug 1161321 Opened 4 years ago Closed 4 years ago

please add pref to point to PROD pocket servers

Categories

(Firefox :: Pocket, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1161654
Tracking Status
firefox40 --- affected

People

(Reporter: edwong, Unassigned)

References

Details

Logging this to be clear about the hostname value correctly points to PROD server.  pocket prod should be ready to handle this by 5/4 at 10am PDT per bug 1157578

Please add pref to point to PROD pocket server.
user_pref("browser.pocket.hostname", "getpocket.com");
Blocks: Pocket
Hey Ed, 

This is slightly more nuanced for production:

The API calls should go to api.getpocket.com, but the place we look for the cookie should be "getpocket.com"

In pktApi.js, there are two lines that differentiate these: 

var pocketAPIhost = Services.prefs.getCharPref("browser.pocket.hostname");
var pocketCookieHost = Services.prefs.getCharPref("browser.pocket.hostname");

Right now they are the same value but should be different for production:

var pocketAPIhost = Services.prefs.getCharPref("browser.pocket.hostname"); // api.getpocket.com
var pocketCookieHost = Services.prefs.getCharPref("browser.pocket.hostname"); // getpocket.com

Note, it's fine for the Nightly this week if they are both api.getpocket.com (it will work), but before we go into beta, we'd like to separate those out. Thanks!
Pocket prod has been updated to use Prod FxA credentials and confirmed working.
To clarify some of the confusion we're seeing over IRC, here is specifically what needs to change/get updated:

1) api.getpocket.com should be used for the api requests
2) getpocket.com should be used for where the user goes to log-in and where to check for their cookie token.

To handle this, two things need to happen:

1) FF needs to pull in the latest Update from the repo as of last night
2) We need to make a tweak to the hostname preferences. I've outlined those in this pull request here: https://github.com/Pocket/Firefox/pull/28/files

Jaws: I specifically didn't put that into the develop branch yet, but if it's helpful, let me know and I can merge it there.
Also to clarify about #1 above - in that update, we made it so the panel links are built by using the hostname from the preference.
The changes for this bug were pulled in with the patch for bug 1161654
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1161654
You need to log in before you can comment on or make changes to this bug.