[E.me]The menu of add smart collections sometimes need a long time(more than 1 min) to prompt

RESOLVED WONTFIX

Status

defect
RESOLVED WONTFIX
4 years ago
4 years ago

People

(Reporter: mlien, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.1 affected, b2g-v2.2 affected, b2g-master affected)

Details

(Whiteboard: [systemsfe], )

[Build Information]
v2.1:
Build ID               20150420161202
Gaia Revision          bbe983b4e8bebfec26b3726b79568a22d667223c
Gaia Date              2015-04-09 13:52:48
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/b85d4f4a6d61
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150420.195244
Firmware Date          Mon Apr 20 19:52:55 EDT 2015
Bootloader             L1TC000118D0

v2.2:
Build ID               20150503162504
Gaia Revision          8d14361337e608c8cdf165ea5034db5eda23b618
Gaia Date              2015-05-01 18:23:46
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/cb7cb6597c91
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150503.200206
Firmware Date          Sun May  3 20:02:17 EDT 2015
Bootloader             L1TC100118D0

[Steps to Reproduce]
  0. Connect to any WiFi AP
  1. Homescreen -> Long tap background space -> Add Smart Collections
  2. Wait for the menu of smart collection prompt -> OK
  3. Repeat step 1 and step 2

[Expected Results]
The menu of smart collection prompt within a short period

[Actual Results]
Sometimes it needs more than 1 minute to prompt the menu

[Reproduction Frequency]
70%
Duplicate of this bug: 1161446
From bug 1161446, v3.0 also has this problem
Can confirm that this issue occurs on 3.0 for flame devices:
Results: Smart Collection loading may take up to a minute to view collections to add when accessed from homescreen

Device: Flame 3.0
BuildID: 20150507064907
Gaia: 83b27f522642ea573c57e882657ab5c73d4b07f4
Gecko: 403e3c2380b5
Gonk: a9f3f8fb8b0844724de32426b7bcc4e6dc4fa2ed
Version: 40.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

The repro rate of this issue confuses me, sometimes I see it consistently, and others the phone seems to be in a workable state.
There also seems to be no correlation between the type of network connection and the bug occurring: occurs with both a Wi-Fi or Data connection.

video- https://youtu.be/3UmMWf4a8fU
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga)
Whiteboard: [systemsfe]
Mass update: Resolve/Wontfix all existing collections bugs as this feature is now removed.

Please re-open or file a new bug if you feel that this bug still exists in master.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.