[Homescreen]The "Operator message" is truncated.

VERIFIED FIXED in Firefox OS v2.2

Status

VERIFIED FIXED
4 years ago
3 years ago

People

(Reporter: zikui.yang, Assigned: kgrandon)

Tracking

({regression})

unspecified
2.2 S12 (15may)
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: LocRun2.2,)

Attachments

(8 attachments)

(Reporter)

Description

4 years ago
[1.Description]:
[Flame][2.2][Homescreen]Set System language to Portuguese Brazil or Russian,the string "Operator message" in heading is truncated.

Attachment:Portuguese_Brazil_Operator_Message.png and Russian_Operator_Message.png


[2.Testing Steps]: 
Precondnition:Insert SIM card
1.Restart device,make sure the SIM is recognized,then the Operator message page will be shown on screen
(If there is a SIM pin, after entering the SIM pin,the Operator message page will be shown on screen)

[3.Expected Result]: 
1.The "Operator message" should not be truncated.

[4.Actual Result]: 
1.The "Operator message" is truncated.

[5.Reproduction build]: 
Device: Flame 2.1 user Unaffected
Build ID               20150504001200
Gaia Revision          b4a03b7ee61de5a479b3cf0916f47e91a43b0f50
Gaia Date              2015-04-30 21:31:55
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/03bfe12e50d0
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150504.040736
Firmware Date          Mon May  4 04:07:47 EDT 2015
Bootloader             L1TC000118D0

Device: Flame2.2 user  affected
Build ID               20150504002502
Gaia Revision          8d14361337e608c8cdf165ea5034db5eda23b618
Gaia Date              2015-05-01 18:23:46
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/cb7cb6597c91
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150504.041541
Firmware Date          Mon May  4 04:15:53 EDT 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test

[8.Note]:
This issue NOT exist on Spanish ,Serbian Cyrillic,Serbian Latin,Bengali from India,Greek,Polish,Basque,Arabic and Portuguese from Portugal
(Reporter)

Comment 1

4 years ago
Created attachment 8601368 [details]
Portuguese_Brazil_Operator_Message.png
(Reporter)

Comment 2

4 years ago
Created attachment 8601370 [details]
Russian_Operator_Message.png
(Reporter)

Updated

4 years ago
status-b2g-v2.1: --- → unaffected
status-b2g-v2.2: --- → affected
Regression between 2.1 and 2.2 for multiple shipping locales, so blocking 2.2 on this.
Keywords: regression
blocking-b2g: --- → 2.2+

Comment 4

4 years ago
Kevin, could you help on this? thanks.
Flags: needinfo?(kgrandon)
(Assignee)

Comment 5

4 years ago
I am fairly sure this is a gaia components problem, or perhaps the way that gaia-header is implemented in the operator message. Moving to the system component to figure out more.

I'm also not sure how to trigger this to test it, or who's worked on this feature in the past. I would like to ask someone who knows more about this feature.

Needinfo on Julien - I know you've done some work on gaia-header recently, anything come to mind that would cause this?
Component: Gaia::Homescreen → Gaia::System
Flags: needinfo?(kgrandon) → needinfo?(felash)
So you can display these screens using the "operator services" part in Settings. Be careful because most of the services are costly.

Various services yield various screens, you'll need to play to find the right screens. From what I see there are 4 different screens:

* confirmation (the one with the issue here, with back button, and close/OK buttons)
* async confirmation (with yes/no button at the bottom, without back button)
* input (with an input in the middle of the screen, back button, and help button)
* simply view (I couldn't display it but I guess it's simpler)

I wonder if this could come from the fact we don't use gaia-header's action button but a "real" <a> element in [1].

I could try to dig in why gaia-header does not like this, but I think it would be better to just use an `action="back"` attribute and the `action` event.

`action="back"` is already used in [2] and I managed to display this screen and I don't have an ellipsis there.

I also managed to display the failing screen and I can reproduce. I changed the button to `action="back"` and it works better.

So I think there is likely an issue somewhere in gaia-header but we can fix this bug easily by using the action attribute.

[1] https://github.com/mozilla-b2g/gaia/blob/bc5bfa18f795919b56b952bbf3637c235d0e13dc/apps/system/index.html#L1083
[2] https://github.com/mozilla-b2g/gaia/blob/bc5bfa18f795919b56b952bbf3637c235d0e13dc/apps/system/index.html#L1109
Flags: needinfo?(felash)
(Assignee)

Comment 7

4 years ago
Awesome, thanks for the pointers Julien - super detailed/helpful information.

It turns out I don't have this operator services menu, probably because my SIM/plan does not support it. Digging though the code though it's not too hard to trigger this manually through WebIDE by running `icc.confirm('some message')` in the console.

I think that should be enough to debug this, so taking this for now.
Assignee: nobody → kgrandon
Status: NEW → ASSIGNED
Created attachment 8602748 [details] [review]
[gaia] KevinGrandon:bug_1161452_operator_message_header_sizing > mozilla-b2g:master
(Assignee)

Comment 9

4 years ago
Comment on attachment 8602748 [details] [review]
[gaia] KevinGrandon:bug_1161452_operator_message_header_sizing > mozilla-b2g:master

Setting the action="back" seems to fix this.

Manuel - I believe you did some STK work in the past, so I was wondering if you'd like to review this? 

Alternatively, maybe you could give me a review stamp here Alive?

Thanks guys!
Attachment #8602748 - Flags: review?(b.mcb)
Attachment #8602748 - Flags: review?(alive)
Comment on attachment 8602748 [details] [review]
[gaia] KevinGrandon:bug_1161452_operator_message_header_sizing > mozilla-b2g:master

Looks good
Attachment #8602748 - Flags: review?(alive) → review+
(Assignee)

Comment 11

4 years ago
Comment on attachment 8602748 [details] [review]
[gaia] KevinGrandon:bug_1161452_operator_message_header_sizing > mozilla-b2g:master

Thanks!
Attachment #8602748 - Flags: review?(b.mcb)
(Assignee)

Updated

4 years ago
Keywords: checkin-needed

Updated

4 years ago
Keywords: checkin-needed

Updated

4 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Comment hidden (typo)
Comment hidden (typo)
(Reporter)

Comment 15

4 years ago
Hi Delphine
This issue verified successfully on flame 3.0.Verified failed on Flame 2.2,would you please uplift the patch to fix 2.2 branch?
Device: Flame 2.2 user
Build ID               20150517002501
Gaia Revision          b388a235e89dab76c24323767cd87ebd7c4c8b17
Gaia Date              2015-05-15 16:08:41
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/54ae7c7182bc
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150517.041351
Firmware Date          Sun May 17 04:14:01 EDT 2015
Bootloader             L1TC000118D0
Refer to picture       2.2fail0518.png
Flags: needinfo?(lebedel.delphine)
(Reporter)

Comment 16

4 years ago
Created attachment 8606815 [details]
2.2fail0518.png
Comment on attachment 8602748 [details] [review]
[gaia] KevinGrandon:bug_1161452_operator_message_header_sizing > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): none in particular.
[User impact] if declined: the header does not work like the other headers in Gaia.
[Testing completed]: yes, manually. QA will need to especially test whether going back (using the "back" button) works fine, in all ICC dialog flavors (there are 4 of them, we changed one of them here). Quite easy to check with a SIM that supports operator services (in the Settings app).
[Risk to taking this patch] (and alternatives if risky): fairly low because the code is fairly self contained so it's easy to check all the variable name changes. no alternative.
[String changes made]: none
Flags: needinfo?(lebedel.delphine)
Flags: needinfo?(bug.autolander)
Attachment #8602748 - Flags: approval-gaia-v2.2?
Hey Elie, for next time, please ask needinfo from the bug assignee, not the committer :) Thanks !

Updated

4 years ago
Attachment #8602748 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
(Reporter)

Comment 19

4 years ago
(In reply to Julien Wajsberg [:julienw] (PTO May 8th -> May 17th) from comment #18)
> Hey Elie, for next time, please ask needinfo from the bug assignee, not the
> committer :) Thanks !

OK Got it,Thanks.

Comment 20

4 years ago
Comment on attachment 8602748 [details] [review]
[gaia] KevinGrandon:bug_1161452_operator_message_header_sizing > mozilla-b2g:master

Elie,
Please verify after land on 2.2.
Flags: needinfo?(zikui.yang)

Updated

4 years ago
Keywords: verifyme
v2.2: https://github.com/mozilla-b2g/gaia/commit/a1a7258eda809990994a92308c95cbac0f31e577
status-b2g-v2.2: affected → fixed
Target Milestone: --- → 2.2 S12 (15may)
Hi Julien, possible to describe the 4 of them, or point them in the code for us? These commands are not that widely used by asia telecom, some of the new sim cards doesn't have stk in them.

(In reply to Julien Wajsberg [:julienw] (PTO May 8th -> May 17th) from comment #17)
> [Testing completed]: yes, manually. QA will need to especially test whether
> going back (using the "back" button) works fine, in all ICC dialog flavors
> (there are 4 of them, we changed one of them here). Quite easy to check with
> a SIM that supports operator services (in the Settings app).
> [Risk to taking this patch] (and alternatives if risky): fairly low because
> the code is fairly self contained so it's easy to check all the variable
> name changes. no alternative.
> [String changes made]: none
Flags: needinfo?(felash)
You can see the 4 sections in [1].

They're being shown by the code in [2], functions are "alert", "confirm", "asyncConfirm", "input". It's being run by the code in [3].

As the names say it, "alert" is displaying a message with a close button, "confirm" and "asyncConfirm" are asking for a confirmation (I'm not exactly sure of the difference), and "input" is asking for user data.

I'll try to trigger them so that I can attach how they look like on my phone.

[1] https://github.com/mozilla-b2g/gaia/blob/d88c2f98ebdc75f8eb4d54de0ef267f32414618f/apps/system/index.html#L938-L996
[2] https://github.com/mozilla-b2g/gaia/blob/d88c2f98ebdc75f8eb4d54de0ef267f32414618f/apps/system/js/icc.js
[3] https://github.com/mozilla-b2g/gaia/blob/d88c2f98ebdc75f8eb4d54de0ef267f32414618f/apps/system/js/icc_worker.js
Created attachment 8607512 [details]
async confirm
Attachment #8607512 - Attachment description: another confirl → async confirm
I couldn't trigger the "alert" type with my SIM.
Flags: needinfo?(felash)

Comment 28

4 years ago
Created attachment 8607894 [details]
Verify picture: Verify1_Portuguese Brazil&Russian_Flame2.2_Pass.png

This issue has been verified successfully on Flame2.2.
See attachment: "Verify1_Portuguese Brazil&Russian_Flame2.2_Pass.png"

Device: Flame 2.2 user(Pass)
Build ID               20150519002500
Gaia Revision          732acec6f37d13ccea6b0ddc48904a53a2970894
Gaia Date              2015-05-19 06:24:24
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/1389e6b8c065
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150519.035525
Firmware Date          Tue May 19 03:55:36 EDT 2015
Bootloader             L1TC000118D0
Flags: needinfo?(zikui.yang)

Updated

4 years ago
Status: RESOLVED → VERIFIED
status-b2g-v2.2: fixed → verified
Keywords: verifyme
Thanks Julien, let me add this to QA backlog for creating new test cases.

(In reply to Julien Wajsberg [:julienw] (PTO May 8th -> May 17th) from comment #23)
> You can see the 4 sections in [1].
> 
> They're being shown by the code in [2], functions are "alert", "confirm",
> "asyncConfirm", "input". It's being run by the code in [3].
> 
> As the names say it, "alert" is displaying a message with a close button,
> "confirm" and "asyncConfirm" are asking for a confirmation (I'm not exactly
> sure of the difference), and "input" is asking for user data.
> 
> I'll try to trigger them so that I can attach how they look like on my phone.
> 
> [1]
> https://github.com/mozilla-b2g/gaia/blob/
> d88c2f98ebdc75f8eb4d54de0ef267f32414618f/apps/system/index.html#L938-L996
> [2]
> https://github.com/mozilla-b2g/gaia/blob/
> d88c2f98ebdc75f8eb4d54de0ef267f32414618f/apps/system/js/icc.js
> [3]
> https://github.com/mozilla-b2g/gaia/blob/
> d88c2f98ebdc75f8eb4d54de0ef267f32414618f/apps/system/js/icc_worker.js
QA Whiteboard: [MGSEI-l10n-1F]
Whiteboard: LocRun2.2,MGSEI-l10n-1F-Portuguese Brazil → LocRun2.2,
You need to log in before you can comment on or make changes to this bug.